DVD-Laufwerk an HiPower-USB-Anschluss vom StromPi 2 wird beim Booten nicht erkannt

  • Moin die Herrschaften,


    gerade habe ich ein USB-DVD-Laufwerk (eigentlich ein Brenner, doch als solchen werde ich ihn nicht benützen) Marke NoName an meinen Raspi 3B gestöpselt. Wegen des niedrigen USB-Ausgangsstroms vom Raspi musste ich das Teil an die HiPower-USB-Buchse der StromPi-USV anschließen — und habe nun ein seltsames Problem: Beim Booten wird das Laufwerk nicht erkannt! Die Gerätedatei /dev/sr0 fehlt. :@ Erst, wenn ich das Laufwerk aus- und wieder anstecke, wird es vom Raspi «gerochen».


    UPDATE: Auch im laufenden Betrieb scheint sich das Laufwerk einfach zu verabschieden. Krude Systemmeldungen suggerieren das:



    Da das auf Dauer kein tragbarer Zustand ist (das ganze System soll mal in ein Auto verbaut werden), würde ich mal gerne wissen, wie diesem Makel abzuhelfen sei. Danke für jeden Tipp, der zur Lösung dieses Ärgernisses führt!

    Edited once, last by Oldsmobile: Ausgabe von dmesg ().

  • Zuerst würde ich einmal den Stromverbrauch am DVD-RW USB Player ablesen. Wahrscheinlich nur über externen USB Hub verwendbar.



    Servus !

    RTFM = Read The Factory Manual, oder so

  • Das externe DVD-Laufwerk für USB-Anschluss in meinem Raspiblaster (LG GP50NW40) läuft an einem RPi3B einwandfrei. Das Laufwerk ist jedoch kein direktes NoName-Gerät, sondern eben immerhin ein LG (auch wenn das alles Chinaware ist, egal welche Marke draufsteht). Die Spannungsversorgung des RPi erfolgt dabei direkt über die 5V-Pins an der GPIO-Leiste und nicht über die µUSB-Buchse! Das Netzteil ist ein MeanWell RS25-5 (5V, 25W), mit dem auch andere gute Erfahrungen haben.

    Laut Gehäusebeschriftung nimmt das LG-Laufwerk max. 1,6A bei 5V, siehe Abbildungen in Beitrag #25.


    Wenn es bei Deinem Laufwerk USB-Probleme gibt, würde ich zuerst die Versorgung des RPi auf absolut stabile Füße stellen: Vernünftiges Netzteil (siehe oben), nicht mit dem windigsten µUSB-Kabel auf die Versorgungsbuchse des RPi gehen, sondern mit eher 5,1V auf die GPIO-Pins.

    Wenn weiterhin Probleme bestehen, kann man am USB-Anschluss zwischen RPi und USB-Laufwerk die rote Leitung (5V-Pin am USB) auftrennen und von einer kräftigen 5V-Quelle einspeisen. Der RPi muss dann die 5V nicht mehr liefern. Die anderen drei Leitungen (Masse und Daten+/-) nicht anfassen!


    Mir drängt sich irgendwie der Verdacht auf, dass Du neben dem Versorgungsproblem auch ein Masseproblem haben könntest (An- und Abmelden des USB-Laufwerks mittendrin, eines von vielen Phänomenen des Mysteriums®). Ganz windige USB-Kabel haben ganz dünne Litzen, bei denen je nach Länge schnell ein paarhundert Millivolt als Spannungsabfall flöten gehen, den Du dann als Sondermüll auf den Wertstoffhof bringen musst. Die Originalkabel von den USB-Laufwerken sind nicht umsonst etwas dicker und haben bisweilen zwei USB-A-Stecker...

  • Genau zwecks stabiler Stromversorgung habe ich den StromPi ja verbaut. ;) Messungen mit einem USB-Multimeter zeigen Stromstärken bis zu 600 mA (Dauerstrom: 300 mA) an. Die Spannung (im Ruhezustand: 5,03 V) sinkt dabei auf 4,67 V und manchmal sogar auf 4,33 V. Und der StromPi liefert angeblich 3 A via USB. Die USB-2.0-Spezifikation spricht von 500 mA bei min. 4,75 V. Seltsam, nicht?


    Das NT (das freilich am StromPi hängt und nicht direkt am Pi) ist auch NoName, doch hatte ich damit bisher keine Probleme. Im Auto herrschen eh andere Verhältnisse: Da hat man zwei (eher instabile) 12-V-Schienen (Zündung & Standby) und muss sie mit einem DC-/DC-Wandler erst mal auf +5 V runterregeln. Das Laufwerk wird, weil es in die Mittelkonsole verbaut wird, eh einen eigenen Regler bekommen. Dann werde ich lediglich ein Y-Kabel brauchen, mit dem ich den extra Saft vom Wandler ins Laufwerk einspeisen kann.

    Edited once, last by Oldsmobile: Der alte Wert galt für den alten StromPi. ().

  • Moglicherweise ist das StromPi kaputt. Eigentlich sollte der extra-USB-Anschluss ja funktionieren, zumindest als Stromquelle. Die Datenleitungen sind ja per default nicht angeschlossen. Das macht aber nix, wenn Du von dem Y-Kabel nur den Zusatz-Anschluss verwendest und den anderen normal in den Pi steckst. ALso normalerweise(!) sollte das auch keine Ground-loop geben, da StromPi ground mit dem Raspberry Pi ground verbinden ist. Aber es kann natuerlich was kaputt sein. Dass die Spannung so weitruntergeht ist komisch (und grenzwertig). Vielleicht ist auch das Kabel kaputt.... Miss doch mal den Widerstand.

  • Blöd nur, dass das (keine 30 cm lange) Kabel fest mit dem Laufwerk verbunden ist und daher auch nicht durchgemessen werden kann. Nicht mal das Gehäuse öffnen kann ich! :@Das NT, das am StromPi hängt, gibt übrigens (offiziell zumindest) 3 A her.

  • Da das Netzteil, aus dem der StromPi die 5V macht, ja eine höhere Spannung haben muss (richtig?), sollten 3A dann bei der höheren Spannung ausreichen, also 3A bei 12V sollten für 5A bei 5V reichen (theoretisch).

  • Nä, nicht ganz! Das NT liefert 5 V / 3 A (also 15 W) an den µUSB-Anschluss vom StromPi. Diese 3 A müssen sich derzeit der Pi (800 mA), die Soundkarte, das Laufwerk (600 mA) und das GPS-Modul teilen. Weitere Peripheriegeräte (vorläufig nur das (mit 650 mA recht durstige) Display) hänge ich aber an ein separates 12-Volt-NT + DC-/DC-Wandler, der daraus 5 V macht. Im Auto gibt's ja nur 12 V, drum werde ich einen Ausgang des Wandlers mit einem µUSB-Anschluss ausrüsten und diesen hernach in den StromPi stecken. Der Wide-Anschluss nimmt dann die Backup-Batterie auf, damit der Pi nicht sofort abkratzt, sollte mal die Batterie keinen Saft mehr liefern.


    UPDATE: Nach ein wenig einschlägiger Lektüre deucht mir langsam, das µUSB-Netzteil könnte der Urheber allen Übels sein. Weiß da jemand genaueres?

  • Wie wend schon sagte: Das Netzteil für den StromPi muss auf jeden Fall eine höhere Spannung als 5V liefern! Die USV (StromPi) macht daraus stabile 5V. Dazu benötigt sie aber eine etwas höhere Spannung (vermutlich mind. 7V oder so, siehe Datenblatt). Außerdem entsteht in jedem Modul zwischen Netzteil und RPi eine Verlustleistung, die das Netzteil zusätzlich bereitstellen muss.

    So wie Du das beschreibst und (derzeit?) in Betrieb hast, wird das nix! Siehe obige Beiträge! Wenn das Gespiel später ins Auto soll, suchst Du Dir wegen Deiner ganzen Peripherie (CD-Laufwerk, Display, ...) am besten einen DC/DC-Wandler, der bei 5V stabil eher 5A als 3A liefern kann...

    Eine USV wie StromPi ist prinzipiell schon sinnvoll, aber dann sollte auch alles drüberlaufen und kein Gewurstel mit StromPi + separaten DC/DC-Wandler + wasweißich verbaut werden, das später womöglich noch die Autobatterie leersäuft. Bringt der StromPi für Deine gesamte Konfiguration die notwendige Leistung?

  • @schlitzbäda: Du meinst wohl den Wide-Eingang des StromPi, ja? Soll dieser als USV dienen, wird er im Normalfall über den µUSB-Anschluss mit 5 V versorgt. An den Wide-Anschluss kommen die Anschlüsse der 9-Volt-Batterie, welche dann als Puffer dient, sollte die Autobatterie nicht genügend Strom liefern. Das suggeriert zumindest die Anleitung. Oder verstehe ich da was falsch? :/


    Soweit ich das ermitteln kann, müsste der StromPi (3 A) die Stromaufnahme der ganzen Geräte verkraften. Aber: Das Blöde bei den Wandlern ist halt, dass das Laufwerk in die Mittelkonsole und damit in einen völlig anderen Einbauplatz kommt als der Pi mitsamt Display, Tastatur und dem ganzen Kram. Da unten habe ich 12 V zur Verfügung, ansonsten müsste ich eine Ader der nach unten verlaufenden Kabelstränge für 5 V zweckentfremden. Dann hätte ich aber das Ärgernis mit dem Spannungsabfall, das mich jetzt schon verfolgt.


    Für die Autobatterie wird's gefährlich, wenn man den kompletten Saft über die 12-V-Standby-Schiene zieht. Dann kann es tatsächlich passieren, dass, wenn ein Verbraucher zu viel Strom schluckt (bei mir war's mal eine hinnige Alarmanlage, bei der ein geiziger Vorbesitzer einfach die Sirene abgeklemmt hat, damit sie Ruhe gibt), irgendwann der Akku draufgeht und überbrückt werden muss.


    Das NT habe ich übrigens von einem Händler in der Nähe. Da habe ich ausdrücklich nach einem Netzteil für den Pi verlangt. Ist das «offizielle» Pi-NT dieses hier (liefert aber nur 2,5 A)?

    Edited 2 times, last by Oldsmobile: Netzteil ().

  • Servus Oldsmobile,


    Den StromPi kannte ich bisher nicht näher aber ich interpretiere die Bedienungsanleitung ähnlich. Daher muss ich meine obige Aussage zumindest relativieren:

    Offenbar schaltet der StromPi die 5V am USB-Anschluss "in", die z.B. von einem 5V-Netzteil kommt, direkt zum angesteckten RPi weiter. Sollte die Spannung an der "in"-Buchse fehlen, schaltet er unterbrechungsfrei auf den Wide-Eingang um. Die maximal lieferbare Stromstäke beträgt dabei laut joy-it-Beschreibung 2A, selbst wenn Dein Netzteil bis zu 3A liefern könnte. Gleiches gilt vermutlich (ziemlich sicher) für den "WIDE"-Eingang, denn der Spannungswandler und die Halbleiter-Umschalter (MOSFETs?) für "in" und "WIDE" haben eben eine Obergrenze von 2A bzw. 10W.

    Wo der StromPi dann die Leistungsreserven für den "High-Power-USB" herzaubert, kann ich jetzt so nicht beurteilen. (Nicht nur) das ist in der Anleitung (bewusst?) etwas schwammig beschrieben.


    Auf den ersten Blick stört mich am Konzept vom StromPi die Verwendung der µUSB-Buchsen für die doch recht beachtliche Leistungsaufnahme (5V * 2A = 10W). Das ist am RPi selbst schon shice und für den StromPi wurde es zumindest für die "normale" Versorgungsbuchse kritiklos übernommen. Selbst wenn die µUSB-Buchsen dafür gerade so ausgelegt sind, kommt noch das konkret verwendete USB-A auf µUSB-Kabel zum Tragen: Da gibt es eben auch Qualitäts- bzw. Leistungsunterschiede hinsichtlich der Aderquerschnitte.

    Wenn Du das später (möglicherweise schwer zugänglich) ins Auto einbaust, würde ich darüber nachdenken, am StromPi die "in"-Buchse durch fest angelötete, ausreichend dicke (da reichen vermutlich echte 0,5mm²) Versorgungslitzen zu ersetzen oder über einen lötbaren µUSB-Stecker zu kontaktieren.

    Ferner glaube ich, dass der StromPi vom Konzept her für Deinen Anwendungsfall nicht optimal ist, da der "in"-Eingang (Standardeingang) offenbar nur für ein 5V-Netzteil ausgelegt ist. Wenn Du ausschließlich am "WIDE"-Eingang die 12V vom Auto anschließt, ist die USV-Funktionalität weg und du benötigst u.U. sogar einen separaten Ein-/Aus-Schalter, damit die Batterie im Stand nicht leergesaugt wird. Ich würde daher eher zur S.USV pi advanced (Achtung: relativ teuer) oder etwas Artverwandtem (Pi-USV) tendieren. EDIT1: Dann aber mit 12V-Zündplus!

    EDIT2: Jetzt verstehe ich vermutlich auch, warum Du neben dem StromPi noch einen DC/DC-Wandler einbauen willst: Damit willst Du wohl die 12V von der Autobatterie an die 5V der "in"-buchse anpassen. Bei Versorgung über Zündplus wäre das sogar eine sichere Lösung gegen eine leere Autobatterie, wenn denn die max. 80µA Standby-Strom des StromPi stimmen. Über den "Wide"-Eingang könnte man dann den RPi noch solange versorgen, bis er sauber heruntergefahren ist...

    Hier ein älterer Artikel aus der c't von 2015 zum Thema USV am RPi.

    PS:

    Dein örtlicher Händer, der Dir das für den RPi3 an sich ausreichende 3A-Netzeil verkaufte, wusste ja vermutlich nicht, dass Du zusätzlich den StromPi einbauen willst.


    Zur Einbausituation im Auto:

    Ich weiß ja nicht, wo Du den RPi im Auto montieren willst. Für das CD-Laufwerk hast Du ja offensichtlich irgendwo in der Mittelkonsole einen Einbauplatz gefunden. Der RPi soll ja vermutlich das Originalradio ersetzen. Passt der RPi bzw. dessen Display dort nicht rein?

    Neuere Fahrzeuge haben ja oft Doppel-DIN-Schächte, wo 12V sowohl als Dauerplus als auch über das Zündschloss geschaltet vorhanden sein dürften.

    Auf jeden Fall musst Du ja ohnehin vom RPi zum Laufwerk ein USB-Verlängerungskabel verlegen. Zu diesem Kabel kannst Du ja daneben eine vernünftige zweiadrige und je nach Länge ausreichend dicke und ggf. nochmals ummantelte 5V-Leitung für die Versorgung des Laufwerks verlegen. Oder die Versorgungsleitungen des USB-Verlängerungskabels im Eigenbau entsprechend pimpen, um den Spannungsabfall im USB-Laufwerk im Rahmen zu halten.


    Ich hoffe, Dich jetzt nicht zu arg vollgetextet zu haben.

    schlizbäda

  • Was den Einbau angeht, lasse ich hier mal ein Bild sprechen:


    [Blocked Image: https://lh3.googleusercontent.com/VW11PvtBFGVxPkCqz1AQCw9_sIS203ieHp2heFa-eFy68zw-eCIN-RnDcj8KmaK78Pzb-rD-1lGWnS2SHLftE4SEIi9k5EWAw6VfU11sB9SNOiUCFP5Xi96CUsiy5IjgC_IDBzYLls7CZIFxISysysIzkmvs9bfqYKft4mGgi-fYbmdaxoXNmmtvdCJUpMDBv9Iz1EUOZPvuQpiatLNKMeMwaQgIA6C38AtATyx3X9kLs4ocb5pyuRflu8X3OqaNzUcGEV0fY_DabiwLM4pj7a1OOC0GPyMSqCm5_ZI-dMARwHgZ1nJp-Qq_vKlCelWwR07QF9WLWNsjNlvlzlKg73EVPg7KJj6xQHywLiXijTC-y86TPFR2sPpS_kGpjgFvtNYhkVIdtC_9c5Y9WrvvRTUpIoqWdsAHSnoffjCf67V850q1yUF0PIO7tlZgdnPSndHsm_MxPzOJEslA7dgYq3_3dMkhjfXSDCDnvseG07w-8fFBLtFhXqeuYYK1s3eiODlFLXk5IUNC36rN5jQD8jCfQ6RySX9yyR2MLRXhhI_o27pXZOwvQAB03p6FUi3Vgjf8Bwyky41XZ4sFWA4Z1MsgS-oCr-OzzQyHEpOei7WrRRTrbkEU-hW_gYiROTHPiZginOLysEeWqZ92GT9JvXTKLyh00aMRQQ=w1426-h949-no]


    Rechts unten liegt die Mittelkonsole. Das Kassettendeck oben (hinterm Wählhebel) fliegt raus. Dort kommt u.a. das Laufwerk rein. Rechts vom Lenkrad befindet sich das alte Radio. Dort soll der Pi mitsamt Tastatur und Display rein. Das ist leider kein Doppel-DIN-Schacht, sondern etwas Proprietäres, in das nicht mal die Radios jüngerer Autos der gleichen Marke reinpassen. Drum kommt der Pi in das entleerte Gehäuse vom alten Radio. Ein ganzes Bündel Kabel verläuft vom Radio runter zur Konsole, um Equalizer und Kassettendeck zu versorgen. Ein paar Adern davon könnte ich für den USB-Anschluss des Laufwerks abzweigen. Der fahrzeugseitige Kabelbaum ist auch nicht standardkonform, doch dafür habe ich schon eine Lösung. Eine Frontplatte müsste ich noch machen lassen. Dazu aber später mehr.


    schlizbäda: Genau das ist es! Der StromPi soll als USV für den Fall dienen, dass den Akku der Teufel holen sollte. Ansonsten hängt der Pi am Dauerplus und ist daher ständig einsatzbereit. Lediglich Sachen wie Display oder Laufwerk müssen nur am Zündungsplus hängen. Und nein, Du hast mich nicht zugespammt. :)


    Den c't-Artikel habe ich schon gelesen und mich genau deswegen für den StromPi entschieden. Der µUSB-Eingang (5 V) vom StromPi wird über den DC-/DC-Wandler am Dauerplus hängen. Fürs Laufwerk und das Display bräuchte ich dann einen zweiten Wandler am Zündungsplus. Die Tastatur wird erst entsperrt, wenn übers Zündungsplus Saft reinkommt. Und was die Buchsen angeht, muss ich noch darüber nachdenken, wie ich sie erschütterungssicher hinkriege, denn Radio tauschen ist hier leider nicht mit ein paar Steckverbindungen getan, sondern da muss schon das halbe Armaturenbrett auseinandergebaut werden.

  • Hi Oldsmobile,


    Geile Karre was Du da hast :thumbup:Ähm, was ist denn das genau für ein Modell? Irgendein Ami, aber da bin ich als kleiner Fiatfahrer (X1/9 und Lancia Delta GT i.e.) leider nicht so firm :blush: Jedenfalls historsich (80er-Jahre?) und dennoch richtig futuristisch. Daher rührt also Dein Foren-Nickname her!


    Der StromPi soll als USV für den Fall dienen, dass den Akku der Teufel holen sollte. Ansonsten hängt der Pi am Dauerplus und ist daher ständig einsatzbereit. Lediglich Sachen wie Display oder Laufwerk müssen nur am Zündungsplus hängen.


    Der µUSB-Eingang (5 V) vom StromPi wird über den DC-/DC-Wandler am Dauerplus hängen.

    Dein Konzept sehe ich problematisch (es sei denn, ich verstehe es gerade komplett falsch):

    1. Wenn ich nicht falsch liege, dient die µUSB-Buchse der StromPi-USV zur "normalen" Versorgung eines 24/7-RPi über ein Netzteil am 230V-Stromnetz. So ein RPi zieht im "Idle"-Betrieb (selbst wenn die ganze Peripherie ausgeschaltet ist) wohl schnell mal 200-500mA (nur geschätzt), auf jeden Fall zu viel, um eine Autobatterie damit im Stand zu belasten. Schon nach einem oder zwei Tagen dürfte damit die Autobatterie so weit leer sein, dass ein Anlassversuch fehlschlägt. Dies ist gerade bei Deinem Fahrzeug ein Problem, da es wohl kein Alltagsfahrzeug ist und schnell mal eine Woche/ein Monat in der Garage steht und die Batterie somit durch die Lichtmaschine nicht nachgeladen wird.

    2. Wenn der StromPi auf den Wide-Eingang umschaltet, weil am µUSB die Spannung fehlt, hat Dein Aufbau die Batterie schon leergesaugt! Da ist es schon zu spät.

    3. Selbst wenn Du den RPi herunterfährst, brennt zumindest noch dessen rote Power-LED und die zieht auch ein paar mA. Was weiß ich, was am RPi im Standby/Stutdown sonst noch für Bausteine so laufen. Der zusätzliche DC/DC-Wandler (12V-->5V) benötigt auch noch seine eigene (Verlust-)Leistung (und läuft wegen des Dauerplus-Anschlusses ständig). 100mA kommen auch da schnell zusammen. Die prinzipielle Entladeproblematik aus Punkt 1 trifft auch hier zu.

    4. die max. 80µA am Wide-Eingang werden (von einer zweiten Stützbatterie) gezogen, wenn die (Standard-)Versorgung über den µUSB-Eingang läuft (und Letzteres leert Deine Autobatterie). Der heruntergefahrene RPi zieht jedenfalls immer im zwei- bis dreistelligen Milliampere-Bereich! Außerdem kommt die Umschaltung auf Wide nicht zustande, da ja der DC/DC-Wandler den StromPi über die µUSB-Buchse versorgt.


    Wenn Du der Sache nicht komplett die Stromzufuhr wegnimmst (und sei es elektronisch mit einem Taster, der dem RPi ggf. vorher noch über eine Ausschaltverzögerung (10-15s, z.B. mit einem NE555) und ein Shutdown-Signal an einem GPIO Zeit zum sauberen Herunterfahren gibt), sehe ich für Deinen nächsten Ausflug auf ein Oldtimertreffen schwarz...

    Eventuell müsste man sich da etwas ganz anderes überlegen. Aber dazu müsste man auch relativ konkret das softwaretechnische Konzept bzw. Deine (softwaremäßigen) Ansprüche hinsichtlich Komfort etc. kennen. In meinen X1/9 habe ich ein zeitgenössisches Autoradio (Blaupunkt Heilbronn SQ26) eingabaut und am Cassettendeck einen Klinkeneingang dazugeschwindelt, um neumoderne MP3-Player oder auch RPis anschließen zu können. Eine sehr billige Lösung, die aber ausbaufähig ist und einen Festeinbau eines RPi samt Zubehör theoretisch zuließe.

  • Genauer gesagt: Es ist ein 1987er Oldsmobile Toronado Troféo. Siehe hier. Das ist übrigens tatsächlich meine Alltags-Möhre. Sollte sie aber für mehr als eine Woche außer Betrieb sein, klemme ich einfach den Akku ab (machen viele andere Oldie-Besitzer ja auch).


    Derzeit hängt der Pi über den µUSB des StromPi am 230-V-Stromnetz. Im Auto wird er an einem DC-/DC-Wandler hängen und dieser wiederum am Dauerplus. Den Wide-Anschluss des StromPi wird eine Pufferbatterie (9-V-Block) versorgen, und die wird wirklich nur dazu dienen, genügend Strom zum Herunterfahren des Pis zu liefern, sollte mal der Akku aussetzen. Vom StromPi versorgt (und damit vom Dauerplus) werden nur der Pi und alles, was direkt am Pi hängt (Tuner, Soundkarte, GPS-Modul, TMC-Modul). Was den Saft nicht vom Pi zieht, hängt an einem zweiten Wandler und dieser wiederum am Zündungsplus, und das sind das VF-Display, das CD-Laufwerk und natürlich die beiden Verstärker (wegen 4 Lautsprechern).


    Den Shutdown übernimmt ein Python-Skript von den StromPi-Machern, das man nur aufsetzen muss. Ich stelle es so ein, dass es für vielleicht 15" einen Batteriebetrieb des Pi ermöglicht (falls der Akku kurzfristig aussetzt) und ihm dann via GPIO-Pin den Befehl zum Runterfahren gibt.


    Es ist übrigens nicht nur die Stromversorgung, die mir Migräne bereitet, sondern auch thermische Aspekte: Vom alten Radio habe ich zwei Kühlkörper für die Verstärker retten können. Zusätzlich befinden sich Luftschlitze an der Oberseite des Armaturenbretts, doch der Pi erzeugt sicher deutlich mehr Abwärme als das alte Radio.


    Das mit einem «zeitgenössischen» Radio schied bei mir leider aus, weil da schon rein mechanisch nur Originalradios reinpassen. Sogar Geräte von späteren GM-Autos (der Toronado wurde 1992 leider eingestampft) lassen sich bei mir gar nicht mehr einbauen, vom Kassettendeck ganz zu schweigen. Es ist das gleiche Drama wie bei viele heutigen Autos auch. Und reparieren konnte mein kaputtes Teil auch keiner, weil wohl einer der ASICs flöten gegangen war. Leider! :(

    Edited once, last by Oldsmobile: typo ().

  • doch der Pi erzeugt sicher deutlich mehr Abwärme als das alte Radio.

    dafür gibt es Vollalu Gehäuse mit "Kühlfinger" aber ein PI im PKW ist vermutlich nicht bei 60°C Umgebung lauffähig, OK der Mensch mag das auch nicht und steigt erst nach Luftaustausch ein.


    Den PI im Vollalu könnte man mit größere Rippenkühlkörper noch aufpimpen


    mehr Abwärme? bei begrenzten 2,5A und 5V gibt das 12,5W ich denke manche Radios brauchen mehr, so sind diese doch eher an 12V mit 5A abgesichert also 60W

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

  • Genauer gesagt: Es ist ein 1987er Oldsmobile Toronado Troféo. Siehe hier. Das ist übrigens tatsächlich meine Alltags-Möhre.

    ...aber dann hoffentlich gescheit hohlraumversiegelt und am Unterboden vernünftig behandelt, dass ihn im Winter das Streusalz nicht gar so herfrisst. Oder alternativ ein Winterauto, um das es nicht schade ist...


    Im Auto wird er an einem DC-/DC-Wandler hängen und dieser wiederum am Dauerplus. Den Wide-Anschluss des StromPi wird eine Pufferbatterie (9-V-Block) versorgen, und die wird wirklich nur dazu dienen, genügend Strom zum Herunterfahren des Pis zu liefern, sollte mal der Akku aussetzen. Vom StromPi versorgt (und damit vom Dauerplus) werden nur der Pi und alles, was direkt am Pi hängt (Tuner, Soundkarte, GPS-Modul, TMC-Modul). Was den Saft nicht vom Pi zieht, hängt an einem zweiten Wandler und dieser wiederum am Zündungsplus, und das sind das VF-Display, das CD-Laufwerk und natürlich die beiden Verstärker (wegen 4 Lautsprechern).


    Den Shutdown übernimmt ein Python-Skript von den StromPi-Machern, das man nur aufsetzen muss. Ich stelle es so ein, dass es für vielleicht 15" einen Batteriebetrieb des Pi ermöglicht (falls der Akku kurzfristig aussetzt) und ihm dann via GPIO-Pin den Befehl zum Runterfahren gibt.

    Also das mit dem nicht abschaltbaren DC/DC-Wandler am Dauerplus stimmt mich nach wie vor bedenklich. Auch wenn ich nicht genau weiß, wieviel Watt ein heruntergefahrener aber nicht von der Stromversorgung getrennter RPi sich tatsächlich gönnt, würde ich dem Frieden nicht trauen. Ich hatte mal ein Sony CarHifi-System mit Radio, CD-Wechsler und externem DSP-Signalprozessor (um 1996 ein absolutes High-End-Gerät), die alle über den proprietären Sony-Unilink-Bus verbunden waren. Um 1996 lief es mit dem ersten Sony-Radio problemlos, 2004/2005 mit einem neuen Sony-Radio (im neuen Auto) leider nicht mehr: Das ganze System fuhr beim Ausschalten der Anlage nicht sauber herunter, die Kommunikation an diesem Bus lief irgendwie weiter und zog ca. 160mA. Es waren definitiv die Sony-Komponenten am relativ dünnen Radiopluskabel und nicht die Endstufen an den 20mm²-Kabeln. Schon am nächsten Tag war die Batterie schwächlich und nach zwei bis drei Tagen sprang das Auto nicht mehr an.

    Ich hoffe, dass Dir mit Deiner Konstruktion dieses Schicksal erspart bleibt!

  • Im Auto wird er an einem DC-/DC-Wandler hängen und dieser wiederum am Dauerplus

    dieses Design hat meinen ersten selbst gebauten FotoTimer das Genick gebrochen, der hat immer innerhalb einer Woche die Akkus leergelutscht obwohl der Atmel geschlafen hat!


    Wenn dann muss der Wandler auch getrennt werden, gestartet weden kann kann mit einem Startimpuls aus Zündung an oder Garagenstellung so wie man halt auch ein Radio betreibt.

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)