Datei- und Ordnerfreigabe mit Samba (Rechte..)

  • Guten Tag,


    ich versuche schon seit gestern, ein NAS mit meinem Raspberry Pi aufzusezten. Dazu möchte ich Samba benutzen. Ich habe dazu mehrere Tutorials befolgt, bei mir funktioniert es aber immer nicht. ;(

    Zum Probieren habe ich erstmal einen 32-GB USB-Stick (fat-32) an den Pi angeschlossen und unter /media/hdd1/ gemountet. Einen Eintrag in fstab habe ich ebenfalls vorgenommen.

    Da habe ich einen Ordner share erstellt, unter dem dann die Dateien liegen sollen.

    Dann habe ich samba mittels

    Code
    sudo apt-get install samba samba-common-bin

    installiert.


    Ich habe die smb.conf-Datei wie folgt modifiziert:

    Als nächstes habe ich mit

    Code
    sudo useradd nas -m -G users
    sudo passwd nas

    den Benutzer nas hinzugefügt und dessen Passwort gesetzt und dann diesen mit

    Code
    sudo smbpasswd -a nas

    samba hinzugefügt.


    Dann einmal neugestartet, im Windows \\ip eingegeben. Dann habe ich bei Nutzer nas, bei Passwort mein Passwort eingegeben.

    Doch ich bekomme eine Fehlermeldung:


    Auf \\ip kann nicht zugegriffen werden. Sie haben eventuell keine Berechtigung, diese Netzwerkressource zu verwenden. Wenden Sie sich an den Administrator des Servers, um herauszufinden, ob Sie über Berechtigungen verfügen.


    Was stimmt mit den Rechten nicht? Muss ich für /media/hdd1/share den Besitzer nas setzten, oder was mache ich falsch?



    Vielen Dank im Voraus!

  • Was stimmt mit den Rechten nicht? Muss ich für /media/hdd1/share den Besitzer nas setzten, oder was mache ich falsch?

    Hallo raspberry_sch,


    das wohl nicht, aber darf der Nutzer "nas" lokal auf /media/hdd1/share lesen/schreiben? Was sind die Ausgaben der folgenden Befehle auf Deinem Pi?


    Code
    ls -l /media/hdd1
    ls -l /media/hdd1/share


    Grüße, STF

  • Hi STF,


    ls -l /media/hdd1/share gibt:

    Code
    pi@raspberrypi:~ $ ls -l /media/hdd1/share
    insgesamt 16
    drwxr-xr-x 2 root root 16384 Jun 18 18:37 backup


    raspberry_sch

  • Vergib mal die Rechte so, dass die Gruppe "users" auch auf /media/hdd1.... zugreifen darf. Näheres über Rechte u.a. hier. Testweise kannst Du natürlich "users" den Ordner übernehmen lassen.


    IMHO braucht "nas" die Rechte nicht.

    Doch. Kannste lokal mit "nas" nicht schreiben, gehts auch über samba nicht.

    warum zerhackt ihr nur immer eure smb.conf? :conf:

    Bitte? Er hat doch nur die neuen Einträge unten angehängt, der Rest sieht aus wie die Standardkonfiguration. Völlig OK. Finde ich.:)

  • Vergib mal die Rechte so, dass die Gruppe "users" auch auf /media/hdd1.... zugreifen darf. Näheres über Rechte u.a. hier. Testweise kannst Du natürlich "users" den Ordner übernehmen lassen.

    Ihr habt Recht:

    Ich hab mal geschaut. Ich kann weder mit nutzer pi noch Nutzer nas lokal schreiben.


    Rechte ändern - Wie muss ich das in dem Fall machen?

    chown oder chmod?


    sudo chmod -R 777 /media/hdd1/share/ hab ich schon gemacht -> kein Fehler - geht aber trotzdem noch nicht


    Wie wäre dann der chown-Befehl?

  • sudo chmod -R 777 /media/hdd1/share/ hab ich schon gemacht -> kein Fehler - geht aber trotzdem noch nicht

    Dann mach das wieder rückgängig. Du kannst nicht jede Änderung, die nichts bewirkt hat, einfach so belassen. Das System wird so immer mehr kaputt.


    Servus !

    RTFM = Read The Factory Manual, oder so

  • Dann mach das wieder rückgängig. Du kannst nicht jede Änderung, die nichts bewirkt hat, einfach so belassen. Das System wird so immer mehr kaputt.

    Wie mach ich das denn? Ich weiß doch nicht, wie die Rechte vorher waren. Bzw doch:

    pi@raspberrypi:~ $ ls -l /media/hdd1/share
    insgesamt 16
    drwxr-xr-x 2 root root 16384 Jun 18 18:37 backup

    Und wie mache ich das wieder so, wie es war?


    llutz Mein Eintrag in der fstab lautet: /dev/sda1 /media/hdd1 auto noatime 0 0

    Was muss ich ergänzen / ändern / löschen ?? uid, oder? Wo muss ich das dann hinschreiben?

  • Spielereien kann man nachträglich einbauen wenn es funktioniert.

    Der hyle hat recht. Auch wenn ich das natürlich nur schwerlich zugeben will. :P

    Ändere Deine Freigabe wie folgt, eigentlich müsstest Du zumindest lesend zugreifen können. Danach ändere die Rechte (mount Hinweise), damit Du auch schreiben kannst. Und erst dann schränke wieder sinnvoll ein.


    Code
    [public]
    comment = public storage
    path = /media/hdd1/share
    #valid users = @users
    #force group = users
    #create mask = 0660
    #directory mask = 0771
    read only = no
    • Official Post
    Quote

    /dev/sda1 /media/hdd1 auto noatime 0 0

    /dev/sda1 /media/hdd1 vfat rw,suid,dev,exec,auto,noatime,users,sync,nofail 0 0 (alles in eine Zeile)


    nofail deshalb, weil sonst gleich der nächten Thread kommt: "mein RPi startet nicht mehr, was nun". ;)

  • hyle deine fstab-Zeile ändert nichts an den default-Berechtigungen.

    suid ist überflüssig, weil vfat das suid-bit nicht speichern kann.

    users will man nicht, wenn ein Service auf das Filesystem zugreifen muss.

    Menschen die keine Ironie verstehen finde ich super!

  • /dev/sda1 /media/hdd1 vfat rw,suid,dev,exec,auto,noatime,users,sync,nofail 0 0 (alles in eine Zeile)

    hab ich probiert, geht nicht --> wieder zurückgesetzt

    Ändere Deine Freigabe wie folgt, eigentlich müsstest Du zumindest lesend zugreifen können. Danach ändere die Rechte (mount Hinweise), damit Du auch schreiben kannst. Und erst dann schränke wieder sinnvoll ein.

    hab ich gemacht:

    Code
    [public]
    comment = public storage
    path = /media/hdd1/share
    #valid users = @users
    #force group = users
    #create mask = 0660
    #directory mask = 0771
    read only = no

    samba mit sudo /etc/init.d/samba restart neugestartet.

    Jetzt werde ich bei Windows trotzdem noch nach Passwort + Nutzer gefragt !?

    Hab mich angemeldet -> trotzdem noch die gleiche Fehlermeldung!


    Wäre es vlt. besser, den USB-Stick ext4 zu formatieren? Hat das irgendwelche Nachteile?

    • Official Post

    llutz Damit wollte ich nur möglichst alle Eventualitäten ausschließen. Zumindest das Filesystem sollte man schon angeben, auch wenn Linux im Zweifel vfat automatisch mountet (habe ich irgendwie so im Hinterkopf). Und wie bereits oben erwähnt, einen Bootfehler bei abgezogenen Stick vermeiden, da nofail im default-mount-Parameter nicht enthalten ist. Außerdem fehlt wenigstens das Komma im fstab Eintrag des TO.

  • hyle Ist ja auch ok, ändert aber nichts daran, dass die Optionen so als "allround-Lösung" nicht wirklich taugen.

    no offense, btw.

    Menschen die keine Ironie verstehen finde ich super!

  • Es ist immer sinnvoller ein Dateisystem wie ext-fs zu benutzen, weil das nativ unterstützt wird und keine mount-Besonderheiten benötigt. Mit der Rechtevergabe unter LInux etc. wirst du dich aber trotzdem beschäftigen müssen.

    Menschen die keine Ironie verstehen finde ich super!