PiHole blockt keine Werbung und hat nur 1 Clienten (localhost)

  • Hallo liebe Community,

    ich habe heute auf meinem Raspberry Pi 3 PiHole installiert. Aber obwohl ich den PiHole-DNS-Server als DNS-Server in der Fritz!Box eingegeben habe, scheint keiner meiner Endgeräte den PiHole zu benutzen X/; : Auf dem Webadmin steht nur ein Client; dieser ist allerdings nur der Localhost:bravo2:. Wie gesagt, die Installation ist perfekt durchgelaufen. :helpnew:


    Hier ist ein aktueller Debuglog :@aus dem PiHole: https://gofile.me/3GoJQ/Hg3kR5fGz


    Hier ist ein Bild zu meinem Problem :X: ---unten---


    Liebe Grüße und viel Dank im Vorraus :danke_ATDE:

    Euer Heinz-Leopold :daumendreh2:



    ------ZUSATZ:

    Jetzt ist nicht mal der localhost Client vom PiHole :/(macht wohl einfach keine Internetanfragen:huh:)

    ZUSATZ------

    Edited 3 times, last by Horst-Leopold: Dateiuploadlinks, Zusatz ().

    • Official Post

    Hallo Horst-Leopold oder Heinz-Leopold! :conf:


    Bitte lade Bilder und Dateien hier ins Forum hoch! Erstens hält sich das/mein Vertrauen in fremde Hoster in Grenzen (Link anklicken ohne das Ziel zu sehen) und zweitens sind die Dateien nach einer Weile weg und der Kontext zu Deinem Beitrag dadurch zerstört. ;)

  • Standardfragen:

    - Pihole lauscht auf dem externen (LAN-) Interface? (netstat, lsof)

    Wenn ja:

    - Pihole reagiert auf Anfragen aus dem LAN? (dig  beliebige.domain.tld @ip.des.pi.hole)

    Menschen die keine Ironie verstehen finde ich super!

  • Hier sind die oben beschriebenen Dateien.


    hyle: Die Debuglog-Datei konnte ich aufgrund der Dateiendung leider nicht hier einfügen.


    Und zu diesem File-Hoster verspreche ich dir:

    Dies ist kein fremder Dateihoster. Das ist meine NAS - Diskstation (Dateifreigaben). Als Beweis habe ich dir noch ein Bild meiner Diskstation hochgeladen (der Link ist angezeigt).

  • sudo netstat -tulpen |grep 53 oder sudo lsof -i :53 vorher evtl sudo apt-get install lsof falls "lsof: command not found" kommt.


    dig www.whitehouse.gov @11.22.33.44

    11.22.33.44 durch die IP-Adresse deines PiHole Rechners ersetzen.

    Menschen die keine Ironie verstehen finde ich super!

  • Wo in der Fritzbox hast du die IP des PiHole eingetragen?

    Wenn ich mich richtig erinnere, dann hat die Fritzbox doch den Rebind Schutz integriert?


    Hast du schon mal versucht, die IP des PiHole bei dir am PC direkt unter DNS einzutragen und nicht automatisch über den DHCP beziehen zu lassen?

    Funktioniert es dann?

    unter "netzwerk"->"netzwerkeinstellungen"->"ipv4-adressen"->lokaler dns server"


    über "lokaler dns server" steht sogar:



    "geben sie hier eine adresse eines dns-server ein, der benutzt werden soll. die adresse, die hier eingetragen wird, wir an die clienten weitergegeben"


    (für die, die auch eine fritzbox haben: ja es ist nicht EXAKT der selbe text aber ich habe alle gut umgeformt -> nichts vergessen)






    ja, die fritzbox hat einen dns-rebind-schutz. was muss ich da ändern?







    und ja auf meinem pc habe ich den dnsserver auch schon manuell eingegeben, in der cmd steht mit "nslookup <website>" als dns server trotzdem 192.168.178.1 (ich musste einen 2.dns eintragen - Fritzbox-IP).


    Der DNS Server wird also als "nicht gültig" angesehen. Weil soweit ich weiß, wird der 2.dns nur benutzt, wenn der 1.dns nicht geht.

  • Ich habe mal die ausgabe als foto gepostet. lauscht er auf dem externen (LAN-)interface?

    Wenn 192.168.178.23 seine IP ist, ja. Unterhalb des dig-Befehls müsste auch eine Zeile "SERVER...." diese IP ausgegeben haben. Mach den Test mit dig mal von einem anderen Rechner (nslookup www.whitehouse.gov 192.168.178.23 unter windows)

    Menschen die keine Ironie verstehen finde ich super!

  • nslookup gibt das aus:

    Jo, DNS Anfragen werden korrekt beantwortet. Nun müsstest du das zur Sicherheit noch mit einer bekannten blacklisted-Domain testen, also eine die pihole garantiert filtert. z.B. nslookup bild.de 192.168.178.23 (Beispiel-Domain)

    Menschen die keine Ironie verstehen finde ich super!

  • OH X(. Jetzt habe ich eine nächste fehlerquelle gefunden:


    "pihole disable && pihole enable": Service dnsmasq konnte nicht gestartet werden:wallbash: .

    Das wird das Problem sein :cursing:.


    Ich poste gleich mal die Ausgabe von "sudo systemctl status dnsmasq.service" und "sudo journalctl -xe". (Mach gerade kurz einen Reboot;))

  • Was sagt den dein Win PC bzw. die Netzwerk Verbindung welcher DNS verwendet wird ?

    cmd "ipconfig /all" sagt, es wird der DNS-Server "192.168.178.23 (Pi-Hole) und 192.168.178.1 (Fritz!Box)" verwendet.





    Wie es oben schon irgendwo steht, ich glaube, der 2.DNS wird dann benutzt, wenn der 1.DNS nicht geht, was stimmt ^^

  • Eben die Nachricht über dem Zitat:


    dnsmasq.service nicht gestartet (Fehler)