Raspberry pi mit Edimax EW-7811UN Wlan Verbindung bricht nach einer Weile ab

  • Hallo,


    mein Raspberry mit einem Edimax EW-7811UN stellt beim Start automatisch eine WLAN Verbindung her. Nach einer Weile bricht die aber ab.

    Dann steht in dem Netzwerkmonitor in der Taskleiste "wlan0 expired". Mit der Meldung kann ich nichts anfangen. Hat jemand eine Idee wie man das Problem beheben könnte?


    Version:

    Raspbian Stretch with desktop

    Version: April 2018

    Release date: 2018-04-18

    Kernel version: 4.14


    Grüße

    Radius

  • hi,


    da gibts es beim edimax ein stromsparmodus, um diesen zu deaktivieren gehe wie folgt vor.


    gebe im terminal folgendes ein:

    sudo nano /etc/modprobe.d/8192cu.conf


    fühge dort folgendes ein:

    options 8192cu rtw_power_mgnt=0 rtw_enusbss=0


    dann speichern fertig.


    habe meinem edimax noch gesagt, dass er jede minute ein ping an den router schicken soll. damit dieser nicht doch einschläft.


    gebe im terminal folgendes ein:

    sudo nano /etc/crontab


    fühge dort folgendes ein (xxx.xxx. steht für die IP deines routers) also ersetzen!!! :

    */1 * * * * ping -c 1 xxx.xxx.xxx.x


    hier auch wieder speichern.

    Einmal editiert, zuletzt von ohne-holger ()

  • Hallo,


    danke für den Tipp. Die Datei /etc/modprobe.d/8192cu.conf war nicht da. Habe sie neu angelegt und den Raspberry neu gestartet.

    Ich werde jetzt beobachten ob der Fehler nochmal auftritt und melde mich vermutlich in ein paar Tagen wieder.


    Grüße

    Radius

  • Hallo,


    die WLAN Verbindung bleibt jetzt über mehrere Stunden ohne Unterbrechung aktiv.


    Einmal habe ich beobachtet, dass die IPV4 Adresse auf expired gesetzt war, während die IPV6 Adresse aktiv blieb. Der Internet Zugang schien verlangsamt zu sein, hat aber noch funktioniert.


    Grüße

    Radius