NFS mount Probleme seit neuster Raspberry Version

  • Hallo


    ich habe heute auf die neueste Raspberry Version gewechselt.

    Seit dem habe ich mit dem NFS mount Probleme.


    Bisherige Lösung:



    sudo nano /etc/fstab



    192.168.2.20:/home/public /home/nfs/public nfs _netdev,rw,bg,soft,intr,rsize=8192,wsize=8192,timeo=60,retry=5 0 0


    Jetzt scheint es aber so zu sein das der Raspberry versucht zu verbinden bevor die Netzwerkverbindung da ist.


    Hat jemand eine Idee was am neuen Raspberry geändert wurde ?

    Oder wie man das Problem lösen könnte ?

  • Einfach mit sudo apt-get update und sudo apt-get upgrade


    home-nfs-public.mount: Mount process exited, code=exited status=32

    Jul 11 15:28:37 raspberrypi systemd[1]: Failed to mount /home/nfs/public.

    Jul 11 15:28:37 raspberrypi systemd[1]: Dependency failed for Remote File Systems.

    Jul 11 15:28:37 raspberrypi systemd[1]: remote-fs.target: Job remote-fs.target/start failed with result 'dependency'.

    Jul 11 15:28:37 raspberrypi systemd[1]: home-nfs-public.mount: Unit entered failed state.

  • Aus < man mount > die Option:

    _netdev

    (The filesystem resides on a device that requires network access

    (used to prevent the system from attempting to mount these

    filesystems until the network has been enabled on the system))



    Servus !.

    Wer nichts weiß, muss alles glauben.

  • RTFM

    Code
    1. 192.168.2.20:/home/public /home/nfs/public nfs _netdev,rw,bg,soft,intr,rsize=8192,wsize=8192,timeo=60,retry=5 0 0

    Aber das hat er doch in seinem Aufruf schon drin :denker:

    Der Unterschied zwischen Genie und Wahnsinn definiert sich im Erfolg.

  • Oder wie man das Problem lösen könnte ?

    Ich habe vorgestern ein ähnlich gelagertes Problem mit einem zu montenden SMB Share lösen müssen. Softwarestand bei mir derzeit raspbian_lite-2018-04-19 mit allen per apt-get dist-upgrade erhältlichen Updates.


    Grundsätzlich neu scheint das Problem nicht zu sein, dass die Netzwerkinterfaces zu dem Zeitpunkt noch nicht initialisiert sind, wenn das Mounten von Laufwerken wie in fstab angegeben stattfinden soll.


    Erste Anlaufstelle ist üblicherweise raspi-config, dort Setzen von

    Boot Options -> Wait for Network at Boot


    Hat bei mir aus welchen Gründen auch immer keinen Erfolg gebracht, obwohl raspi-config wie erwartet die Datei /etc/systemd/system/dhcpcd.service.d/wait.conf neu geschrieben hat. Eventuell ein Problem von raspi-config, systemd oder an ganz anderer Stelle, das habe ich nicht weiter verfolgt.


    Letztendlich habe ich mir mit einem Eintrag in der systemweiten crontab beholfen, der nach 10 Sekunden Wartezeit einen weiteren Mount-Versuch unternimmt. Funktioniert bei mir bisher einwandfrei.

    Code
    1. scr@raspi01:~ $ tail -2 /etc/crontab
    2. # pragmatic attempt to mount cifs shares after a reboot, except "noauto" ones
    3. @reboot root ( /bin/sleep 10; /bin/mount -a -t cifs )

    Für NFS mounts geringfügig anzupassen, versteht sich.

    Pi 3 B+ (mein erster Raspi)

    Einmal editiert, zuletzt von MrToddsFriends () aus folgendem Grund: Raspbian Version berichtigt.

  • Wie ist die Ausgabe von:

    Code
    1. apt-get -s upgrade --with-new-pkgs

    ?

    apt-get -s upgrade --with-new-pkgs

    NOTE: This is only a simulation!

    apt-get needs root privileges for real execution.

    Keep also in mind that locking is deactivated,

    so don't depend on the relevance to the real current situation!

    Reading package lists... Done

    Building dependency tree

    Reading state information... Done

    Calculating upgrade... Done

    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.



    Ich hatte auch mal die Vorgänger Version von Raspian getestet funktioniert auch nicht.

    Ich weiß leider nicht mehr welche Version ich installiert hatte damals.

  • Das funktioniert bei mir nicht weil ich noch eine Webcam Software habe die Bilder aufnimmt und deshalb schon auf die Freigabe wartet. Erfolgt die Freigabe nicht können keine Bilder aufgezeichnet werden.

  • Hi!


    192.168.2.20:/home/public :-/


    Eher so: //192.168.2.20/home/public ? :geek:


    Edit: Was ich mir dabei nur wieder dachte? :conf:

    "Alles, was wir sind, ist Sand im Wind, Hoschi."

    Einmal editiert, zuletzt von hyle ()