Nach Stromausfall nur noch Emergency Mode - Hilfe bei Fehlersuche benötigt

  • Hallo zusammen,


    zunächst einmal, Google und die SuFu auf dieser Homepage haben mich leider noch nicht die passende Hilfe finden lassen. Falls doch etwas existiert, entschuldigt bitte diesen Post.


    Mein Setting: Ich hab hier ein RPI 3 mit Raspbian. Auf diesem läuft sein einigen Monaten ein nextcloud Server. Die System- und Serverdaten liegen auf der SD Karte. Nutzerdaten liegen auf einer externen HDD. Das System ist als ein headless-System installiert.


    Nun zu meinem Problem: Vor kurzem wurde die Stromversorgung meines RPI unterbrochen und seit dem startet dieser nur noch in den emergency mode. Beim Starten wird mir u.a. die Fehlermeldung "failed to start load kernel modules" angezeigt. Vermutlich wurde während des Stromausfalls gerade ein Schreibvorgang durchgeführt und nun ist irgendeine Datei beschädigt.


    Bevor ich nun mein System komplett neu aufsetze, würde ich gerne versuchen das System zu retten. Zugegebenermaßen bin ich eher ein Anfänger, weswegen ich gerade etwas ahnungslos bin, wie ich am besten Vorgehe. Ich hoffe ihr könnt mir helfen.


    Edit: Ich konnte inzwischen herausfinden, dass wenn ich in fstab die USB-Festplatte auskommentiere, dass er dann normal bootet. Fehlermeldungen bleiben allerdings am Anfang erhalten und fraglich ist auch warum die Festplatte nicht mehr unter ihrer normalen UUID erkannt wird.


    Viele Grüße

    MW

    Edited once, last by walterm ().

  • Hi,


    Hast du mal versucht die Festplatte bzw. das Dateisystem zu überprüfen und anschließend reparieren zu lassen -> fsck .

    Eventuell hat sich die UUID geändert?

    Vielleicht solltest du auch mal die SD-Karte mit fsck überprüfen.

    Wenn's brennt 112 hilft weiter!

  • Hallo und Willkommen im Forum,


    hilft dir folgendes weiter?: https://askubuntu.com/question…start-load-kernel-modules



    Bevor ich nun mein System komplett neu aufsetze,

    Ein guter Server besitzt doch immer Backups (:;)

    Ein gutes Tool dafür bietet das von framp : https://www.linux-tips-and-tri…omatic-backups-of-itself/

  • Hi,


    erstmal danke für die Tipps. Das System läuft wieder. :)


    In der Tat lag es am Dateisystem. Wie es scheint wurden die File System Superblocks durch den Stromausfall in Mitleidenschaft gezogen.


    Falls mal jemand wieder ein ähnliches Problem haben sollte, ich habe folgendes getan:

    1. USB-Festplatte aus fstab auskommentiert und neu gestartet --> Dadurch kein emergency mode mehr

    Code
    1. sudo nano /etc/fstab

    2. USB-Festplatte versucht manuell zu mounten, dabei kam heraus, dass einer der Superblocks fehlerhaft ist.

    3. Dateisystem mit fsck geprüft und repariert

    Code
    1. fsck /dev/sdaX


    So wie es aussieht, wurden zu Beginn relativ viele Fehler geworfen, obwohl diese nur indirekt mit dem eigentlichen Problem zu tun hatten. Diese sind nach einem Reboot nun auch wieder verschwunden. Liegt wohl an meinem Setup.


    Danke noch mal und viele Grüße

    MW

  • PS:

    Ein guter Server besitzt doch immer Backups (:;)

    Da kann ich dir nur zustimmen. Wird nun doch Zeit, dass ich automatische Backups mal einrichte. Morgen als aller erstes ;-)