Autostart von Kodi will einfach nicht

  • Moin,

    ich habe jetzt so einige Möglichkeiten getestet um Kodi beim Systemstart automatisch zu starten. Aus irgend einen Grund, klappt es aber nicht.

    Hintergrund: Ich führe gerade 2 Pi's zusammen. Auf einer lief eine SQL-Datenbank und wiringPi, die andere war Openelec. Zukünftig soll dies alles eine machen. Was zu meinem Glück nun fehlt ist nur noch, dass Kodi automatisch startet.

    Hatte gehofft das sich hier jemand findet, der mir sagen kann wie er es gemacht hat, dass Kodi unter Raspbian automatisch startet, damit wir dann gemeinsam den Fehler finden können


    Gruß
    Ryckmaster

  • Zum beispiel dies: https://strobelstefan.org/?p=5137

    Die nicht vorhandene Datei habe ich erstellt.


    Hier habe ich mich auch durchgekämpft, unter anderem punkt 3 blieb erfolglos.


    Auch ein script blieb ohne erfolg :(


  • Was wäre mit OSMC -> basiert auf Raspbian d.h. Du hast die komplette Freiheit was du machen willst und eben , dass du deine Benötigten Programme installieren kannst.

    Wenn's brennt 112 hilft weiter!

  • Was wäre mit OSMC -> basiert auf Raspbian d.h. Du hast die komplette Freiheit was du machen willst und eben , dass du deine Benötigten Programme installieren kannst.


    Es wird doch wohl möglich sein, unter Raspbian ein Autostart anzulegen O.O

  • Die Anleitung von dem Link ist (zu) alt. Vermutlich wird das so nicht mehr gemacht, oder es ist einfach nur falsch?


    Es gibt verschiedene Möglichkeiten Autostart zu bewerkstelligen. Zwei einfache sind, eine Desktopdatei in /home/pi/.config/autostart erstellen, oder ein Eintrag in /home/pi/.config/lxsession/LXDE-pi/autostart einfügen. Für die Desktopdatei (in diesem Fall Kodi) empfiehlt es sich eine Vorlage aus /usr/share/applications zu kopieren nach /home/pi/.config/autostart und diese dann wie gewünscht anpassen.

  • Das war ja nun doch einfach :D


    Ich habe die Datei in den Autostartordner kopiert, wie du es mir empfohlen hast und zack - läuft.


    Vielen Dank!