Flackern bei dunklen Bildern und crop Einstellung nicht möglich.

  • Moin, nachdem mein Ambilight jetzt funktioniert gibt es noch ein paar Dinge die mich stören, Das Feintuning sozusagen.

    Ich habe Probleme mit der Randeinstellung des Grabbers. Die Menge der Maximal entfernbaren Pixel liegt bei 100, jedoch habe ich dann trotzdem noch dezente Striche.



    Wie bekomme ich die Striche denn weg?

    Die Qualität vom Screenshot ist leider sehr schlecht, da die Hdmi Eingänge an meinem Fernseher leider nicht funktionieren, ich aber auch nicht weiß warum. Das Signal muss ich von Hdmi konvertieren und dann per Scart einfügen.


    Mein zweites Problem ist, dass die Leds bei dunklen Bildern flackern, Ein Problem mit der Spannung ist es denke ich nicht, da ich erst heute eine zweite Einspeisung gelegt habe weil die Farben ab und zu aufgeblitzt sind. Das ist aber behoben. (Sind Apa102 und 229 Leds)


    Ich weiß leider nicht, wie ich das beheben kann aber hier bekommt man ja sehr schnell Hilfe.


  • Hallo,

    Was willst Du da noch von den Rändern abschneiden, mit den Crop Werten entfernst Du die schwarzen Ränder um das Bild.

    Das liegt im Bereich von ca. maximal 20 Pixel oder eher weniger. Bei 100 nimmst Du vom eigentlichen Bild schon viel zu viel weg.

    Diese leichten Striche oder Linien sollten das Ambilight nicht großartig beeinflussen.

    Du könntest stattdessen die Abtastung eher etwas nach innen verschieben, Richtung Bildmitte.

    Das Screenshot sieht für mich ok aus, besser wird es nicht werden.


    Ich der Config stellst Du beim Grabber die Option "frameDecimation" am besten auf den Wert 2, somit wird nur jedes zweite Bild ausgewertet.


    "frameDecimation" : 2,

  • Moin, vielen Dank für den Tipp aber leider habe ich bei 20 Pixeln noch immer einen komplett schwarzen Rahmen. Die Werte müssen leider so hoch sein.

    Ich nehme an, die frame Decimation beruhigt das Ambilight bzw macht es "smoother"?


    Was hilft denn bei dem Flackern?

  • Mach mal ein Screenshot wo die schwarzen Ränder noch nicht gecropt sind.


    Lese mal im Hyperion Wiki wegen den ganzen Einstellungen. Ich würde es so einstellen, das bei dunklen Szenen die LEDs noch schwach leuchten.

    Du muss glaube ich "luminanceMinimum" : 0.0000 etwas erhöhen.


    Ich selbst benutze eine ältere Version von HyperCon, da gab es noch die blacklevel Einstellung, da fand ich das irgendwie besser.

    Wollte mich schon lange mal wieder damit befassen, bin aber noch nicht dazu gekommen.


    Ich habe bei mir auch die Abtastung vom gesamten Bild eingestellt, so das es eine Art Durchschnitt vom Gesamtbild errechnet.

    Da hat man zwar keine Detailbezogenen Farben mehr, aber das Ambilight ist viel ruhiger.

  • Ich habe bei mir auch die Abtastung vom gesamten Bild eingestellt, so das es eine Art Durchschnitt vom Gesamtbild errechnet.

    Da hat man zwar keine Detailbezogenen Farben mehr, aber das Ambilight ist viel ruhiger.

    Klingt ja interessant.... Wie hast´n das gemacht? Funzt das auch bei der neuen Version von HyperCon?

  • Welche HyperCon Version ist egal, einfach den Bildbereich erhöhen, bei mir 97%. Also Horizontale Tiefe und vertikale Tiefe erhöhen, bis das Gitter aufs ganze Bild verteilt ist. Das ist sicher nicht jedermanns Sache, da die Farben dann nicht mehr im Detail passen.