Suche besonderes Display

  • Hey,


    ich suche für meinen Pi3B (Raspian Jessie) ein Display, welches auch in der initramfs-Shell ein Bild anzeigt.


    Hintergrund: Ich habe meine SD-Karte mit LUKS voll-verschlüsselt und muss bei jedem Start des Pis die Karte in der initramfs-Shell entschlüsseln (cryptsetup luksOpen...). Diese Passworteingabe geschieht derzeit blind.


    Getestet habe ich bereits zwei 3,5“ Displays von Waveshare... ein Display lief direkt über den GPIO-Port und das andere über einen kleinen HDMI-Stecker. Beide Displays verlangten aber zwingend einen Treiber, was eine Funktionalität in der initramfs-Shell wohl ausschließt?! Jedenfalls zeigten die Displays kein Bild und sprangen erst an, wenn das Passwort eingegeben wurde und der eigentliche Boot-Vorgang losging.


    Gibt es hierfür eine Lösung oder ein funktionierendes Display? Bevorzugen würde ich 3,5“... ein Touch-Screen muss es nicht haben.

    Übrigens: Der HDMI-Port funktioniert in der initramfs-Shell... mein 47“ Toshiba-Fernsehr zeigt über HDMI ein Bild.


    VG

    nuclearfallout

  • Hm ... also ich sehe bei meinen 3.5" HDMI TFT Displays durchaus den gesamten Bootvorgang ...

    Das sollte mit einem HDMI Display also schon funktionieren.

    Dass das Display, das auf die GPIO-Leiste gesteckt wird, nichts anzeigt, ist imho nicht weiter verwunderlich, weil da zuerst die Module geladen werden müssen.

    Ich hab's jetzt gerade noch mal probiert ... also es erscheint ein blinkender Cursor links oben, dann das Bootlogo, dann sausen in der untersten Zeile die Bootmeldungen durch und plopp ist der Desktop da. Geht alles wahnsinnig schnell, aber das sollte klappen.


    Was sollte auch dagegen sprechen ... ist HDMI und das Teil dürfte im VGA-Modus starten.

    cu,

    -ds-

  • dreamshader

    Welche(s) Display(s) nutzt du? Wie gesagt, das 3,5“ von Waveshare zeigte trotz HDMI-Verbindung kein Bild.

    Wenn du bei dir das Bootlogo und den blinkenden Cursor siehst, müsste es ja wirklich funktionieren (wie gesagt, mein Fernseher funktioniert ja auch mit HDMI). War/ist für dein Display ein Treiber notwendig?

  • Dass das waveshare nicht funktioniert wundert mich allerdings ...

    Ich hab' eines von Kedei ( so was z.B. -> https://www.ebay.de/itm/New-3-…spberry-Pi-3/162285114464 )


    Bei einem der Displays war eine DVD mit dabei. Darauf ist ein spezielles Image. Das habe ich mittlerweile aber ohne Probleme schon per update/upgrade aktualisieren können.

    Ausserdem läuft, bis auf die Kalibrierung, das Image auf beiden.

    Ich war immer der Meinung, dass die Dinger, inkl. dem von waveshare, kompatibel sind. Zumindest die 3.5" HDMI Touch-Teile.

    Bei den anderen TFT Displays ist das ja leider nicht der Fall.

    Probier' doch evtl. einfach mal das kedei HDMI-Image aus ... das kannst Du bei denen herunterladen.


    cu,

    -ds-

  • Hast Du schon in der /boot/config.txt versucht HDMI anzupassen? Vielleicht stimmt z.B. einfach nur die Auflösung nicht. Ist aber nur so ein Gedanke... Meine RPi laufen kopflos. ;)

    "Alles, was wir sind, ist Sand im Wind, Hoschi."

  • hyle ,

    Er muss scheinbar schon beim Laden ins ramfs ein Passwort eingeben ...

    Genauso ist es. In der besagten Config zu spielen habe ich nicht versucht... Bin auf dem Gebiet auch absoluter Laie.


    Ich habe mir nur das verlinkte Display von Kedei bestellt. Nach Erhalt werde ich mich hier wieder melden :)


    Soweit erst einmal Danke an alle.