Rasbian Lite, welchen Desktop mit guten Browser nachinstallieren?

  • Hallo zusammen,


    ich habe einen Pi3 ursprünglich für IoT "ioBroker".

    Das Ganze hatte ich über ein Raspbian lite Image installiert.


    Jetzt möchte ich aber ein Desktop darauf nachinstallieren mit einem guten Browser.

    Und zwar möchte ich von außen über Anydesk (oder Teamviewer) darauf zugreifen und den Browser bedienen um diverse Geräte anzusprechen.

    Der Pi ist ja immer an, deshalb ist das ganz praktisch.


    Jetzt die Fragen. Welchen Desktop und wie installiere ich den nach? Ich brauche dann wohl auch "X-Server". Ist der bei Lite schon dabei oder muss der auch noch nachinstalliert werden?



    Danke für Tipps!

    Tobi

  • Raspbian lite Image installiert. Jetzt möchte ich aber ein Desktop darauf nachinstallieren mit einem guten Browser.

    Und wenn Du jetzt mal ganz verwegen den Tipp von TanteG ausprobierst? Nur musst Du dann noch definieren, was genau jetzt einen guten von einem schlechten Browser unterscheidet (nein, Edge läuft auf dem RPi nicht...).


    von außen über Anydesk (oder Teamviewer)

    Die Raspberry Pi Foundation hat VNCConnect lizensiert, das funktioniert sehr gut, auch von ausserhalb. So Geraffel wie oben braucht es nicht extra noch.


    Abgesehen davon ist es evt. die leichtere Variante, den RPi mit Raspbian mit Pixel neu zu installieren. Kommt nur darauf an, ob Du etwas funktionierendes erhalten willst/musst.


    Grüße, STF

    "And now for something completely different."


    Hofeis guide to: Wie frage ich nach Hilfe? *** Mein nagelneuer Raspberry Pi 3B+ zeigt nur ein buntes Bild. (Ab)Hilfe.

  • Hallo


    das hört sich das ganz gut an.

    Leider bekomme ich bei der Installation von x-server folgende Fehlermeldung:



    Habe hinten noch -core angehängt, bringt aber auch eine Fehlermeldung.

  • Leider komme ich hier nicht weiter.


    Wenn ich ausführe:


    "sudo apt-get install --no-install-recommends xserver-xorg-core"


    kommt folgendes:


    Paketlisten werden gelesen... Fertig

    Abhängigkeitsbaum wird aufgebaut.

    Statusinformationen werden eingelesen.... Fertig

    Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass

    Sie eine unmögliche Situation angefordert haben oder, wenn Sie die

    Unstable-Distribution verwenden, dass einige erforderliche Pakete noch

    nicht erstellt wurden oder Incoming noch nicht verlassen haben.

    Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:


    Die folgenden Pakete haben unerfüllte Abhängigkeiten:

    xserver-xorg-core : Hängt ab von: xserver-common (>= 2:1.19.2-1+rpt1+deb9u2) soll aber nicht installiert werden

    Hängt ab von: libegl1-mesa soll aber nicht installiert werden oder

    libegl1 ist aber nicht installierbar

    Hängt ab von: libepoxy0 (>= 1.0) ist aber nicht installierbar

    Hängt ab von: libgbm1 (>= 10.2~0) soll aber nicht installiert werden

    Hängt ab von: libgl1-mesa-glx soll aber nicht installiert werden oder

    libgl1

    Hängt ab von: libpciaccess0 (>= 0.12.902) ist aber nicht installierbar

    Hängt ab von: libpixman-1-0 (>= 0.30.0) ist aber nicht installierbar

    Hängt ab von: libxfont2 (>= 1:2.0.1) ist aber nicht installierbar

    Hängt ab von: libxshmfence1 ist aber nicht installierbar

    E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.



    Auch wenn ich nur Pixel nachinstallieren möchte erhalten ich folgendes:

    sudo apt-get install raspberrypi-ui-mods

    Paketlisten werden gelesen... Fertig

    Abhängigkeitsbaum wird aufgebaut.

    Statusinformationen werden eingelesen.... Fertig

    Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass

    Sie eine unmögliche Situation angefordert haben oder, wenn Sie die

    Unstable-Distribution verwenden, dass einige erforderliche Pakete noch

    nicht erstellt wurden oder Incoming noch nicht verlassen haben.

    Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:


    Die folgenden Pakete haben unerfüllte Abhängigkeiten:

    raspberrypi-ui-mods : Hängt ab von: lxpanel soll aber nicht installiert werden

    Hängt ab von: pcmanfm soll aber nicht installiert werden

    Hängt ab von: openbox soll aber nicht installiert werden

    Hängt ab von: xserver-xorg ist aber nicht installierbar

    Hängt ab von: x11-xserver-utils ist aber nicht installierbar

    Hängt ab von: policykit-1 ist aber nicht installierbar

    Hängt ab von: lightdm ist aber nicht installierbar

    Hängt ab von: zenity soll aber nicht installiert werden

    Hängt ab von: libglib2.0-bin ist aber nicht installierbar

    Empfiehlt: xserver-xorg-video-fbturbo soll aber nicht installiert werden

    Empfiehlt: libgksu2-0 ist aber nicht installierbar

    Empfiehlt: fonts-piboto (>= 1.1) soll aber nicht installiert werden

    Empfiehlt: pimixer soll aber nicht installiert werden

    Empfiehlt: pipanel soll aber nicht installiert werden

    Empfiehlt: lxinput soll aber nicht installiert werden

    Empfiehlt: raspberrypi-artwork soll aber nicht installiert werden

    Empfiehlt: pi-greeter soll aber nicht installiert werden

    Empfiehlt: rpd-plym-splash soll aber nicht installiert werden

    Empfiehlt: rpd-wallpaper soll aber nicht installiert werden

    Empfiehlt: pishutdown soll aber nicht installiert werden

    Empfiehlt: scrot ist aber nicht installierbar

    Empfiehlt: fontconfig-infinality soll aber nicht installiert werden

    Empfiehlt: point-rpi soll aber nicht installiert werden

    Empfiehlt: gtk2-engines-pixbuf ist aber nicht installierbar

    Empfiehlt: gtk2-engines-clearlookspix soll aber nicht installiert werden

    Empfiehlt: gnome-icon-theme ist aber nicht installierbar

    Empfiehlt: rpd-icons soll aber nicht installiert werden

    Empfiehlt: lxplug-volume soll aber nicht installiert werden

    Empfiehlt: lxplug-network soll aber nicht installiert werden

    Empfiehlt: lxplug-bluetooth soll aber nicht installiert werden

    Empfiehlt: lxplug-ejecter soll aber nicht installiert werden

    Empfiehlt: lxplug-ptbatt soll aber nicht installiert werden

    Empfiehlt: rc-gui (>= 1.18) soll aber nicht installiert werden

    E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.


    Kann mir bitte jemand Tipps geben?


    Eine Neuinstallation ist nur leider nur mit erheblichen Aufwand verbunden, da ich immer komplette Images aufspiele, und die gibt es in der aktuellen Version nur als lite version.

    Einmal editiert, zuletzt von hg6806 ()

  • cat /etc/os-release

    PRETTY_NAME="Raspbian GNU/Linux 9 (stretch)"

    NAME="Raspbian GNU/Linux"

    VERSION_ID="9"

    VERSION="9 (stretch)"

    ID=raspbian

    ID_LIKE=debian

    HOME_URL="http://www.raspbian.org/"

    SUPPORT_URL="http://www.raspbian.org/RaspbianForums"

    BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"


    cat /etc/apt/sources.list

    deb http://raspbian.raspberrypi.org/raspbian/ stretch main contrib non-free rpi

    # Uncomment line below then 'apt-get update' to enable 'apt-get source'

    #deb-src http://raspbian.raspberrypi.org/raspbian/ stretch main contrib non-free rpi

  • So, habe noch die Config angepasst, VNC installiert und Desktop Autologon, dazu "sudo apt-get install lightdm" erfolgreich ausgeführt.

    Der Pi startet mit Desktop, jedoch will er sich anmelden.

    Als Anmeldenamen habe ich "pi" + mit Passwort, das funktioniert aber nicht, zumindest wird der Bildschirm kurz schwarz und schwups, istd er Anmeldescreen wieder da.

    Bei absichtlich falschen PW meldet er es auch, das stimmt also.

    Einmal editiert, zuletzt von hg6806 ()