Raspberry pi3 startet läuft aber startet nicht mit USB Festplatte

  • Hallo

    Ich will den Pi3 als Nas und Medienserver nutzen das Betriebssystem Stretch ist auf einem USB Stick. Nun habe ich aber das Problem das ich die Festplatte anhängen und dann auch Dateien ansehen kann, sie läuft problemlos. Wenn ich aber den Raspi neu Starte dann fährt er nicht mehr hoch. Das Problem besteht ob ich die Festplatte "einhänge" oder nicht. Es sieht für mich aus als ob die Festplatte anstelle des USB Sticks angesprochen wird, aber dann nicht startet der PI nicht da er dort kein Betriebssystem findet.


    Grüsse und Dank Joch

  • Hallo joch,


    auch wenn die Informationen ein wenig dürftig sind, würde ich mal auf die Verwendung einer 2,5“ Platte ohne eigene Stromversorgung tippen. Dann könnte der Strom an den USB Ports nicht ausreichen. Abhilfe in diesem Fall bringt ein USB Hub mit eigener Stromversorgung.


    Gerüsts, STF

  • Hallo

    Ja, es ist eine 2,5" Platte ohne Stromversorgung, eine WD Elements 1TB. Ich habe gelesen das diese Erfolgreich verwendet wurden. So gesehen muss ich veilleicht mal Testen wie es ist wenn ich den Strom ausgang am USB Port erhöhe.

    Grüsse und Dank Joch

  • Nützt nix, denn der Eintrag in der config.txt wird erst nach dem Start aktiv. Außerdem bedeutet „wurde erfolgreich verwendet“ keinesfalls, dass dies an Deinem Pi mit zusätzlichem USB Verbraucher (aka Stick) geht.


    Grüße, STF

    • Official Post

    Hallo joch,

    Es sieht für mich aus als ob die Festplatte anstelle des USB Sticks angesprochen wird,

    für mich sieht es nach fehlerhaftem Mounteintrag aus. Wie hast Du das System eingerichtet? Verwende bitte folgendes als Leitfaden! Wie Frage ich nach Hilfe?


    und eine weitere Hilfe für den armen RPi wird, wie von STF schon angesprochen, sein...

    Abhilfe in diesem Fall bringt ein USB Hub mit eigener Stromversorgung.

    :thumbup:

  • Wenn die UUIDs zweier Partitionen ident sind (was beim Erstellen eines Device aus derselben Quelle geschehen kann), kann auch nicht gebootet werden.


    Die Partitionsdaten kann man sich mit mit "list block devices"=lsblk und den Ausgabeoptionen (lsblj -h) anzeigen lassen. Z.B.< lsblk -o name,partuuid,uuid >


    Servus !

    RTFM = Read The Factory Manual, oder so

    Edited once, last by RTFM ().

  • Nützt nix, denn der Eintrag in der config.txt wird erst nach dem Start aktiv

    alle meine PI 2/3 starten mit einer WDplatte 2,5" passport von 1TB bis 3TB am USB, natürlich darf nicht mehr oder zu viel dranhängen, was nicht geht ist +wlanstick, was nicht geht ist +USB Stick was geht ist ein HID Tastatur/Maus FunkStick

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

  • Ja klar. Ich glaube inzwischen, dass ich die Frage auch falsch interpretiert habe. joch s Aussage „dann fährt er nicht mehr hoch“ ist zu unklar, es wäre hilfreich, das zu konkretisieren.


    Grüße, STF

  • Hallo

    Nun, ich habe nochmals Diverse Versuche gemacht und verstehe weniger als zuvor. Also, der Raspberry Pi3 hat auf einem USB Stick das Stretch als Betriebssystem. Wenn ich dann da die WD 1TB 2,5" Festplatte anschliesse kann ich die Benutzen und auch Mounten. Aber der Pi3 startet danach nicht mehr damit. Das Mounten sollte nicht das Problem sein den der Pi startet auch nicht wenn ich die WD Platte ohne zu Mounten anhänge vor dem Start. Nächster versuch, ich habe also zuerst den zweiten USB Stick angehängt auf dem das NAS lauffen soll. Das ging problemlos auch das Mounten des Sticks funktioniert da nach dem Neustart der Stick richtig gemounted ist und alles funktioniert. Wenn ich aber dann die WD Platte einstecke wird der Nas USB Stick rausgeschmissen aber die WD Platte funktioniert soweit, aber der Pi startet auch so nicht mehr. Ich habe das mit 2 verschiedenen WD Platten versucht und immer dasselbe ergebnis bekommen. Also nächster Versuch mit einer uralten 2,5" Buffalo 500Gb Platte USB-2 0,5A und siehe da läuft problemlos, und der Pi startet auch wieder damit. Also diese Platte gemounted und wieder kein problem mit dem Start. Ich habe keinen USB Hub mit Stromversorgung zur hand und möchte wegen Stromsparen auch lieber darauf verzichten und auch weil denke das die Platte so immer läuft da sie immer strom hat. Ich bin mir nicht mehr sicher ob es wirklich an zuwenig strom liegt. So wie ich im Netz gefunden habe sollten die WD Platten auch 500mah konsumieren wie die Buffalo. Der unterschied ist jedoch dass diese USB-3 haben jedoch voll USB-2 Kompatibel sein sollen. Als letzter versuch habe ich vor dem einstecken der WD Platte den Strom am USB ausgang erhöht, aber der "nas" Stick wird bei einstecken der Platte immer noch ausgeworfen. Ich Verstehe dass das nichts genützt hätte zum Start Problem aber ich wollte schauen ob der Stick evt. nicht ausgeworfen wird. Ist evt. ein Problem mit USB-3 möglich oder irgendetwas anderes mit den WD Platten?


    Grüsse und Dank Joch

  • vergiss deine USB Stick zusammen mit der Platte am USB


    entweder du bootest von der Platte oder von der SD


    Beides zusammen schafft der PI beim booten nicht!

    Nacheinander eingesteckt im Betrieb ist eine andere Baustelle als beim Booten schon vorher eingesteckt.

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

  • Wenn die UUIDs zweier Partitionen ident sind (was beim Erstellen eines Device aus derselben Quelle geschehen kann), kann auch nicht gebootet werden.


    Also, der Raspberry Pi3 hat auf einem USB Stick das Stretch als Betriebssystem.

    Kann es sein, dass der Pi der Meinung ist er müsste von der HDD das OS Booten?

    Habe selbst noch nie von einem USB Stick gebootet, deshalb weiß ich nicht wie das konfiguriert wird was der Startpunkt ist...wär aber denkbar dass...

  • Hallo

    jar: Aber da ist komisch das es mit der USB Buffalo Platte schon funktioniert mit dem OS auf USB Stick und NAS auf USB stick. Mit der Platte startet der Pi auch ohne Probleme ob gemountet oder nicht.

    RTFM: Ich habe das kontrolliert und alle PartUUID sind verschieden. Es sieht aus als ist beim Start mit den zwei Usb Sticks erst der Nas Stick "sdb1". Wenn ich dann die Platte einstecke wird der Stick rausgeworfen und die Platte ist "sdb1", der Nas stick wäre dann sdc1 aber ist nicht mehr erreichbar da ausgeworfen.


    NAME PARTUUID UUID

    sda

    ├─sda1 43a00f1b-01 6228-7918

    └─sda2 43a00f1b-02 6bfc8851-cf63-4362-abf1-045dda421aad

    sdb

    └─sdb1 f4b0af3e-01 067883FF7883EBAD

    pi@raspberrypi:~ $ lsblk -o name,partuuid,uuid


    Nach Platte einstecken:

    NAME PARTUUID UUID

    sda

    ├─sda1 43a00f1b-01 6228-7918

    └─sda2 43a00f1b-02 6bfc8851-cf63-4362-abf1-045dda421aad

    sdb

    └─sdb1 00023f15-01 AA84EEDD84EEAAD1

    sdc

    └─sdc1 f4b0af3e-01 067883FF7883EBAD



    STF: Mit nicht starten meine ich das ich sehe das er die USB Platte anspricht aber dann passiert nichts mehr, das grüne Led blinckt nicht mehr nur das Rote leuchtet.

    Hofei: Für mich sieht es auch aus als ob er nach dem einstecken der WD Platte meine er müsse von dort aus Booten. Ich verstehe aber absolut nicht warum.

    Grüsse und Dank Joch

  • hyle: Ich wusste schon das USB-3 mehr Strom nimmt. Aber es heisst bei der Platte 100% USB-2 Kompatibel, das müsste die Platte doch auch mit den 0,5A Arbeiten?


    Grüsse Joch

  • Hallo

    hyle: Habs nun gelesen, es tönt nicht so ganz wie ich es gerne hätte. Ich denke ich muss mir in nächster Zeit einen Hub mit Stromversorgung Organisieren und so testen ob die Platte dann läuft. Falls ja sehe ich mich mal um ob es noch Platten mit USB2 gibt.


    Grüsse und Danke joch

  • Servus,

    ... ob es noch Platten mit USB2 gibt.

    schau lieber, ob Du eine Platte bekommst, die mit dem Strom klarkommt.

    USB 2 kompatibel dürfte sich in den meisten Fällen lediglich auf das verwendete Protokoll bzw. die Stecker und deren Belegung beziehen.


    cu,

    -ds-

  • Ich wusste schon das USB-3 mehr Strom nimmt

    nehmen kann! am USB3 Stecker den der PI eh nicht hat!

    Falls ja sehe ich mich mal um ob es noch Platten mit USB2 gibt.

    unnötig, das wäre eher schlecht!


    1. sind die WDpassport 2.5" genügsam, wie schon geschrieben es funktioniert am PI, ich habe 7-8 PI und 6x WDpassport Platten von 1TB bis 3TB, alle mit USB3

    wie ich es gerne hätte

    so ist das Leben, wie ich es mir wünsche gibt es auch selten, aber hier gibt es einfache Lösungen.


    trotzdem wäre es gut mehr Grundlagen zu lernen!


    1. das USB Protokoll schreibt vor das immer mit 100mA gestartet wird.

    2. Erst auf Anforderung einer hi-power device wird 500mA freigegeben

    3. üblicherweise wird das aber auch von vielen Herstellern mißachtet oder ignoriert

    4. ein PI2/3 kann neuerdings eben bis 1200mA für alle 4 USB Ports bereitstellen, nutzt nur nichts wenn mehr dranhängt oder die 1200mA noch nicht eingeschaltet sind.

    5. WDpassport starten an jedem USB Port, mir ist an keinem USB Port je ein Start missglückt, ausgenommen ich hänge zuviel ran!

    6. grundsätzlich sind moderne WDpassport oder USB3 Platten 2.5" allen anderen älteren Lösungen vorzuziehen die am Y-Kabel auch gerne 1A fordern, 2x 0,5A ohne Not!

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

    Edited once, last by jar ().

  • schau lieber, ob Du eine Platte bekommst, die mit dem Strom klarkommt.

    USB 2 kompatibel dürfte sich in den meisten Fällen lediglich auf das verwendete Protokoll bzw. die Stecker und deren Belegung beziehen.

    Das wäre die beste Lösung eine solche Platte zu Kaufen, aber wie so eine Platte finden? Das Problem ist ja das sie scheinbar funktioniert solange sie die einzige am Pi ist. Auch konnte ich die genaue Stromaufnahme nicht finden. Wer kann mir einen Tip geben was funktioniert am Pi zusammen mit USB Sticks? Ich bin halt ein Fan vom Stromsparen. Zurzeit habe ich einen Pi2 mit OS auf USB Stick und Nas auf USB Stick in Betrieb. An dem Funktioniert aber der HDMI Anschluss nicht mehr seit einem Blitzschlag. Filme sehe ich mit mit einem Medienplayer an. Nun möchte ich das alles zusammen nehmen auf dem Pi3. OS auf USB Stick 16Gb, Nas auf USB Stick 256Gb, und wegen dem Platz Filme und Fotos auf USB Platte 1TB. Wegen Spindown und einem weiterem Netzteil bei einem Hub mit Stromversorgung möchte ich darauf verzichten. Das wäre schon eine Schlanke Lösung so mit dem Pi3 mit minimalem Verbrauch. Nur die Platte ist jetzt das Problem. Also was am besten??

    Grüsse und Dank Joch