Raspi hängt manchmal beim Runterfahren und wird glühend heiß

  • Hallo,

    ich habe mich hier angemeldet, weil ich mit einem Problem nicht weiterkomme und auch noch keine Lösungsansätze im Netz gefunden habe.


    Mein aktuelles Projekt ist es, mit einer Kamera meine Wohnung über das Internet beobachten zu können. Dazu habe ich mir einen Raspberry Pi 3B mit dem offiziellen Kameramodul V2.1 und dem Original-Netzteil gekauft. Bisher habe ich erstmal nur Raspian Stretch installiert und dann etwas damit rumgespielt, um ein Gefühl für das System zubekommen.


    Während des Herumprobierens habe ich den Raspi auch oft heruntergefahren oder einen Reboot gemacht. Dabei passiert es ca. bei jedem 3. bis 5. Mal, daß der Raspi sich beim Runterfahren aufhängt und auf nichts mehr reagiert. Damit könnte ich vielleicht noch leben, das Problem ist aber, daß er nach dem Aufhängen extrem heiß wird. Beim ersten Mal habe ich es erst gemerkt, als die Platine schon leicht gerochen hat. Am Prozessor habe ich mir dann fast eine Brandblade am Finger geholt. Seitdem habe ich beim Shutdon schon immer die Hand am Netzteil.


    Woran könnte das liegen, daß der Raspi so heiß wird, wenn er sich aufhängt? Ich würde gern die Möglichkeit vorsehen, ihn bei Bedarf über das Internet neu zu starten oder auszuschalten, aber so habe ich habe ich Angst, daß mir die Bude abfackelt.

  • Hallo hans_d,


    willkommen im Forum! ;)

    Raspian Stretch installiert


    Erzähle uns mal bitte mehr von Deinem System! Hast Du irgendwelche updates gemacht und wenn ja wie bzw. mit welchen Befehlen? Was hängt noch alles am RPi außer der Cam und Netzteil? u.s.w.

    "Alles, was wir sind, ist Sand im Wind, Hoschi."

  • ...das Problem ist aber, daß er nach dem Aufhängen extrem heiß wird. Beim ersten Mal habe ich es erst gemerkt, als die Platine schon leicht gerochen hat....

    Kannst Du genauer eingrenzen wo die Raspi genau heiss geworden ist? Die Platine ist gross ;)

    "Really, I'm not out to destroy Microsoft. That will just be a completely unintentional side effect." Linus Torvalds, 28.9.2003

    >>> raspiBackup: Sichere Deine Raspberry regelmäßig im laufenden Betrieb <<<

  • ich erstmal nur Raspian Stretch installiert und dann etwas damit rumgespielt, um ein Gefühl für das System zubekommen.


    Wenn Du beim Herumspielen die Konfiguration verändert hast, musst Du die Änderungen wieder rückgängig machen, wenn sie nicht das gewünschte Ergebnis bringen... Sonst bastelst Du Dir ein inkonsistentes System zusammen, das manchmal schon zu Beginn der Shutdown Programme hängen bleibt.


    Installuere den Raspi nochmals neu, den Spielfehler wirst Du vermutlich nicht ohne grossen Aufwand finden.



    Servus !

    Wer nichts weiß, muss alles glauben.

  • Hallo hyle,

    vielen Dank für die nette Begrüßung.


    Also ich habe den Raspi erst seit ein paar Tagen und hatte auch erst ein Wochenende Zeit, mich intensiv damit zu befassen.

    Ich bin auch nicht der absolute Experte, was Linux und den Raspberry betrifft.


    Mein System sieht im Moment so aus:


    Am Raspberry hängt die Kamera, ein Monitor über HDMI, ein Ethernetkabel zum Router und ein Unifying-USB-Adapter von logitech für Tastatur und Maus (und natürlich das Netzteil).


    Ich habe das aktuelle Raspian-Image mit Desktop runtergeladen (Datum vom 26.07.2018) und auf die SD-Karte kopiert, dann installieren lassen. Während der Installation wurden automatisch Updates geladen und installiert. Danach war das System der Meinung, auf dem neuesten Stand zu sein. Ich bin dann davon ausgegangen, daß das den selben Effekt hat wie


    sudo apt-get update

    sudo apt-get upgrade


    und habe daher weiter keine Updates manuell eingespielt.


    Dann habe ich noch den Midnight-Commander installiert und die Kamera über motion eingerichtet. Das weitere war dann, alles mögliche auszuprobieren wie Zugriff auf den Kamerastream über das Netzwerk, ssh-Zugang über Netzwerk usw.


    Das wars eigentlich auch schon im großen und ganzen. Ich habe in den Config-Dateien für motion und sshd verschiedene Optionen durchprobiert und dabei das System immer wieder neu gestartet. Das hat auch immer alles wunderbar funktioniert. Der Raspi ist nie im laufenden Betrieb abgestürzt, sondern wenn dann nur beim Runterfahren und auch nur da wird er heiß.


    Dabei spielt es offenbar keine Rolle, ob ich aus dem Desktop runterfahre oder von der Kommandozeile aus, und auch nicht, ob ich das Runterfahren lokal auslöse oder über ssh von einem anderen Rechner.


    framp : heiß wird einer der beiden ICs auf der Oberseite. Das ist mir jetzt sehr peinlich, aber welcher weiß ich gerade nicht, obwohl ich es ja etliche Male getestet habe. Habs in der Aufregung einfach vergessen. Am nächsten WE werde ich das weiter prüfen, dann reiche ich die Info nach.


    RTFM , ja das befürchte ich auch, daß die Fehlersuche langwierig wird. Ich schließe nicht aus, daß ich unbeabsichtigt irgendwo im System was verbogen habe, obwohl ich eigentlich immer nur einen Parameter auf einmal geändert und vor der nächsten Änderung wieder zurückgesetzt habe. Daher werde ich bei der nächsten Gelegenheit das ganze mal mit einem frisch aufgesetzten System testen, auf dem noch gar nichts weiter installiert ist.


    Vielen Dank an euch alle für die schnellen Antworten.

    Grüße Hans

  • Während des Herumprobierens habe ich den Raspi auch oft heruntergefahren oder einen Reboot gemacht. Dabei passiert es ca. bei jedem 3. bis 5. Mal, daß der Raspi sich beim Runterfahren aufhängt und auf nichts mehr reagiert. Damit könnte ich vielleicht noch leben, das Problem ist aber, daß er nach dem Aufhängen extrem heiß wird. Beim ersten Mal habe ich es erst gemerkt, als die Platine schon leicht gerochen hat. Am Prozessor habe ich mir dann fast eine Brandblade am Finger geholt. Seitdem habe ich beim Shutdon schon immer die Hand am Netzteil.

    ja das befürchte ich auch, daß die Fehlersuche langwierig wird. I

    Das sieht nach einem Fehler der Hardware aus. Die Fehlersuche ist einfach. Installiere nochmal ein frisches Image (das kann auch Raspbian lite) sein und prüfe, ob der Fehler wieder auftritt (wovon ich ausgehe). An der Hardware lässt sich erfahrungsgemäß leider nichts reparieren. Der Prozessor wird auf dem Pi bei intensiven Berechnungen schon sehr warm, nichtsdestotrotz hätten sämtliche Schutz- und Energiesparmechanismen lange vor "es roch schon leicht" eingreifen müssen.


    Grüße, STF

    "And now for something completely different."


    Hofeis guide to: Wie frage ich nach Hilfe? *** Mein nagelneuer Raspberry Pi 3B+ zeigt nur ein buntes Bild. (Ab)Hilfe.

  • Warum häuft sich dieses Betriebstemperatur-Phänomen derzeit so dermaßen? Siehe auch folgende Threads (EDIT 20.09.2018 - immer wieder meldet sich jemand):
    Raspberry wird sehr heiß

    pi haengt sich auf beim Herunterfahren

    Liegt hier evtl. ein Qualitätsproblem bei der Fertigung seitens der RPi-Foundation vor?

  • Warum häuft sich dieses Betriebstemperatur-Phänomen derzeit so dermaßen? Siehe auch diesen Thread...

    Liegt hier evtl. ein Qualitätsproblem bei der Fertigung seitens der RPi-Foundation vor?

    Genau das dachte ich auch gerade beim lesen des Threads!


    ein rpi-update wurde nicht zufällig gemacht? (nicht machen ;) )

  • Ich habe das aktuelle Raspian-Image mit Desktop runtergeladen (Datum vom 26.07.2018) und auf die SD-Karte kopiert, dann installieren lassen. Während der Installation wurden automatisch Updates geladen und installiert. Danach war das System der Meinung, auf dem neuesten Stand zu sein. Ich bin dann davon ausgegangen, daß das den selben Effekt hat wie


    sudo apt-get update

    sudo apt-get upgrade

    Wie sind z. Zt. die Ausgaben von:

    Code
    1. dmesg | head -n 5
    2. uname -a
    3. lsmod | grep -i bluetooth
    4. apt-get -s upgrade --with-new-pkgs

    ?


    EDIT:


    Siehe auch:


    https://www.raspberrypi.org/fo…ewtopic.php?f=28&t=222475

    https://github.com/raspberrypi/linux/issues/2681

    Einmal editiert, zuletzt von rpi444 ()

  • Warum häuft sich dieses Betriebstemperatur-Phänomen derzeit so dermaßen? Raspberry wird sehr heiß

    Ganz so wie in diesem Beitrag ist es bei mir nicht. Wenn das System läuft (egal ob Desktop oder Kommandozeile), wird der Chip nicht so sehr heiß, würde ich sagen. Nur wenn sich der Raspi beim Runterfahren aufhängt, dann fängt er fast an zu glühen.

    ein rpi-update wurde nicht zufällig gemacht? (nicht machen ;) )

    Ich hatte bisher nur die Desktopvariante ausprobiert, und da wird während der Installation vorgeschlagen, ein Update durchzuführen. Das habe ich gemacht. Keine Ahnung, ob das ein rpi-update oder ein normales war.


    Ich installiere aber am Wochenende auch mal raspian lite und teste ausgiebig damit direkt nach der Installation, bevor ich irgend etwas am System verändere.

    Einmal editiert, zuletzt von hans_d ()

  • Hallo zusammen!


    Ich habe auch so ein ähnliches Problem, seit gestern.


    Ich habe mich gestern mit Samba gespielt um mit meinem Pi ein Nas zu erstellen.


    Und jetzt passiert es mir immer das mein Pi beim runterfahren hängenbleibt und das Temperaturwarnsymbol rechts oben erscheint. (siehe Foto)

    Der Pi kühlt sich dann auch nicht mehr ab und bleibt dann ziehmlich warm.


    Ich habe versucht den Pi zu kühlen und sobald er ein wenig kühler wird verschwindet auch das Überhitzungssymbol.


    Nach kurzer Zeit taucht es aber dann wieder auf.


    lg

    Lüläs

  • Die jetzige Ausgabe von:

    1. uname -a

    willst Du uns nicht zeigen?

    Doch, aber mein Raspi ist zur Zeit nicht da, wo ich gerade bin:conf:. Wir kommen erst am Wochenende wieder zusammen. Dann schaue ich nach und teste auch weiter.


    Grüße hans

  • Hallo,

    ich habe zunächt Raspian Stretch nochmal neu installiert und damit am Freitag den ganzen Abend rebbootet. Keinerlei Abstürze oder Hängenbleiben, auch nicht nach der Einrichtung der Kamera und der Installation von motion. Ich habe dann versucht, verschiedene Sachen von voriger Woche nachzuvollziehen, aber die Absturzsituation habe ich bis jetzt nicht reproduzieren können. Der Raspi läuft bisher absolut stabil.


    Wenn der Raspi beim Runterfahren hängen bleibt (mit der Installation von letzter Woche), wird der BMC2835 heiß, innerhalb von wenigen Sekunden.


    Der Befehl


    Code
    1. uname -a


    gibt folgendes aus: Linux raspberrypi 4.14.69-v7+ #1141 SMP Mon Sep 10 15:26:29 BST 2018 armv7l GNU/Linux


    Der Pie ist ca. 4 Wochen alt.


    Ich denke, einen Hardwaredefekt kann man sicherlich ausschließen? Also muß ich wohl bei der ersten Installation etwas total vergurkt haben. Was ich im einzelnen und in welcher Reihenfolge alles so gemacht habe, bekomme ich natürlich nicht mehr zusammen. Ich werde das Problem weiter im Auge behalten, kann aber ansonsten im Moment nicht mehr allzuviel Zeit darauf verwenden. Ich hatte ohnehin mal die Idee, eine externe Watchdogschaltung mit einem Attiny o.ä. aufzubauen, die bei Abstürzen die Stromversorgung unterbricht und eventuell den Raspi neu startet. Das werde ich dann wohl auf jeden Fall machen. Damit ist das ursprüngliche Problem nicht mehr ganz so dringend, mir ist wohler und ich kann mich wieder auf meine eigentlichen Projekte konzentrieren.


    Vielen Dank an alle für eure Hilfe und eure Aufmerksamkeit.

    Grüße hans

  • Linux raspberrypi 4.14.69-v7+ #1141 SMP Mon Sep 10 15:26:29 BST 2018 armv7l GNU/Linux


    war die (heisse) Version mit dem shutdown-Fehler ?


    Und was zeigt uname -a jetzt ?



    Servus !

    Wer nichts weiß, muss alles glauben.

  • Sowohl bei der Version mit den Shutdown-Problemen als auch bei der funktionierenden ergibt


    uname -a


    exakt die gleiche Antwort. Sie basieren auch beide auf dem selben offiziellen Image, und zwar diesem:


    2018-06-27-raspbian-stretch.zip (Download von letzter Woche, ist also ganz aktuell)


    Grüße