Bluetooth JBL Go Lautsprecher und Teufel Bluetooth Mute Kopfhörer spuken keinen Ton aus

Heute ist Stammtischzeit:
Jeden Donnerstag 20:30 Uhr hier im Chat.
Wer Lust hat, kann sich gerne beteiligen. ;)
  • Hallo,

    ich bin ganz frischer Rasberyy Pi Model 3+ Besitzer und bekomme via Bluetooth keinen Ton sowohl am JBL Go lautsprecher als auch Bluetooth Kopfhörer Teufel Mute heraus. Beide sind gepairt und connected und lassen sich auch aktivieren, allerdings beim Ton ist Fehlanzeige.

    Weiss jemand bitte Rat?:danke_ATDE:

    PS: Als BS ist das aktuellste Raspian Strecht drauf.

    LG

    dtmblog

  • Bluetooth JBL Go Lautsprecher und Teufel Bluetooth Mute Kopfhörer spuken keinen Ton aus? Schau mal ob du hier fündig wirst!

  • Hallo,

    • bist Du auf der grafischen Oberfläche (=Desktop)?
      Für Konsole müßte man noch was machen.
    • Du hast mit rechte Maustaste auf das Lautsprecher-Symbol in der Taskleiste geklickt und den Bluetooth-Lautsprecher ausgewählt?
    • Die Lautstärke ist nicht Null?
    • wie hast Du "beim Ton ist Fehlanzeige" festgestellt, wie hast Du Ton ausgegeben?

    Schönen Gruß, kle

  • Hi kle,

    es wird kein Ton ausgegeben, obwohl Lautstärke auf 70% ist,

    Ja ich bin auf der graphischen Oberfläche und habe mit der rechten Maustaste den Bluetooth Lautsprecher aktiviert, der auch gepairt und connected ist.

    Was gehört noch im Terminal für Kommandos durchgemacht.

    Lg

    dtmblog

  • Hallo,

    (0) Welches Image hast Du auf die SD-Karte geschrieben?
    Als welcher Benutzer bist Du eingeloggt? Kommando id (im Terminal).

    (1) Mit diesem Kommando, gibst Du direkt auf Bluetooth-Lautsprecher aus, sofern dieser "connectet" ist:

    Du mußt "11:22:33:44:55:66" nur mit der Bluetooth-Mac-Adresse deines Lautsprechers ersetzen:

    aplay -D bluealsa:HCI=hci0,DEV=11:22:33:44:55:66 /usr/share/sounds/alsa/Front_Center.wav

    Hörst Du was?

    (2) Bitte poste mal anschließend die Datei /home/pi/.asoundrc und, falls vorhanden die Datei /etc/asound.conf, beide in Code-Tags das ist das </>-Symbol in dem schwarzen Balken über der Eingabe.

    (3) Bitte poste die Ausgabe von sudo service bluetooth status und

    (4) die Ausgabe von sudo service bluealsa status, beide in Code-Tags.

    (5) Hast Du mit rpi-update den Kernel aktualisiert?

    Das sollte man nicht ohne Not tun und auch nur dann, wenn man sich auskennt.

    Ausgabe von Kommando uname -a

    Hast Du irgendetwas installiert?

    (6) Du kannst auch mal die Lautstärke mit dem Alsa-Mixer prüfen:

    Code
    alsamixer
    Taste "F6"
    scrollen zu "enter a new device name"
    Taste "Enter"
    im Eingabefeld den Text "default" mir "bluealsa"
    Taste "Enter"
    # Du siehst 3 Balken, mit den Pfeil Tasten kannst Du die Lautstärke auf 90% setzen
    # Danach alsamixer beenden mit
    Taste "Esc"

    Du bist am Zug, kle

    Edited 2 times, last by kle (October 1, 2018 at 6:58 PM).

  • Hallo Kle,

    zu Frage 0)

    Rasbian Stretch

    pi@raspberrypi:~ $ id

    uid=1000(pi) gid=1000(pi) Gruppen=1000(pi),4(adm),20(dialout),24(cdrom),27(sudo),29(audio),44(video),46(plugdev),60(games),100(users),101(input),108(netdev),997(gpio),998(i2c),999(spi)

    zu Frage 1)

    Kein Ton zu hören, hier die Fehlermeldung

    pi@raspberrypi:~ $ aplay -D bluealsa:HCI=hci0,DEV=B8:27:EB:59:D7:BC /usr/share/sounds/alsa/Front_Center.wav

    ALSA lib bluealsa-pcm.c:680:(_snd_pcm_bluealsa_open) Couldn't get BlueALSA transport: Kein passendes Gerät gefunden

    aplay: main:788: Fehler beim Öffnen des Gerätes: Kein passendes Gerät gefunden

    2)

    Meine Verzeichnisse in /home/pi/

    pi@raspberrypi:~ $ less home/pi/.asoundrc

    home/pi/.asoundrc: Datei oder Verzeichnis nicht gefunden

    pi@raspberrypi:~ $ pwd

    /home/pi

    pi@raspberrypi:~ $ ls -l

    insgesamt 56

    drwxr-xr-x 3 pi pi 4096 Sep 30 07:39 Desktop

    drwxr-xr-x 3 pi pi 4096 Sep 30 07:39 Documents

    drwxr-xr-x 3 pi pi 4096 Sep 30 07:39 Downloads

    drwxr-xr-x 3 pi pi 4096 Sep 30 07:39 MagPi

    drwxr-xr-x 3 pi pi 4096 Sep 30 07:39 Music

    drwxr-xr-x 3 root pi 4096 Sep 30 07:39 Network Trash Folder

    drwxr-xr-x 4 pi pi 4096 Sep 30 07:39 oldconffiles

    drwxr-xr-x 3 pi pi 4096 Sep 30 07:39 Pictures

    drwxr-xr-x 3 pi pi 4096 Sep 30 07:39 Public

    drwxr-xr-x 3 pi pi 4096 Sep 30 07:39 python_games

    drwxr-xr-x 10 pi pi 4096 Sep 30 08:11 rtl-sdr

    drwxr-xr-x 3 pi pi 4096 Sep 30 07:39 Templates

    drwxr-xr-x 3 root pi 4096 Sep 30 07:39 Temporary Items

    drwxr-xr-x 3 pi pi 4096 Sep 30 07:39 Videos

    - keine Datei asound.conf in /etc vorhanden


    zu 3)

    pi@raspberrypi:~ $ sudo service bluetooth status

    ● bluetooth.service - Bluetooth service

    Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor preset

    Active: active (running) since Mon 2018-10-01 14:59:17 CEST; 1 day 8h ago

    Docs: man:bluetoothd(8)

    Main PID: 579 (bluetoothd)

    Status: "Running"

    CGroup: /system.slice/bluetooth.service

    └─579 /usr/lib/bluetooth/bluetoothd

    Okt 01 14:59:17 raspberrypi bluetoothd[579]: Failed to set privacy: Rejected (0x

    Okt 01 14:59:21 raspberrypi bluetoothd[579]: Endpoint registered: sender=:1.20 p

    Okt 01 14:59:21 raspberrypi bluetoothd[579]: Endpoint registered: sender=:1.20 p

    Okt 01 14:59:21 raspberrypi bluetoothd[579]: RFCOMM server failed for Headset Vo

    Okt 02 22:58:17 raspberrypi bluetoothd[579]: Endpoint registered: sender=:1.13 p

    Okt 02 22:58:20 raspberrypi bluetoothd[579]: Browsing: connect error: Connection

    Okt 02 23:09:49 raspberrypi bluetoothd[579]: Unable to get io data for Hands-Fre

    Okt 02 23:10:28 raspberrypi bluetoothd[579]: Browsing: connect error: Connection

    Okt 02 23:10:37 raspberrypi bluetoothd[579]: No SDP records found for Headset Vo

    Okt 02 23:10:37 raspberrypi bluetoothd[579]: No SDP records found for Headset Vo

    lines 1-19/19 (END)

    4)

    pi@raspberrypi:~ $ sudo service bluealsa status

    ● bluealsa.service - BluezALSA proxy

    Loaded: loaded (/lib/systemd/system/bluealsa.service; static; vendor preset:

    Active: active (running) since Mon 2018-10-01 14:59:17 CEST; 1 day 8h ago

    Main PID: 582 (bluealsa)

    CGroup: /system.slice/bluealsa.service

    └─582 /usr/bin/bluealsa

    Okt 02 22:58:10 raspberrypi bluealsa[582]: /usr/bin/bluealsa: Unsupported AT mes

    Okt 02 22:58:10 raspberrypi bluealsa[582]: /usr/bin/bluealsa: Unsupported AT mes

    Okt 02 22:58:10 raspberrypi bluealsa[582]: /usr/bin/bluealsa: Unsupported AT mes

    Okt 02 22:58:10 raspberrypi bluealsa[582]: /usr/bin/bluealsa: Unsupported AT mes

    Okt 02 23:10:18 raspberrypi bluealsa[582]: /usr/bin/bluealsa: Unsupported AT mes

    Okt 02 23:10:18 raspberrypi bluealsa[582]: /usr/bin/bluealsa: Unsupported AT mes

    Okt 02 23:10:18 raspberrypi bluealsa[582]: /usr/bin/bluealsa: Unsupported AT mes

    Okt 02 23:10:18 raspberrypi bluealsa[582]: /usr/bin/bluealsa: Unsupported AT mes

    Okt 02 23:10:18 raspberrypi bluealsa[582]: /usr/bin/bluealsa: Unsupported AT mes

    Okt 02 23:10:18 raspberrypi bluealsa[582]: /usr/bin/bluealsa: Unsupported AT mes

    5)

    Ja ich habe sowohl Kernel als auch Firmware aktualisiert

    pi@raspberrypi:~ $ uname -a

    Linux raspberrypi 4.14.72-v7+ #1146 SMP Wed Sep 26 16:58:28 BST 2018 armv7l GNU/Linux

    So leider nichts positiveres zu vermelden Kle

  • Hallo,

    --- bitte lese den Post ganz genau ---

    (zu #13) Du hast die Ausgaben nicht in Code-Tags eingefügt, dafür mußt Du in dem schwarzen Balken auf das </>-Symbol klicken, dann wird der Code-Block an der Cursorposition eingefügt, dann die Consolausgabe in den Code-Block einfügen (Copy&Past).

    (zu #13) Du hast mit rpi-update den Kernel aktualisiert. In Beitrag #12 Punkt (5) habe ich davor gewarnt.

    (zu #13) Du beantwortest meine Fragen nicht präziese. Zum Beispiel auf die Frage #10 Punkt(0) nach dem Image, antwortest Du "Raspbian Stretch". Es gibt Raspbian Stretch seit 16.08.2017, deshalb ist das "Release Date" notwendig. Es steht z.B. im Dateinamen oder Du kannst es sehen mit cat /etc/os*.

    --- wenn Du das gelesen und verstanden hast: ---

    mein Rat, fange noch einmal von vorne an:

    1. schreibe das aktuelle "Raspbian Stretch with Desktop" Release Date: 2018-06-27 auf Deine SD-Karte
    2. lege auf dieser SD-Karte eine Datei ssh oder ssh.txt an, damit wird der Zugang über ssh aktiviert.
    3. [optional für WLAN Zugang] lege eine Datei wpa_supplicant.conf mit den Zugangsdaten (ssid, psk) an.
      Code: wpa_supplicant.conf
      country=DE
      ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
      update_config=1
      
      # WPA2
      network={
          ssid="deine wlan ssid"
          psk="dein wlan passwort"
          key_mgmt=WPA-PSK
      }
    4. führe Windows: "Hardware sicher entfernen" durch.
    5. jetzt steckst Du die SD-Karte in den Raspi und schaltest die Stromversorgung ein.
      Netzteil: 5.1V/2.5A --- bei RPi 3B+ notwendig
    6. synchronisiere die Paketlisten mit dem Internet: sudo apt-get update,
      (nicht sudo apt-get upgrade und keinesfalls rpi-update)
    7. jetzt testest Du den Bluetooth-Lautsprecher (neues Device anlegen, Lautspreche auswählen)
      poste Beitrag #10 Punkt (1) - (4) und
      poste die Ausgabe von sudo bluetoothctl -a und paired-devices und info <bluetooth-mac-address>
      ACHTUNG: "<bluetooth-mac-address>" ersetzen mit der Bluetooth MAC Adresse Deines Bluetooth Lautsprechers

    Schönen Gruß, kle

    Edited once, last by kle (October 3, 2018 at 12:19 PM).

  • kle

    da verlangst du zuviel von einem Linux-Laien.

    Ich bin happy,dass ich mit Linux den rasberry schon soweit zum Laufen gebracht habe,

    doch jetzt nochmals neu aufsetzen, da passe ich.

    Erinnert mich stark an meine Windows-Zeiten mit Bluescreen.

    Daher der Wechsel zu Mac Os.

  • Hallo,

    mittlerweile glaube ich Dir nicht, daß der Lautsprecher connectet war.

    Sonst wäre bei raspbian-stretch mit Desktop die Datei /home/pi/.asoundrc vorhanden.

    Sie wird automatisch erzeugt.

    Info für Linux-Anfänger: Dateien deren Namen mit '.' beginnen sind versteckt.

    Sichtbar werden sie mit Kommando ls -a.

    nochmals neu aufsetzen, da passe ich

    gibt es einen Grund dafür, der Raspi ist eine Bastel- und Lernplatine

    • was hast Du denn alles installiert?
    • was hängt am Raspi alles dran?

    Du könntest Dir auch eine weitere SD-Karte kaufen.

    Noch eine Info zu Bluetooth: der interne Bluetooth-Kontroller des RPi 3B[+] belegt die serielle Schnittstelle. Wenn Du die auch brauchst, siehe hier

    Na ja, was solls, :shy: kle

    PS: ich bin kein MS Fan, aber

    Erinnert mich stark an meine Windows-Zeiten mit Bluescreen.

    Erfahrungsgemäß sitzt die Problemursache meistens vor der Tastatur.

  • [OT]

    Hallo dtmblog,

    jetzt bist du nicht damit einverstanden, Raspbian neu aufzusetzen? Das versteh mal einer...

    ich möchte noch etwas zu Umgangsformen loswerden. Ein Minimum an Höflichkeit erleichtert den Umgang im Forum. Meine Beiträge im Forum, schreibe ich nicht gegen Geld oder aus Langeweile, sondern um z.B. Dir zu helfen. Du hast keinen Anspruch darauf. Verwende bitte in Zukunft "bitte" und "danke".

    Schönen Gruß, kle

    [/OT]

  • [OT]

    Hallo dtmblog,

    ich möchte noch etwas zu Umgangsformen loswerden. Ein Minimum an Höflichkeit erleichtert den Umgang im Forum. Meine Beiträge im Forum, schreibe ich nicht gegen Geld oder aus Langeweile, sondern um z.B. Dir zu helfen. Du hast keinen Anspruch darauf. Verwende bitte in Zukunft "bitte" und "danke".

    Schönen Gruß, kle

    [/OT]

    Hallo kle, Vielen Dank für deine Bemühungen,

    ich finde es großartig, wie du versuchst, hier im Forum allen zu helfen, soweit es dir möglich ist.

    LG

    dtmblog

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!