TP-Link TL-WN823N (v3)

  • Hallo und guten Morgen in die Runde,


    ich habe einen RaspberryPi2 mit Raspbian Stretch im Einsatz. Ich habe das Problem das ich den o.g. Wlan Stick nicht installiert bekomme. Habe den Stick durch einen Edimax ersetzt, weil dieser nach kurzer Zeit immer kaputt geht. Die Linux Treiber für den Stick habe ich mir von der TP-Link Seite bereits heruntergeladen. Leider komme ich mit der beigefügten Anleitung nicht weiter (Bin nicht so fit mit Linux).


    pi@raspberrypi:~ $ lsusb

    Bus 001 Device 005: ID 2357:0109

    Bus 001 Device 004: ID 046d:c52b Logitech, Inc. Unifying Receiver

    Bus 001 Device 006: ID 046d:c05b Logitech, Inc. M-U0004 810-001317 [B110 Optical USB Mouse]

    Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter

    Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub

    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


    2.473969] usb 1-1.5: Product: 802.11n NIC

    [ 2.473989] usb 1-1.5: Manufacturer: Realtek

    [ 2.474020] usb 1-1.5: SerialNumber: 00e04c000001

    [ 2.921582] EXT4-fs (mmcblk0p2): re-mounted. Opts: (null)

    [ 3.059536] systemd-journald[92]: Received request to flush runtime journal from PID 1


    Ich hoffe das reicht erst einmal an Daten und bedanke mich schon im Voraus für eure Unterstützung !

  • Moin Sasch72,


    erstmal: Herzlich Willkommen im Forum!


    Es wäre schön, wenn du den Link zu dem Treiber nachliefern könntest. Brauchen wir nicht zu suchen und wir reden dann von der gleichen Software.


    Die Ausgabe sind von einem RaspBian OHNE Änderungen??

    Was sagt lsmod vor und nach dem stecken des Sticks?


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Einmal editiert, zuletzt von Bernd666 () aus folgendem Grund: 2 Fragen hinzugefügt

  • Hallo Bernd,


    vielen Dank für deine Ausführung. Ich werde die benötigten Daten heute Abend zu Verfügung stellen, da ich heute arbeiten muss.


    Bis später.


    Gruß
    Sascha

  • Hallo Bernd,


    hier kommen die gewünschten Daten:


    https://www.tp-link.com/de/download/TL-WN823N.html Das ist der Stick um den es sich handelt.


    lsmod vor stecken des Sticks:


    Module Size Used by

    bnep 20480 2

    bluetooth 368640 7 bnep

    ecdh_generic 28672 1 bluetooth

    fuse 106496 3

    cfg80211 573440 0

    rfkill 28672 4 bluetooth,cfg80211

    joydev 20480 0

    hid_logitech_hidpp 36864 0

    evdev 24576 4

    hid_logitech_dj 20480 0

    snd_bcm2835 32768 1

    snd_pcm 98304 1 snd_bcm2835

    snd_timer 32768 1 snd_pcm

    snd 69632 5 snd_timer,snd_bcm2835,snd_pcm

    fixed 16384 0

    uio_pdrv_genirq 16384 0

    uio 20480 1 uio_pdrv_genirq

    i2c_dev 16384 0

    ip_tables 24576 0

    x_tables 32768 1 ip_tables

    ipv6 434176 42


    lsmod mit eingesteckten Stick:


    Module Size Used by

    bnep 20480 2

    bluetooth 368640 7 bnep

    ecdh_generic 28672 1 bluetooth

    fuse 106496 3

    cfg80211 573440 0

    rfkill 28672 4 bluetooth,cfg80211

    joydev 20480 0

    hid_logitech_hidpp 36864 0

    evdev 24576 4

    hid_logitech_dj 20480 0

    snd_bcm2835 32768 1

    snd_pcm 98304 1 snd_bcm2835

    snd_timer 32768 1 snd_pcm

    snd 69632 5 snd_timer,snd_bcm2835,snd_pcm

    fixed 16384 0

    uio_pdrv_genirq 16384 0

    uio 20480 1 uio_pdrv_genirq

    i2c_dev 16384 0

    ip_tables 24576 0

    x_tables 32768 1 ip_tables

    ipv6 434176 42


    Da würde ich mal sagen, kein Unterschied. Ich hoffe das diese Informationen erst einmal weiterhelfen.


    Danke!


    Gruß

    Sascha

  • Moin Sascha,


    hast du dir den Treiber übersetzt?

    Oder brau7chst du dabei Hilfe?


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

  • Moin Sascha,


    ich bin gerade dabei den Treiber zu compilieren. Aber da ist ein Fehler drin. Nun probiere ich mal den älteren.

    Ich melde mich.


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

  • Moin Sascha,


    also, das alte Teil kennt noch keinen Raspberry. Und, wie gesagt, im neuem Teil kommt es zu einem Fehler beim Laden des Treibers.


    Ich teste die Variante mit dem Kernel noch, aber das halte ich für blöd. Weil man dann nicht automatisch auf den nächsten Kernel updaten kann, sondern sich immer wieder dieser Prozedur unterziehen muß.


    Aber das Testen wird nicht gleich morgen passieren. Ich denke das ich am Wochenende dazu komme.


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

  • Guten Morgen Bernd,


    vielen vielen Dank für deine Mühe. Mach dir bitte keinen Stress. Das hat wirklich keine Priorität. Hatte mir das auch eigentlich etwas einfacher vorgestellt. Aber nun ist es einmal so. Dann lerne ich hoffentlich wieder was dazu.

    Kann ich mir alternativ einen anderen besorgen? Mit welchem hast du denn gute Erfahrungen gesammelt? Du sollst dir ja auch nicht wegen diesem blöden Ding das Wochenende versauen!

    Nochmals vielen Dank und schon mal ein schönes Wochenende...


    Viele Grüße

    Sascha

    Einmal editiert, zuletzt von Sasch72 ()

  • Ich habe mir von Edimax die EW-7612Uan V2 gekauft, funktionieren einwandfrei und ohne Stress.

    Der Stecker ist zwar etwas breit, aber es liegt ein kurzes Verlängerungskabel bei.

    Durch die Antenne ist der Empfang wesentlich besser als bei meinen ersten Wlan-Sticks.

    Aber wegen der Versandkosten etc. habe ich eine Sammelbestellung gemacht.

    Der despotische Bierbaron sagt: Kein Support per PN ! :angel::wink:

  • Dieser hier (TP-Link TL-WN722N) funktioniert auch ganz hervorragend. Wohingegen ich mit dem TP-Link TL-WN822N die gleichen Probleme hatte wie Du jetzt. Generell empfiehlt es sich, vor dem Kauf mal eine Suchmaschine mit den Begriffen "<Typ des WLan Adapters>" und "raspbian" bzw. "raspberrypi" zu füttern. Da kommt dann schon einiges. Aber vielleicht kriegt es Bernd666 ja hin, Dir zu helfen.


    Grüße, STF

    "And now for something completely different."


    Hofeis guide to: Wie frage ich nach Hilfe? *** Mein nagelneuer Raspberry Pi 3B+ zeigt nur ein buntes Bild. (Ab)Hilfe.

  • So ich habe jetzt noch mal meinen alten, zerbröselten X/ Edimax hervorgekramt. Der funktioniert auf Anhieb. Dann werde ich den mal benutzen bis sich etwas anders ergibt. Noch mal vielen Dank an alles die mir versucht haben zu helfen. Ich werde mal gucken was die Zeit so bringt.

    Allen ein schönes Wochenende.


    Gruss

    Sascha

  • Ich habe das Problem das ich den o.g. Wlan Stick nicht installiert bekomme. Habe den Stick durch einen Edimax ersetzt, weil dieser nach kurzer Zeit immer kaputt geht.

    Ähm.... 2 Fragen:


    Verständnisproblem bzgl. deiner oben gemachten Aussage:

    WER ist DIESER?

    Der Edimax oder der TP?


    Und warum geht der <noch auszufüllen> Stick immer nach kurzer Zeit kaputt?

    Also:

    Was heißt kaputt:

    • Läuft überhaupt nicht mehr?
    • Entlässt magischen Rauch?
    • Läuft nicht mehr am RasPi, aber an einem anderen Gerät geht er?
  • Hallo Zentris,


    ich habe mittlerweile drei Edimax Wlan-Sticks "durchgebracht". Nach ca. sechs bis acht Wochen hat sich bei allen das Plastik um den Stick "aufgelößt". Einer davon funktioniert noch einigermaßen (der steckt gerade in meinem Raspi). Leider habe ich Sie nicht getauscht bekommen, da es angeblich ein "Handhabungsfehler" gewesen sein soll.

    Aus diesem Grund habe ich mir den TP-Link TL-WN823N (V3) gekauft. Ich habe eine Seite gefunden wo er als kompatibel aufgeführt wurde. Wahrscheinlich war es die Version V2 oder V1.


    Ich hoffe du hast mich jetzt verstanden. Habe gesehen das ich oben einen Fehler gemacht habe, entschuldige bitte das ich dich verwirrt habe.


    Gruss

    Sascha

  • Edimax Wlan-Sticks "durchgebracht". Nach ca. sechs bis acht Wochen hat sich bei allen das Plastik um den Stick "aufgelößt".

    Hm, ist des Plastik geschmolzen oder hat es sich zersetzt oder sind die Gehäusehälften auseinander gefallen?


    Geschmolzen: Zu heiss? ==> Produktfehler

    Zersetzt?: ==> Umwelteinflüsse (zu) feucht, warm, aggressive Gase in der Umgebungsluft?

    Zerfallen?: :conf:

    ... da fällt mit nix ein...

    Normalerweise steckt man den Stick ja und fasst den kaum noch an... Warum auch...

  • Moin Sascha,


    ich bin dir noch eine Antwort schuldig.

    Also, der Kernel wird wird von mir nicht übersetzt, weil es Quatsch ist. Der Code des Treibers stammt aus dem Jahr 2017.

    Beim Kompilieren des Treibers, bei aktuellen Kernel, geht zwar alles gut, aber beim Installieren kommt eine Fehlermeldung.


    Sri, das ich dir da nicht weiterhelfen kann.


    Falls dein Thema erledigt ist, dann, bitte, oben bei "Thema bearbeiten" als erledigt markieren. Danke.


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

  • Moin Bernd,


    danke erst mal für deine Hilfe. Ich gucke mal wie es da weitergeht. Eventuell kaufe ich mir noch mal einen anderen Stick.


    Gruß

    Sascha