RPi 3B+ / 5 GHz Wlan deaktivieren

  • Hallo,


    habe einen RPi mit FHEM aufgesetzt. Mir fällt auf, dass wenn der RPi3B+ im 5GHz Netz ist, die Website nicht aufgerufen werden kann.


    Schalte ich am Router 5GHz aus, funktioniert alles. Würde auch den internen WLAN-Adapter komplett deaktivieren und wieder einen 2,4GHz USB-Adapter nutzen.


    Jemand einen Vorschlag zur Lösung ?

    Einmal editiert, zuletzt von hwpi ()

  • Mir fällt auf, dass wenn der RPi3B+ im 5GHz Netz ist, die Website nicht aufgerufen werden kann.


    Schalte ich am Router 5GHz aus, funktioniert alles. Würde auch den internen WLAN-Adapter komplett deaktivieren und wieder einen 2,4GHz USB-Adapter nutzen.

    Du könntest in der wpa_supplicant.conf-Datei einen festen Kanal bzw. Frequenz (der dann auch im Router so konfiguriert sein muss) für das 2.4 GHz konfigurieren.

  • Moin hwpi,


    ich frage mich warum das nicht gehen soll?

    Die Funkfrequenz 5 Ghz ist doch nur ein Medium und hat nichts mit dem Protokoll zu tun.

    Funktioniert bei dir am Router was nicht??


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

  • Kann es sein, dass du zwei separate Netzwerke hast? 2.4 GHz für dein Heimnetz und 5.0 GHz für ein Gastnetz? Einige Router bieten diese Trennung an und lassen keine Übergriffe zu.

    Kelvin

  • Und ich würde gern das 5 GHz Netzwerk nutzen, kann mich aber nur über das 2,4 GHz Netzwerk mit dem Raspi verbinden. Kann man das 5 GHz Netz beim Raspi separat einschalten?

  • ich würde gern das 5 GHz Netzwerk nutzen

    Der einfachste Weg ist im Router dem 2.4GHz WLAN und dem 5GHz WLAN verschiedene Namen (=SSIDs) zu geben, dann kannst Du über den Namen (=SSID) Dir das Freuenzband aussuchen.

    Schönen gruß, kle

  • Und ich würde gern das 5 GHz Netzwerk nutzen,

    Weil dein Pi 1m neben deinem Router steht? Sobald eine Wand dazwischen ist, ist der Datendurchsatz um 5GHz Netz schon schlechter als im 2.4er. Jeder FPV Pilot kennt das, bei 5.8Ghz hat man selbst innerhalb eines Raumens schon Bildstörungen.

    Ich würde 5 und 2.4 immer zusammen laufen lassen, so dass er notfalls den 2.4 Ghz fallback machen kann.

    Der Unterschied zwischen Genie und Wahnsinn definiert sich im Erfolg.

  • Sobald eine Wand dazwischen ist, ist der Datendurchsatz um 5GHz Netz schon schlechter als im 2.4er

    alles eine Frage der Ausgangslage.

    Bei mir ist Router und Raspi im selben Raum, 6m voneinender entfernt. Das 2,4GHz Netz ist total überfüllt, zusätzlich benutze ich einen Bluetooth-Lautsprecher im Bad, 3m und eine dünne Wand vom Raspi entfernt. Deshalb benutze ich 5GHz für den Internet-Radio Stream

  • Du kannst das in der wpa_supplicant.conf konfigurieren. Z. B.:

    Code
    1. # Example config file that will only scan on channel 36.
    2. freq_list=5180

    Hat es leider auch nicht gebracht. Ich habe mal in meiner FB nachgeschaut, welche Kanäle gerade von meinen anderen Geräten benutzt werden und die Frequenz entsprechend angepasst, bzw. mehrere Frequenzen benutzt.


    Mein config file /etc/wpa_supplicant/wpa_supplicant.conf sieht übrigens so aus:

    ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev

    update_config=1

    country=DE


    und dann

    freq_list=xxxx


    Wenn ich im Desktop auf das Netzwerksymbol gehe und WLAN eingeschaltet ist steht da

    TURN Off Wi_Fi

    No APs found - scanning



    Was könnte ich nun noch tun?


    Und an #Ewig-Gestriger: Ja, der Pi steht 3 Schritte Luftlinie (mit Luft und nicht Blech oder Wasser dazwischen) von der FB entfernt.

  • Aus deiner Beschreibung kann man nicht erkennen wie deine wpa_supplicant.conf aussieht bzw. wie und wo Du diese ergänzt hast.

    Poste mal (... richtig bzw. brauchbar anonymisiert) in code blocks, deine vollständige und aktuelle wpa_supplicant.conf.

  • Aus deiner Beschreibung kann man nicht erkennen wie deine wpa_supplicant.conf aussieht bzw. wie und wo Du diese ergänzt hast.

    Poste mal (... richtig bzw. brauchbar anonymisiert) in code blocks, deine vollständige und aktuelle wpa_supplicant.conf.

    Code
    1. ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
    2. update_config=1
    3. country=DE
    4. freq_list=5180
  • Da fehlt der network-block, ... und:

    Code
    1. freq_list=5180

    sollte auch im network-block eingetragen sein.

    BTW: War die wpa_supplicant.conf deines PI schon immer ohne network-block?

    Ich habe den Pi ganz neu aufgesetzt mit "2018-11-13-raspbian-stretch.img" und außer dem bei der Installation angebotenen update keine weiteren Programme installiert. Das ist also gewissermaßen das Original.


    Frage: Wo sollte der network-block stehen? In welcher Datei in welchem Verzeichnis?

  • Das ist also gewissermaßen das Original.


    Frage: Wo sollte der network-block stehen? In welcher Datei in welchem Verzeichnis?

    Wie bzw. wo bist Du dann an diese Zeilen:

    Code
    1. ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
    2. update_config=1
    3. country=DE

    gekommen?


    Am Ende der Datei wpa_supplicant.conf (mit chmod 600) und diese im Verzeichnis "/etc/wpa_supplicant/"

  • Keine Ahnung wie die Datei bei einem jungfräulichen System aussieht, bevor das erste mal eine WLAN-Verbindung über das GUI eingerichtet wurde. Ob da schon ein Networkblock existiert?

    //Edit ... und falls ja, was sollte dann darin stehen.

    Zitat

    Ich habe den Pi ganz neu aufgesetzt mit "2018-11-13-raspbian-stretch.img" und außer dem bei der Installation angebotenen update keine weiteren Programme installiert.

    //Edit2 quasimodoz Wir reden aber schon über diese Datei /etc/wpa_supplicant/wpa_supplicant.conf?

  • Keine Ahnung wie die Datei bei einem jungfräulichen System aussieht, bevor das erste mal eine WLAN-Verbindung über das GUI eingerichtet wurde. Ob da schon ein Networkblock existiert?

    Im Beitrag #5 schreibt er:

    Code
    1. ... kann mich aber nur über das 2,4 GHz Netzwerk mit dem Raspi verbinden.

    Wird das dann ohne den network-block möglich gewesen sein? In seinem Beitrag #10 erwähnt er die "/etc/wpa_supplicant/wpa_supplicant.conf"


    EDIT:


    OK, das wäre evtl. möglich wenn er den NetworkManager (oder gleichwertig) benutzt und die SSID bzw. das Passwort dort eingetragen/konfiguriert sind.