RPi3+ nach Installation tot - bereits das 2te mal?

  • Moin andaron,


    ich muss mich erstmal korrigieren.

    Du solltest zumindest den bunten Bildschirm sehen.

    Das ist, zumindest beim RPi2, falsch! ich denke das Besitzer einen RPi 3b+ das bestätigen.


    Beim RPi 2 leuchtet die grüne Led, wenn keine SD gesteckt ist. Aber mir fehlt der Vergleich.


    Alles andere wurde schon geschrieben.


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Nutze doch Berryboot, da kannst Du ca. 30 Dateien auf eine Micro-SD - Karte drauflegen (FAT32)

    und dann starten. Das Betriebssystem schiebst du vom Internet oder von USB-Stick drauf.Die installierten Betriebssysteme kannst Du jederzeit komprimiert absaven , also auf

    USB-Stick mit instalierter Software speichern. Auch Dokumente bleiben erhalten.

  • bist Du sicher, daß die SD-Karte richtig im Slot steckt und die Kontakte sauber sind?

    Wenn ich die SD-Card in den Raspi einstecke, guckt sie noch ca. 2mm raus - um sie auch wieder rausziehen zu können. Damit konnte ich auch schon die Installation durchführen. Nach Abschluss der Installation kommt ein Neustart. Da habe ich die Karte nicht rausgezogen - sie blieb im Slot, so wie sie zuvor funktioniert hat. Nur der Neustart wurde nicht durchgeführt - Installationsroutine beendet, Bildschirm wird dunkel (vermutlich Warmstart) und der Raspi friert ein: rote LED an, grüne LED zeigt kein Lebenszeichen mehr und der Bildschirm sagt: "No Signal". Danach habe ich dann die SD-Card gegen eine andere getauscht (Neuware). Nach Kaltstart (Power off/on) keine Änderung: rot an, grün aus, Screen "No Signal". An den SD-Cards kann es eigentlich nicht liegen.


    Lass Etcher das *.zip entpacken!

    Ok, das habe ich jetzt auch nochmal probiert: Wieder nichts: rot an, grün aus, Screen "No Signal"


    Bernd666 Danke für den Hinweis. Aber ich schlage mich hier mit einem RPi3B+ rum...


    Nutze doch Berryboot,

    Wäre vielleicht eine Idee, wenn der Raspi irgendeine SD-Card lesen würde. Oder gibt es einen Weg ohne SD-Card zu booten? Ich habe keine Möglichkeit gefunden, da das ROM des SoC meines Wissens nach ausschließlich auf den SD-Card-Slot zugreifen kann. Der USB-Anschluß wird erst durch den Kernel aktiviert.


    Schönen Abend noch

    • Official Post

    Langsam wirds komisch seltsam! Nur um sicher zu gehen... Was steht auf Deinem Netzteil hinten drauf? (Firma und Output reicht) Und mach mal bitte ein paar aussagekräftige Fotos von Deiner Hardware, wenn alles angeschlossen ist.


    //Edit: Und dann bitte was Linus schrieb!

  • Probieren wir mal was anderes:

    Er bekommt es nicht mal gelötet ein System auf dem Raspi zu booten, warum auch immer.

    • Official Post

    nur wenn es tatsächlich das von der Foundation ist, sollte es daran ja nicht liegen.

    Soweit ich mich dunkel erinnern kann, gab es mal eins mit weniger Leistung als dem offiziellen NT für den RPi 3, bei dem war die Beere aufgedruckt. Deshalb meine Frage. ;)

  • Mit orakeln kommt man hier wohl nicht weiter. Wenn es schon die 2. Bestellung ist, scheint irgendwo im Ablauf ein entscheidender Fehler zu sein. Wenn der TE im Norden wohnt schaue ich da gerne mal rauf. Aber igendwas passt da nicht.

  • Aus Erfahrung passt da etwa 70-100cm vor dem Bildschirm etwas nicht.

  • Wäre vielleicht eine Idee, wenn der Raspi irgendeine SD-Card lesen würde. Oder gibt es einen Weg ohne SD-Card zu booten? Ich habe keine Möglichkeit gefunden, da das ROM des SoC meines Wissens nach ausschließlich auf den SD-Card-Slot zugreifen kann. Der USB-Anschluß wird erst durch den Kernel aktiviert.

    Berryboot ist erstmal Käse, das bringt nur noch mehr Variabilität. Es gehen ja noch nicht mal einfachste Sachen. Der Pi3B+ boot ohne weiteres natürlich auch von einem USB Stick, diese Funktionalität ist änders als beim 3B bereits freigeschaltet (da muss auch nichts durch den kernel aktiviert werden). PXE übers Netz funktioniert auch ootb, verlangt aber einiges an Vorbereitungen.

  • Probieren wir mal was anderes:

    Schreibe Raspbian oder Raspbian Lite mit Etcher auf die Karte. Aktiviere SSH, indem du eine Datei mit dem Namen ssh (oder ssh.txt) auf der Boot-Partition erstellst.

    Stecke alles vom Pi ab. NT dran. Kannst du dich per SSH mit dem Pi verbinden, wie leuchten die LEDs diesmal?

    Ist wahrscheinlich selbstverständlich und der TE wird das bestimmt auch selbst bedenken, aber sollte nicht zumindest ein Ethernet-Kabel dran bleiben? Ich denke das WiFi wird nicht eingerichtet sein wenn der TE gar nicht bis dahin gekommen ist. Oder hat es soweit gereicht die Einstellungen für das WLAN vorzunehmen?

  • Ich denke, solange die grüne LED sich nicht rührt, sind alle weiteren Versuche überflüssig. Die müsste auf jeden Fall blinken, wenn der Pi bootet.


    Da andaron das jetzt schon zwei mal erlebt hat, erscheint mir ein Hardwaredefekt eher unwahrscheinlich – ich habe allerdings auch keine wirkliche Idee, was es sonst sein könnte. Hauptverdächtiger wäre für mich das Netzteil.

  • – ich habe allerdings auch keine wirkliche Idee, was es sonst sein könnte. Hauptverdächtiger wäre für mich das Netzteil.

    oder eine zu dünne microSD die im PI mies kontaktiert, einige Lagen Tesa unterkleben optimal nicht auf der Kontaktseite könnte helfen.

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

  • [OT]

    Hallo STF,

    Der Pi3B+ bootet ... auch von einem USB Stick, diese Funktionalität ist anders als beim 3B bereits freigeschaltet (da muss auch nichts durch den Kernel aktiviert werden).

    Danke für die Info, wußte ich noch nicht.

    Schönen Gruß, kle

    {/OT]

  • Hallo,

    ich unterstütze Linus' Vorschlag in #25.


    andaron teste ohne zusätzliche Hardware, also nur mit Netzteil, RPi 3B+ und SD-Karte.


    Der RPi 3B+ ist in Bezug auf Netzteil der empfindlichste Raspi.


    Wenn ich meinen RPi 3B+ ohne SD-Karte mit Strom versorge:

    • rote LED: an
    • grüne LED: aus

    Schönen Gruß, kle

  • Hallo mal wieder...


    Also, hier nochmal die Fehlerbeschreibung in Kurzform (wer liest schon einen solchen Thread von Anfang bis Ende genau durch):

    - Neu gekauften RaspberryPi 3B+ mit vorinstallierter SD-Card (aus diesem Paket: Amazon Link (Affiliate-Link)), Tastatur, Maus, Bildschirm angeschlossen

    - NT dran -> rote LED leuchtet auf, grüne LED blink in unregelmäßigen Abständen, Installtionsbild (NOOBS - aus der Erinnerung) erscheint am Bildschirm

    - Verbinden mit dem WLan (Tastatur und Maus funktionieren) und starten der Installation von Raspian

    - warten der ca. 15 Minuten für die Installation, SoC und WLan-Chip werden warm (Fingertest)

    - Bestätigen des Abschlusses der Installation und warten auf den Neustart

    - Bildschirm wird schwarz, rote LED leuchtet durchweg, grüne LED erlischt und leuchtet seitdem überhaupt nicht mehr -> Vermutung: Raspi "tot"

    - NT aus/an, SD-Card Wechsel oder auch ohne, Tastatur & Maus mit/ohne ergeben einzeln oder gemeinsam immer das gleiche Ergebnis: rot an, grün aus, Screen "No Signal" (nur sinnvolle Kombinationen)


    mach mal bitte ein paar aussagekräftige Fotos von Deiner Hardware, wenn alles angeschlossen ist.

    9 Bilder auf Cloud-Speicher (Sorry, keine Ahnung, wie ich Bilder hier im Forum einfügen soll.)

    Kannst du dich per SSH mit dem Pi verbinden, wie leuchten die LEDs diesmal?

    - Nochmals neue SD-Card mit "2018-06-27-raspian-stretch-lite.zip" über "Etcher" beschrieben

    - Leere Datei "ssh.txt" in "/" der SD-Card erzeugt

    - Nur SD-Card, Netzwerkkabel und NT (in dieser Reihenfolge) angeschlossen

    - rote LED leuchtet, grüne LED durchgehend dunkel (kein Blinken, Flackern, Glimmen), LEDs der Netzwerkbuchse durchweg dunkel

    - Raspi erscheint nicht in der Geräteliste des Speedport

    - Raspi ist nicht über "ssh pi@pi3" aus dem Terminal ansprechbar (Befehl laut Beschreibung aus meinem Buch...)

    Wenn der TE im Norden wohnt schaue ich da gerne mal rauf

    Was bedeutet bitte TE? (Ich wohne leider nicht im Norden, trotzdem danke für das Angebot, falls damit eine persönliche Konsultation gemeint ist.)

    Der Pi3B+ boot ohne weiteres natürlich auch von einem USB Stick, diese Funktionalität ist änders als beim 3B bereits freigeschaltet

    Müsste dann nicht die Lampe der optischen Maus leuchten? Tut sie leider auch nicht... (im Falle das Strom am Raspi ist natürlich)


    Ist wahrscheinlich selbstverständlich und der TE wird das bestimmt auch selbst bedenken

    Ja, ich versuche mitzudenken. Aber ich muß zugeben: Aufgrund inzwischen lange ausbleibender Phantasie, wo der Fehler liegen könnte probiere ich geduldig jeden Vorschlag einfach mal durch - auch wenn es manchmal das zweite oder dritte mal ist. Ich bin ja schon froh, das hier noch keiner glaubt, das mein Fehler unter die Kategorie "Versteckte Kamera" fällt. Ich komme mir jedenfalls langsam ein wenig auf den Arm genommen vor - allerdings von dieser kleinen Platine mit ihrer kleinen roten Lampe, als würde die sagen wollen: "Ampel ist rot, in dieser Richtung geht's jedenfalls nicht weiter."


    Hauptverdächtiger wäre für mich das Netzteil.

    Habe gerade nochmal PP7 gegen GND (Pin3) gemessen: 5,24 Volt - zuviel?

    Sollte hier der Fehler liegen, warum hat dann die Installation funktioniert?

    oder eine zu dünne microSD die im PI mies kontaktiert, einige Lagen Tesa unterkleben optimal nicht auf der Kontaktseite könnte helfen.

    Die SD-Cards sitzen gut. Der Fehler trat auch direkt nach der Installation auf, ohne das die SD-Card gewechselt wurde - spricht gegen diese Vermutung.


    Vielen Dank für Eure Mühen

  • "TE" bedeutet Thread Ersteller.


    Wenn ich mir das alles so durchlese, ist die einzige Variable die du noch nicht getestet hast MacOS. Hast du die Möglichkeit die SD Karte an einem Linux oder einem Windows PC zu beschreiben ?

  • - rote LED leuchtet, grüne LED durchgehend dunkel (kein Blinken, Flackern, Glimmen)

    wenn die güne LED nicht mal geblinkt hat ist das suboptimal, dann kannst Du den Rest vergessen.


    INFO: die Datei ssh[.txt] zur Aktivierung von ssh:

    wenn Du die Boot-Partition sehen kannst, gehört "ssh" oder "ssh.txt" flach in die Boot-Partition.

    wenn die SD-Karte im Raspi steckt, wir die Boot-Partition gemountet nach: /boot,

    der Pfad ist dann /boot/ssh bzw. /boot/ssh.txt.


    Schönen Gruß, kle


    Hast du die Möglichkeit die SD Karte an einem Linux oder einem Windows PC zu beschreiben ?

    damit verwendest Du auch mal ein anderes SD-Karten-Gerät.

    Edited once, last by kle ().