Raspberry Pi Ambilight - Kombination Hardware

  • sigi28 danke, werd ich dann auch so machen. Was für eine Aderleitung hast du von der XT60 Buchse zum RemoteBoard genommen? 0,75mm? Und welchen Querschnitt vom XT60 Stecker zum Netzteil? Ich werde ein RPi 3 B+ mit den RemoteBoard verwenden.

    Und reichen für DAT und CLK die einfachen Steckbrücken?

  • Mal zur Anregung hier mein Projekt:


    Hyperion Receiver Vorstellung und Danksagungen


    Ist zwar schon "alt", läuft aber nach wie vor immer noch tadellos!!!!

    Stromverbrauch mit 100 Stück "WS2801" mal kpl. mit 100 % Schwarz und 100 % Weiß meßtechnisch ermittelt und mach Dir da mal keinen Kopf, 100 Watt wirst Du niemals brauchen.

    Zur Farbtreue kann ich Dir aber nur von den WS2801 abraten (damals gab es aber nichts besseres bzw. keine großen Alternativen)

  • sigi28 danke, werd ich dann auch so machen. Was für eine Aderleitung hast du von der XT60 Buchse zum RemoteBoard genommen? 0,75mm? Und welchen Querschnitt vom XT60 Stecker zum Netzteil? Ich werde ein RPi 3 B+ mit den RemoteBoard verwenden.

    Und reichen für DAT und CLK die einfachen Steckbrücken?

    Ja 0,75 mm sind ok.

    Vom XT60 Stecker zum Netzteil habe ich so altes Lautsprecherkabel verwendet, hat relativ großen Querschnitt.

  • Pieper das sieht im Bild sehr gut aus, aber es hat sehr wenig mit der Hardware zu tun die ich nutzen möchte bzw. die die ich schon habe.


    Meine monentane Hardware:

    Raspberry 3 B+

    RemotePi

    Apa102

    Meanwell 5V 26A Netzteil

    HDMI2AV Splitter/Converter

    Grabber


    Ich lese mich nebenbei noch über Spannungsabfall ein, damit ich weiß wieviel wo ankommen muss. Denn damit es Störungsfrei und Leistungsfähig bei mir auch läuft, ist der Querschnitt gewisser Leitungen anscheinend enorm wichtig. Auch eine eventuelle Abschirmung muss ich anscheinend in Betracht ziehen wenn mein RPi nicht unmittelbar am TV liegt bzw. alles nicht auf kurzen Distanzen gekoppelt ist. Aber über jeden neuen Rat oder Vorschlag freue ich mich riesig. Von daher immer her damit8o

  • ja der wird vorerst über ein seperates Netzteil betrieben.

    Naja und die microSD ist nicht mit abgebildet (10GB Class 10)

  • Aber sonst ist alles richtig, sodass ich so auch alles anschließen/verbinden kann und im Anschluss den Softwareteil beginnen kann?

    Und ist es besser den RemotePi nach der Einrichtung anzuschließen, um eine Fehlerquelle auszuschließen?

  • Ich sehe jetzt keinen Fehler, sollte funktionieren. Kannst das Remote Board gleich anschließen.

    Du kannst auch erstmal nur mit der Software beginnen und den Grabber testen und einstellen.

    Willst Du Dein eigenes Image einrichten oder das von mir im Thread? Habe gestern erst neu erstellt und auch das Remote Board Script ist drin.

  • ich würde wahrscheinlich dein Image nehmen. Muss dieses einfach nur auf der microSD entpackt werden und es spart alle Schritte, ausser natürlich die Hyperioneinstellung und die Anbindung ans WLan?

  • noch eine technische Frage:

    arbeiten die GPIOs beim RPi 3 B+ auch mit 3,3 Volt?

    Und wenn ja, kann zu einen level shifter empfohlen werden der dann CLK und DAT auf 5V bringt um einen großen Spannungsabfall zu vermeiden?


    Möchte ungern im Nachhinein wieder mit Lötarbeiten an den Gerät "basteln".

    Einmal editiert, zuletzt von Marc123 ()

  • Wie man auf der Skizzierung sieht wird vom Pi ausgehend nur Data und Clock zum LED geleitet. Diese beiden Leitungen werde ich mittels CAT 7 leiten.

    (V- und V+ werden seperat geleitet.)


    Das CAT7 hat 4 2er Paare und ich werde nur 2 Leitungen brauchen.


    Nun zu zwei meiner Fragen:


    1. Wenn es Sinn macht aufgrund des Spannungsabfall, würde ich zwei 2er Paare an Clock sowie zwei 2er Paare an Data legen. Und somit hätte ich jede Ader genutzt.

    Wird dadurch der Spannungsabfall verringert oder hat es kein Einfluss da man den Querschnitt der einzelnen Leitungen nicht als gemeinsamen zählen kann? Oder kann sich das sogar negativ auswirken?



    2. Ich habe gelesen das es wichtig ist die Abschirmund vom CAT7 immer von beiden Seiten an GND zu legen, sonst wirkt das Kabel wie eine "Antenne". Ist das so richtig?