Internes WLAN deaktivieren und USB-WLAN Stick nutzen

  • Hallo,

    ich möchte an meinem Raspi3 das interne WLAN dauerhaft ausschalten und nur einen USB-WLAN Stick (Realtek RTL8191) mit externer Antenne nutzen.


    Wie mache ich dies am besten?
    Habe was gefunden über die /etc/modprobe.conf/raspi-blacklist.conf ....
    Dann war zwar der interne WLAN-Adapter weg, aber seitdem zeigt mir #ifconfig z.B. auch den eth0 nicht mehr als "eth0" an, sondern als "enxb827eb425c5a" !?
    Die raspi-blacklist.conf habe ich wieder gelöscht (war vorher auch nicht vorhanden), rebootet. Int. WLAn geht wieder (wlan0), aber eth0 heißt immer noch so merkwürdig. Wie kann ich das wieder korregieren?


    Und wie bekomme ich letztlich den USB-WLAN Stick als (z.B.) wlan1 angeboten, so das ich es wie gewohnt konfigurieren kann?


    Danke!

  • Habe was gefunden über die /etc/modprobe.conf/raspi-blacklist.conf ....
    Dann war zwar der interne WLAN-Adapter weg, aber seitdem zeigt mir #ifconfig z.B. auch den eth0 nicht mehr als "eth0" an, sondern als "enxb827eb425c5a" !?
    Die raspi-blacklist.conf habe ich wieder gelöscht (war vorher auch nicht vorhanden), ...

    Wie war der Inhalt der "raspi-blacklist.conf"-Datei?


    BTW: War das der richtige Pfad:

    Code
    1. /etc/modprobe.conf

    ?

  • Ja, gebootet habe ich jedesmal.


    Das mit der Config.txt teste ich.


    Aber woher kommt der "blöde" Name für eth0, und wie bekomme ich den USB WLAN nutzbar? lsusb zeigt mir zwar den Stick. ipconfig zeigt ihn nicht. Und heisst er automatisch wlan1?

  • Wenn ich mich richtig erinnere, kann man den Namen per raspi-config wieder auf eth0 setzen. Bin gerade unterwegs und kann selber nicht nachsehen.

    "Alles, was wir sind, ist Sand im Wind, Hoschi."

  • Hallo, danke euch,

    beide Tipps haben funktioniert,

    eth0 heißt wieder eth0 (Eintrag in der cmdline.txt), und das interne Wifi konnte in der der /boot/config.txt ausgeschaltet werden.


    Der USB WIFI Stick wird nun auch als wlan0 erkannt, aber irgendwie bin ich jetzt unsicher, wo der Stick korrekt konfiguriert werden muss/darf.

    In der /etc/dhcpcd.cond oder in der /etc/network/interfaces; oder in beiden "etwas"?
    Wifi-Name und PW ist in der wpa_supplicant.conf hinterlegt


    DHCP möchte ich nicht nutzen, habe immer feste IP Adressen (im Router ist da ein extra IP-Bereich vorhanden). DHCP dann am Raspi ausschalten?
    Wie? So? # systemctl disable dhcpcd



    Danke!

  • Du kannst auch mit dem dhcpcd feste IP-Adressen konfigurieren bzw. nutzen. Wenn Du das nicht willst, dann kannst Du dhcpcd disablen oder auch deinstallieren, mit z. B.:

    Code
    1. sudo apt-get remove --purge dhcpcd5

    (wenn Du weißt was Du tust). Für die Konfiguration der festen IP-Adresse, dann systemd-networkd verwenden und nicht die interfaces-Datei.

  • Wenn fest IP's auch in der dhcpcd.conf gehen, würde ich das versuchen.

    Aktuell steht der Verweis auf die wpa_supplicant.conf in der /etc/network/interfaces -Datei; kommt der dann auch in dhcpcd.conf?
    Mir ist unklar, was wo stehen darf und muss ...

    Ist die /etc/network/intrefaces dann leer, kann gelöscht werden?

  • Aktuell steht der Verweis auf die wpa_supplicant.conf in der /etc/network/interfaces -Datei; kommt der dann auch in dhcpcd.conf?
    Mir ist unklar, was wo stehen darf und muss ...

    Ist die /etc/network/intrefaces dann leer, kann gelöscht werden?

    Die WLAN-Verbindung ist unabhängig von der Zuweisung der IP-Adresse. Nein, die interfaces-Datei kann nicht gelöscht werden.


    EDIT:


    BTW: Warum willst Du das built-in wifi ersetzen bzw. nicht benutzen. Hast Du evtl. Unzulänglichkeiten für deinen Anwendungsfall entdeckt bzw. festgestellt? Wenn ja, welche?