LXDE Maus/Tastatur Konfiguration wird nicht gespeichert

  • Sorry falls ich bei der Suche blind war…:daumendreh2:


    Ich hab mein Rasp Pi nun zum ersten Mal wirklich am Bildschirm hängen und scheitere schon an etwas Trivialem…:geek:


    Wie kann ich die Einstellung für Mausbeschleunigung und Tastatur dauerhaft unter LXDE einstellen? Ich stelle die Werte ein, aber nach jedem re-login und selbst beim erneuten Starten der LXDE Konfiguration sind wieder die Defaultwerte eingestellt...

  • Guck mal unter /home/pi/.config/lxsession/LXDE-pi/desktop.conf

    unter

    Code
    1. [Mouse]
    2. AccFactor=20
    3. AccThreshold=10
    4. LeftHanded=0


    und unter

    Code
    1. [Keyboard]
    2. Delay=500
    3. Interval=30
    4. Beep=1

    bzw. mit xset mouse x y

    x und y durch Zahlen ersetzen, z.B. 3 0

    Der despotische Bierbaron sagt: Kein Support per PN ! :angel::wink:

  • Zitat

    ~/.config/lxsession/LXDE-pi/desktop.conf


    Das hatte ich auch schon vermutet, doch leider werden die Werte, die ich dort händisch eintrage, auch komplett ignoriert...


    xset mouse 2 0


    resultiert inxset:  unable to open display ""

  • Das Problem hatte ich auch von Beginn an mit RPi 3B und Raspbian Stretch. Siehe hier. In Betrag #7 habe ich ein Workaround beschrieben. Kannst du ja mal probieren und berichten, ob es bei dir funktioniert.

  • Das Problem hatte ich auch von Beginn an mit RPi 3B und Raspbian Stretch. Siehe hier. In Betrag #7 habe ich ein Workaround beschrieben. Kannst du ja mal probieren und berichten, ob es bei dir funktioniert.


    Leider bringt es bei mir keine Abhilfe, die Datei ~/.config/autostart/LXinput-setup.desktop zu bearbeiten oder zu löschen.


    Ich muss allerdings anmerken, dass ich nur die Beschleunigung der Maus einstellen möchte (Defaultwert = 5,0) und den anderen Werten bisher keine Beachtung geschenkt habe. Ich hab nun auch die anderen Werte mal komplett verstellt und siehe da, die Werte bleiben erhalten, selbst wenn ich die Datei ~/.config/autostart/LXinput-setup.desktop komplett ignoriere.


    Mit EINER Ausnahme - die Mausbeschleunigung wird ignoriert, es sei denn ich stelle sie auf Minimum = 0 bzw. Maximum = 10. Abstufungen zwischen den Werten 0 / 5,0 / 10 werden ignoriert, auch wenn ich den Wert manuell in die Datei ~/.config/autostart/LXinput-setup.desktop eintrage.


    Was ist das?? :conf:

    Einmal editiert, zuletzt von Raspita ()

  • Ja, irgendetwas läuft da schief. Das GUI - Einstellungen -> "Tastatur und Maus" dient auch zur Verwirrung. Dies zeigt teilweise die richtigen oder geänderten Werte an, oder nicht. Aber nicht unbedingt was angewendet wird. Auf das was angezeigt wird, kann man sich also nicht verlassen. Die stimmen auch nicht mit den Werten der desktop.conf überein.


    Was ich gemacht habe: Unter Einstellungen -> "Tastatur und Maus" meine Einstellungen vorgenommen. Die werden auch angewendet. Also du merkst das sich der Mauspfeil schneller oder langsamer bewegt. Das gleich mit Tastatur Intervall und Verzögerung. Nach klicken auf OK die Datei ~/.config/autostart/LXinput-setup.desktop löschen und nach Neustart sind die geänderten Einstellungen noch da. Das GUI "Tastatur und Maus" zeigt nun aber eben irgendwas an. Z.B. Mausgeschwindigkeit steht auf 5, läuft aber auf 8. Tastatureinstellungen scheinen zu stimmen und sind gleich mit der desktop.conf. Man darf nun aber nicht mehr auf OK klicken, da sonst die ~/.config/autostart/LXinput-setup.desktop angelegt wird und die Einstellungen stehen auf irgendwas.