FrimpieBox - meine Hörspielbox

  • so, bin gerade dabei nochmal eine Frimpiebox aufzubauen, da ich noch nen alten Raspberry 2B rumliegen hatte. Die Pinbelegung des RPI 3B kann was den RFID Reader angeht 1:1 übernommen werden für den RPI 2B. Ich habe soweit alles neu auf dem Pi installiert und eingerichtet, nur die Musicbox Files habe ich von meiner anderen Box kopiert.

    Und nun zu meinen Problemen:

    1. Den RFID Reader wollte ich ausprobieren wenn ich ne Karte dranhalte und folgendes ausführe:

    Code
    sudo python Read.py

    Jedoch erhalte ich dann jede Menge Fehler.

    Hatte da auch noch was im Hinterkopf bezgl. Python.... und dazu auch schon auf GitHub Hinweise gefunden wie man das Problem(scheinbar) in den Griff bekommt:

    https://github.com/mxgxw/MFRC522-…mment-585122485

    Code
    git clone https://github.com/lthiery/SPI-Py.git
    cd SPI-Py
    git checkout -b 8cce26b9ee6e69eb041e9d5665944b88688fca68
    sudo python setup.py install

    Hab das dann so ausgeführt, Jedoch hat das bei mir leider keine Änderung gebracht.

    2. Den Moc Player wollte ich mal manuell starten

    mocp jedoch erhalte ich dort dann ebenfalls eine Fehlermeldung :(

    Code
    FATAL_ERROR: Error in config file: missing option value on line 6!

    Ich weiß das es ein recht altes Thema ist, aber vielleicht hat jemand nen Tipp für mich,

    Edited 3 times, last by pi_noob15 (January 16, 2021 at 4:52 PM).

  • die Login daten für die Konsole wären ?

    ah... das Tastaturlayout ist nur falsch eingerichtet....z/y ist verdreht

    user: pi

    pw: raspberry

    *update*

    Cardreader und moc player laufen.....Audio an der 3,5mm Buchse :thumbup:

    Hatte nur noch kleine Unstimmigkeiten mit den Files auf dem USB Stick. Mann muss quasi alle audio files direkt ins root verzeichnis auf dem Stick legen. Dann den stick an die Musicbox stecken, nun werden alle files in einen ordner gepackt und beim auflegen der RFIS Karte abgespielt.

    Bei meiner anderen Box lade ich die Ordner ja direkt per FTP Verbindung drauf.

    Das wichtigste geht mal...Jetzt kann ich die restlichen Sachen noch verdrahten wobei das dürft keine Probleme mehr geben.

    Vielen Dank :danke_ATDE:

    Edited 4 times, last by pi_noob15 (January 18, 2021 at 11:12 AM).

  • so die Box läuft zu 90% hab nur noch keinen Laustsprecher für den AMP.

    Aber dafür folgendes Problem......

    An Pin 3 hängt ja bei der Mute Pin für den AMP, wenn der player pausiert oder die Box herunterfährt soll dieser ja den Amp lautlos schalten.

    Wenn die Box hochgefahren ist klappt das auch problemlos, Karte an Reader, Pin3 = 3,3V, Karte Weg, Pin3= 0V.

    Jetzt habe ich nur das Problem das wenn der RPI heruntergefahren ist der Pin3 auf 3,3V liegt -> AMP an.

    Kann man den Pin3 default auf 0V setzen also wenn der RPi aus ist, und auch während des Bootvorgangs?

    Sobald der Player dann startet passt es ja.

    Sind das die beiden Werte oben in der speakerhandler.py bzw. welcher der beiden?

    Edited 2 times, last by pi_noob15 (January 19, 2021 at 5:38 PM).

  • @

    Kann man den Pin3 default auf 0V setzen also wenn der RPi aus ist, und auch während des Bootvorgangs?

    Hallo pi_noop15,

    ich bin jetzt ein bisschen verwirrt ("Sind das die beiden Werte oben in der speakerhandler.py bzw. welcher der beiden?")- aber ich probier's mal:

    beim Raspberry Pi 3 ist es so, dass der Pin 3 initial 3,3V führt und nicht etwa 0. Darum habe ich auch den Transistor und die Schaltung entsprechend gewählt:

    Quote

    "Wichtig ist nur, dass es sich um einen P-Channel Transistor handelt, da die RaspberryPi Ausgänge im Grundzustand 3.3V (und nicht 0V) führen."

    (https://frimpiebox.blogspot.com/p/die-umsetzung.html)

    Somit ist während dem Start der Verstärker aus geschaltet und darum ist es in der Logik auch so umgesetzt, dass speaker_off den Eingang auf 1 (-> 3,3V) bzw. speaker_on auf 0 (0V) setzt:

    In deinem Code, ist das gerade umgekehrt (wobei im init wird der PIN auf 1 gesetzt - was nicht zusammen passt) - warum?

    Falls Pin 3 initial wirklich 0V hat, müsste man

    - einen N-Channel Transistor verwenden

    - diesen zwischen Verstärker Masse und Pi Masse hängen (anstatt zwischen 3,3V vom Pi und 5V des Verstärkers)

    - die Logik umkehren (0 statt 1 und umgekehrt)

    Nun aber konkret zu deiner Frage:

    Beim Raspberry Pi 3 kann man das initiale Verhalten der Ausgänge konfigurieren, was ich auch für die LED mache:

    (https://frimpiebox.blogspot.com/p/die-umsetzung.html)

    Ob das für den 2er auch so funktioniert, weiß ich leider nicht...

    Mal schauen, ob du nun daraus schlau wirst :)

  • hab aktuell ein Problem mit der Box, da ausversehen das Kabel vom Netzteil abgezogen wurde.

    Beim booten der Box kommt nun nach ca. 38 sekunden ein Fehler:

    Code
    Running the server...
    rc.local[335]: It seems that the server is already running with pid 363.
    rc.local[335]: If it is not true, remove the pid file  (/root/.moc/pid) and try again.
    rc.local[335]: FATAL_ERROR: Exiting !
    rc.local[335]: FATAL ERROR  Server exited!

    Sieht für mich so aus, dass er den moc Player nicht starten kann. Aber was kann ich tun ?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!