FrimpieBox - meine Hörspielbox

  • super :) wo lag das Problem wenn man fragen darf ?

    das Problem war im shutdownScheduler - da wird über einen Timer gesteuert, dass die Box nach einer halben Stunde Inaktivität ein shutdown macht und dieser Timer hat den shutdown Prozess blockiert.

    D.h. beim shutdown über den Ausschaltknopf wird der Prozess nicht einfach gekillt (braves Betriebssystem :-), sondern es wird abgewartet, bis er sich beendet. Das hat dann halt eine halbe Stunde gedauert (bis der Timer abgelaufen ist).


    Nun wird der shutdownScheduler benachrichtigt, dass er sich beenden soll, was er dann auch tut.

    D.h. der shutdownScheduler hat nun eine shutdown Methode:

    Code
    1. def shutdown(self):
    2. if self.timer.is_alive():
    3. self.timer.cancel()

    und im exit handler in der musicbox.py wird diese aufgerufen, sobald ein shut down (über den Ausschalt-Knopf) erfolgt:

    Code
    1. def exit_handler(signum=None, frame=None):
    2. shutdown_scheduler.shutdown()
    3. speaker_handler.speaker_off()
    4. rfid_reader.antenna_off()
    5. led_handler.shutdown()
    6. sys.exit(0)
    7. for sig in [signal.SIGTERM, signal.SIGINT, signal.SIGHUP, signal.SIGQUIT]:
    8. signal.signal(sig, exit_handler)
  • ich hab mal noch nen FTP Server installiert zum Transfer der Musik, damit die Box nicht immer aufgeschraubt werden muss.

    Zum testen hab ich mal den RFID Reader und den Raspberry in der Box installiert, war mir unsicher ob es mit dem Empfang klappt durch das Holz.... aber es klappt :)




    Jetzt brauche ich noch kleinere Lautsprecher, die was ich da hatte sind zu groß(10cm).

    Dann kann ich die Frontplatte fertigstellen


    frimp die 1.02 auf Github ist die aktuellste Version

  • die Statusanzeige über die LED funktioniert soweit :bravo2:

    Hab 100Ohm Vorwiderstand drin, ein perfektes Nachtlicht :thumbup:

    Morgen baue ich den Rest ein.


    Einmal editiert, zuletzt von pi_noob15 ()

  • Fertig 👍🏻😊


    Hab die Pullups an den Tastern weggelassen, geht auch ohne.


    Ansonsten ist der rote Taster ->aus/ein

    gelb -> zurück

    blau -> vor


    Der Drehschalter regelt die Lautstärke in 5 Stufen


    Oben rechts die Betriebsled welche auch als Nachtlicht an die Decke Strahlt


    Was ich noch aktuell noch machen muss ist Pin3 an den AMP anzuschließen, da ich beim Ausschalten ein kurzes "plopp" habe. Der Adafruit AMP hat dafür eigens einen Shutdown Pin welcher Low aktiv ist -> GND= AMP aus

    3 Mal editiert, zuletzt von pi_noob15 ()

  • So, mit der neuen Version v1.1.2 wird nun der Verstärker nach einigen Sekunden nach dem Ende des Hörspiels abgeschalten.

    perfekt :thumbup:


    Habe gestern noch den "Mute-Pin" angeschlossen.... war leider invertiert..... habs in der Datei speakerHandler.py manuell angepasst.


    Hier noch ein Bild vom inneren der Box


  • Hallo,

    bin totaler Anfänger. Versuche mich trotzdem hier dran.


    Kann mir jemand helfen:

    In der Anleitung zur Verkabelung des Verstärkers und des Speakers heißt es: "

    • Audio Masse direkt an die Masse der Kopfhörerbuchse anlöten"

    Welches ist die Audiomasse? Das selbe Kabel, dass auch an Netzteilmasse führt?

  • Ja, das war mir verständlich.


    Was ich mich frage ist, wo das schwarze Kabel herkommt. Ich habe vom Verstärker den 5V Masse auf Masse des Raspberry Netzteils gelötet... Ich habe aber kein MusikMasseSchwarzes Kabel...

  • Und noch eine andere Frage: Müsste ich nicht, sofern Verstärker und Lautsprecher nicht angeschlossen sind, trotzdem per Kopfhörer über die Buchse trotzdem Musik hören können?

  • Was ich mich frage ist, wo das schwarze Kabel herkommt. Ich habe vom Verstärker den 5V Masse auf Masse des Raspberry Netzteils gelötet... Ich habe aber kein MusikMasseSchwarzes Kabel...

    Sieh dir den Blog von frimp in #1 an, dann siehst du es.

    Wenn du den GND des Verstärkers mit dem GND des Raspis verbunden hast, hast du automatisch auch die Musikmasse.

    Musikmasse des Raspi = GND Raspi

    Und noch eine andere Frage: Müsste ich nicht, sofern Verstärker und Lautsprecher nicht angeschlossen sind, trotzdem per Kopfhörer über die Buchse trotzdem Musik hören können?

    Ja, müsstest du können.

  • Was ich mich frage ist, wo das schwarze Kabel herkommt.

    Der Verstärker hat Zwei Anschlüsse die mit IN gekennzeichnet sind. Auf dem einen kommt der linke und rechte Kanal über den 1:10 Spannungsteiler, an dem anderen die Masse des Kopfhöreranschluss.
    siehe Schaltbild


    Und wie flippo sagt, ja, man kann den Kopfhörer anschließen.


    flippo : Anfangs (noch vor dem Spannungsteiler) hatte ich extreme Störgeräusche - da konnte man jedes Bit hören, das auf dem Pi geschalten wurde :-)

    Und hab' mich mal etwas eingelesen: https://www.mikrocontroller.net/topic/377414

    Darum habe ich nicht die Masse der Spannungsversorgung auf den Verstärkereingang gelegt. Kann allerdings auch sein, dass der Spannungsteiler das Problem ebenfalls erledigt...

  • Vielen Dank. Das hat mir erstmal geholfen.


    Dann muss ich mal suchen gehen, warum ich über die Kopfhörer nichts höre. Musik ist im richtigen Ordner. Ist es richtig, dass die ID der Karte um 2 oder 3 Stellen länger ist, als der Ordner benannt ist?

  • warum ich über die Kopfhörer nichts höre

    Hmmm - kannst du mal in der raspberry configuration Audio "headphone jack" konfigurieren?

    Wahrscheinlich habe ich das ganz am Anfang mal konfiguriert und habe vergessen das zu dokumentieren...

    Code
    1. sudo raspi-config

    Da sollte es dann unter "Advanced Options" - "Audio" die Möglichkeit geben, den analogen Audio Output auf "3.5mm jack" zu konfigurieren.

    https://www.raspberrypi.org/do…iguration/audio-config.md

  • Kopfhörer im 3,5mm Jacks des RPi. Aktivieren hat nichts gebracht. Kann man irgendwie prüfen, ob der MP3 Player läuft?


    Vielleicht ist es doch zu schwer für mich.

    Einmal editiert, zuletzt von PhilipBe ()