Apache2 und Certbot - fullchain.pem Fehler

  • Hallo,

    ich frage mich gerade ob dies normal ist:


    immer wenn ich in der Konsole meines RPi 3 eingebe:

    Code
    1. apache2ctl configtest

    (oder einen anderen parameter hinter apache2ctl)


    kommt immer die Fehlermeldung:

    Code
    1. AH00526: Syntax error on line 59 of /etc/apache2/sites-enabled/000-default-le-ssl.conf:
    2. SSLCertificateFile: file '/etc/letsencrypt/live/example.de/fullchain.pem' does not exist or is empty


    Aber wenn ich dann eingebe


    Code
    1. SUDO apache2ctl configtest

    Dann funktioniert alles normal.


    Ist das so richtig???


    Also die Datei fullchain.pem existiert unter dem angegebenen Pfad.



    Liebe Grüße und Vielen Dank im Vorraus :danke_ATDE:


    Horst-Leopold

  • Horst-Leopold

    Hat den Titel des Themas von „Apache2 und Certbot - AH00526: fullchain.pem“ zu „Apache2 und Certbot - fullchain.pem Fehler“ geändert.
  • Aber Deine Nutzerkennung hat vermutlich keine Berechtigung, darauf zuzugreifen.

    Hm

    Daran habe ich auch schon gedacht. Aber das ist eigentlich der ganz normale User "pi". Außerdem sind die Ordnereinstellungen so, dass jeder darauf zugreifen kann. Warum geht das dann nicht?


    Warum muss man das immer als Root machen?


    Aber der Apachebenutzer "www-data" hat ebenfalls Zugriff?

  • Dass JEDER" auf di Zertifikate Zugriff hat, ist keine gute Idee. Normalerweise hat der Zertifkatsordner sehr eingeschränbkte Rechte, da es sich um Schlüsselmaterial handelt. Bei mir gehört der Zertifikatsordner und die Zertifikate root mit den Rechten 700.


    Poste doch mal die Apache conf (oder VHost). In der Fehlermeldung steht ja, dass der Pfad nicht passt oder die Datei leer ist.

    Willst du einen Tag lang glücklich sein, dann saufe.

    Willst du ein Jahr lang glücklich sein, dann heirate.

    Willst du ein Leben lang glücklich sein, dann fahr Yamaha.

  • Code
    1. Include /etc/letsencrypt/options-ssl-apache.conf
    2. SSLCertificateFile /etc/letsencrypt/live/example.de/fullchain.pem
    3. SSLCertificateKeyFile /etc/letsencrypt/live/example.de/privkey.pem

    Also ich regele das Meiste über meine VHost Conf.


    Inhalt /etc/letsencrypt/options-ssl-apache.conf


    Code
    1. SSLCertificateFile /etc/letsencrypt/live/example.de/fullchain.pem
    2. SSLCertificateKeyFile /etc/letsencrypt/live/example.de/privkey.pem

    Und diese beiden Ordner existieren mit normalem Zugriff

  • Code
    1. Include /etc/letsencrypt/options-ssl-apache.conf
    2. SSLCertificateFile /etc/letsencrypt/live/example.de/fullchain.pem
    3. SSLCertificateKeyFile /etc/letsencrypt/live/example.de/privkey.pem

    Also ich regele das Meiste über meine VHost Conf.


    Inhalt /etc/letsencrypt/options-ssl-apache.conf


    Code
    1. SSLCertificateFile /etc/letsencrypt/live/example.de/fullchain.pem
    2. SSLCertificateKeyFile /etc/letsencrypt/live/example.de/privkey.pem

    Und diese beiden Ordner existieren mit normalem Zugriff

    Also dies sind die Einstellungen von Certbot

  • geh mal in den Ordner /etc/letsencrypt/live (als root) und zeig mal die Ausgabe von ls -la

    Eventuell stimmen wirklich die Rechte nicht. Bei mir gehören die Dateien root:root mit den Rechten -rw-r--r--

    Willst du einen Tag lang glücklich sein, dann saufe.

    Willst du ein Jahr lang glücklich sein, dann heirate.

    Willst du ein Leben lang glücklich sein, dann fahr Yamaha.

  • geh mal in den Ordner /etc/letsencrypt/live (als root) und zeig mal die Ausgabe von ls -la

    Eventuell stimmen wirklich die Rechte nicht. Bei mir gehören die Dateien root:root mit den Rechten -rw-r--r--

    Code
    1. drwx-w--w- 3 root root 4096 Nov 3 12:51 .
    2. drwxrwxrwx 9 root root 4096 Nov 11 20:23 ..
    3. drwxrwxrwx 2 root root 4096 Nov 3 12:51 example.de
  • Wie setze ich Verzeichnisse 755 und den key 600? Kannst du mir bitte einen Befehl geben?

    mit chmod (siehe man chmod). Andere frage... wenn du Grundlagen wie chmod nicht kennst, wieso beschäftigst du dich dann mit Webservern? Das kann böse enden... :no_sad:

  • Du unterhältst einen, wahrscheinlich aus dem Internet erreichbaren, Webserver, kennst aber nicht die Basics der Linux Rechteverwaltung/-vergabe, au weia.


    Lies bitte u.a. "man chmod" und überdenke dein Handeln.


    no offense, btw.

    Fragen sind genau dann dumm, wenn sie mit dem Manual, Google, DuckDuckGo oder gar

    (dieses ist die schlimmste Alternative!)

    von der FAQ beantwortet werden! [strcat.de]