Wie konfiguriere ich das ABelectronics RS485 Shield auf dem Raspberry

  • Ich habe zwei Stück RS485 Aufsteckshields von ABelectronics.

    Jetzt finde ich für den Raspberry keine Konfigurationsanleitung für diese RS485, sondern nur USB-RS485 Anleitungen.

    Hat jemand dieses RS485 Aufsteckshield schon einmal konfiguriert oder einen Hinweis wo ich dazu Informationen finde?

    Lg


    Chris


    Raspberry Pi 2/2+/3/3+


    Jessie, FHEM
    RFXtrx433E, SIGNALduino, nanoCUL433MHz & 868MHz, HomeMatic


    FS20, IT, HomeMatic, WMR200, TEK603, YouLess, APC, SUSV, Resol VBUS, Fronius DataloggerWeb2

  • Moin Burny,


    schon mal HIER nachgelesen??


    Tut mir leid das es dich nun trifft....


    Mir ist es schon mehrfach aufgefallen, das sich hier Leute melden, die nicht wissen wie sie ihr neues Zusatzteil konfigurieren sollen. Kümmert man sich nicht eigentlich vorher um sowas?ß


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

  • Den Hinweis habe ich gelesen, nur was bringt der bei einem Pi2+.

    Hier gibt es kein Bluetooth.

    In der /boot/cmdline.txt steht der passende Eintrag.

    dwc_otg.lpm_enable=0 console=tty1 console=serial0,115200 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait

    Da ich keine USB Schnittstelle mehr frei habe, möchte ich das Shield verwenden und bin leider davon ausgegangen das dies ähnlich dem USB/RS485 entspricht.

    Da gebe ich dir Recht das mann sich vorher informieren sollte.

    Jetzt suche ich eine Info wie ich die Schnittstelle lokal oder für ser2net einrichte. Leider bin ich noch nicht fündig geworden.

    Lg


    Chris


    Raspberry Pi 2/2+/3/3+


    Jessie, FHEM
    RFXtrx433E, SIGNALduino, nanoCUL433MHz & 868MHz, HomeMatic


    FS20, IT, HomeMatic, WMR200, TEK603, YouLess, APC, SUSV, Resol VBUS, Fronius DataloggerWeb2

  • Burny

    Hat den Titel des Themas von „Wie konfiguriere ich das ABelectronics RS485 Shild auf dem Raspberry“ zu „Wie konfiguriere ich das ABelectronics RS485 Shield auf dem Raspberry“ geändert.
  • Moin Burny,


    naja, das Shield nutzt die serielle Schnittstelle und BT nutzt sie halt auch.


    Ich habe mal die Einträge von der Seite gemacht. Auch ein RPi2.


    Habe sowohl in der cmdline.txt als auch in der config.txt die Änderungen gemacht. Reboot...

    Und ich habe eine /dev/serial0


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

  • Hallo Bernd.


    Die Datei serial0 ist auch bei mir im Verzeichnis /dev vorhanden.


    ~ $ ls -l /dev/ttyAMA0

    crw--w---- 1 root tty 204, 64 Nov 10 15:51 /dev/ttyAMA0


    ~ $ ls -l /dev/serial0

    lrwxrwxrwx 1 root root 7 Nov 10 15:50 /dev/serial0 -> ttyAMA0


    Somit müsste ich dann unter /dev/ttyAMA0 auf die RS485 zugreifen können.

    Lg


    Chris


    Raspberry Pi 2/2+/3/3+


    Jessie, FHEM
    RFXtrx433E, SIGNALduino, nanoCUL433MHz & 868MHz, HomeMatic


    FS20, IT, HomeMatic, WMR200, TEK603, YouLess, APC, SUSV, Resol VBUS, Fronius DataloggerWeb2

  • Moin Burny,


    nee, nach meinem Verständnis auf /dev/serial0


    Aber das kann man ja testen.


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

  • Gut das werde ich testen wenn ich den RS485 Link hergestellt habe.

    Danke einstweilen.

    Lg


    Chris


    Raspberry Pi 2/2+/3/3+


    Jessie, FHEM
    RFXtrx433E, SIGNALduino, nanoCUL433MHz & 868MHz, HomeMatic


    FS20, IT, HomeMatic, WMR200, TEK603, YouLess, APC, SUSV, Resol VBUS, Fronius DataloggerWeb2