Raspberry Pi3 bootet nicht mehr hoch ( emergency mode .. ohne weitere Möglichkeit des Weiterkommens .. ?! )

  • Hallo liebe Mitstreiter :conf:


    ich bräuchte mal dringend Hilfe..

    Da ich meine Himbeere als "Gehirn" meiner SmartHome Lösung mit iobroker nutze und in dem Zusammenhang natürlich ein

    möglichst sicheres System am Start haben möchte, habe ich nach einer Lösung gesucht, ein automatisches, regelmäßiges Backup

    auf einem angeschlossenen USB Stick zu realisieren , nachdem man irgendwann endlich alles , wie gewünscht laufen hat..


    Weder hatte ich Glück (.. oder genug Geschick :daumendreh2:) mit RaspiBackup ein ordentliches Backup zu realisieren ( Backup brach immer mit Fehler ab),

    und schon gar nicht damit, den USB Stick dauerhaft im System erkannt zum laufen zu bekommen..


    Gestern war dann leider der Tag, an dem ich neu booten mußte.. Und siehe da.. Natürlich habe ich noch nichts gesichert :cursing: .. und...

    NATÜRLICH BOOTET DIE KISTE JETZT NICHT MEHR HOCH... !!! :@:@


    Wenn ich das richtig interpretiere, hat das jetzt irgendwas mit dem vorher eingerichteten USB Stick zu tun .. oder sehe ich das falsch ??


    .. nach einiger Zeit kommt dann folgendes .. :



    .. und dann ist leider hängen im Schacht.. und weder mit Enter noch mit CTRL-D , ESC oder was auch immer komme ich weiter..

    .. geschweige denn , an irgendeine Möglichkeit einer Konsoleneingabe ... :no_sad: Natürlich auch nicht über Putty vom anderen Rechner ...


    HHHIIIIILLLFFFEEE !!!!!!! :wallbash:



    .. Vielen Dank erst schon einmal , daß Ihr Euch meines Frustes hier überhaupt annehmt..

    Ich hoffe auf irgendeine Art Hilfe..


    LG aus Hagen


    Andre

  • Weder hatte ich Glück (.. oder genug Geschick :daumendreh2:) mit RaspiBackup ein ordentliches Backup zu realisieren ( Backup brach immer mit Fehler ab),

    und schon gar nicht damit, den USB Stick dauerhaft im System erkannt zum laufen zu bekommen..

    Abbruch mit Fehler gibt es so in Linux nicht. Jeder Fehler hat einen Grund und der wird auch angezeigt.

    Jetzt hast Du weder ein funktionierendes Backup, noch ein funktionierendes root-Filesystem. Mach jetzt wenigstens ein Image der SD am Windows Rechner, damit Dir die restl. Daten nicht auch noch verlorengehen. Und danach boote in eine Shell, den recovery/emergency Modus [1] oder diagnostiziere das root Filesystem mit einem anderen Linuxsystem (Live CD, USB Stick).


    Ich fürchte nur, dass Du mit einer root-Shell (zur Diagnose und zur Fehlerbehebung) wenig anzufangen weisst, sodass es Deiner Eigeneinschätzung überlassen bleibt, das System gleich neu aufzusetzen.



    Servus !


    [1] https://www.freedesktop.org/wi…re/systemd/TipsAndTricks/ (Changing Default Boot Target)

    Wer nichts weiß, muss alles glauben.

    3 Mal editiert, zuletzt von RTFM ()

  • Hallo,

    bei mir war mal ein schwaches Netzteil am "emergency mode" schuld.

    Der Akku eines über USB angeschlossenen Lautsprechers war fast leer.


    1. Tipp zum Fehlersuchen: Welcher Raspi? Was hängt am Raspi alles dran? Welches Netzteil verwendest Du?

    Schönen Gruß, kle

  • Das sieht mir irgendwie nach nem fstab-Fehler aus... oder einer, der daraus hervorgeht. Ich würde mal alle zusätzlichen (!!!!) Einträge in der fstab mit # kommentieren und nur die zwei system-Partitionen stehen lassen und dann die SDC wieder reinstecken und neu booten.