Apt-get problem: Segmentation fault, Fehler 127, broken pipe

  • Hallo, mein Raspi3 läuft eigentlich nach einem Reboot noch mit Fhem usw aber ein Programm (speedport-cli) will wegen einem "Speicherzugriffsfehler" nicht mehr.


    Nach dem ich das Paket neu installieren wollten ergaben sich merkwürdige Fehlermeldungen zu python-pkg-resources, die ich nicht mehr wirklich einordnen kann.

    Jemand eine Idee?:/


  • Da scheint ja diese Python-Paket nicht zu funktionieren, daher bringt das leider nichts.

    Die blöden Sonderzeichen kommen scheinbar über die ConnectBot-App.

  • Wie gesagt vermute ich den speedtest-cli nicht als ursächlich, sondern als Opfer der Python-Problems.


    Code
    1. pi@raspberrypi:~ $ which speedtest-cli
    2. /usr/local/bin/speedtest-cli
    3. pi@raspberrypi:~ $ pwd
    4. /home/pi
    5. pi@raspberrypi:~ $ ls -la speedtest-cli
    6. -rwxr-xr-x 1 pi pi 61423 Dez 3 14:50 speedtest-cli
    7. pi@raspberrypi:~ $ ./speedtest-cli
    8. Speicherzugriffsfehler
  • Die 16GB SD-Karte ist ca. 2 Jahre alt, 12 GB frei

    Dieser interne Error wundert mich, liegt evtl auch daran dass ich schon ein paar andere per Google gefunden Tipps angewendet habe,


    sudo rm -rf /var/cache/apt/*.bin

    sudo rm -rf /usr/bin/apt-listchanges/*.*


  • Da passiert nix. Backup habe ich natürlich , da muss ich wohl eine andere Speicherkarte nehmen?(

    Code
    1. pi@raspberrypi:~ $ sudo dpkg --configure --pending
    2. pi@raspberrypi:~ $ speedtest-cli
    3. Speicherzugriffsfehler
  • Hat leider auch nichts gebracht

    Probiere gerade: sudo dpkg -i /var/cache/apt/archives/*.deb

  • Hat leider nicht gebrachts, das dpkg war wohl mittlerweile zu sehr durcheinander.

    Habe das BackUp auf eine andere SD-Card gespielt, läuft erstmal wieder.