Autostart Problem

  • Hi,


    Ich betreibe einen RPi3B+ mit Rapsbian Stretch. Nun möchte ich einen Dienst "homebridge" beim Booten automatisch starten, was aus irgendeinem Grund nicht funktioniert.


    Was ich gemacht habe...


    1) Habe editiert "sudo nano /etc/init.d/homebridge" und folgendes eingefügt:



    Lasse ich mir nun den Status vom Dienst homebridge anzeigen, so erhalte ich folgendes:

    Das klappt aber nur, weil in init.d/homebridge steht:


    Quote


    1. cmd="homebridge"


    Ich muss homebridge aber mit dem Parameter "-I" starten.

    Ändere ich es auf "cmd=homebridge -I", so erhalte ich bei der Statusanzeige folgenden Fehler:


    Ich weiß also nicht genau, wie ich dem homebridge-Aufruf lediglich noch den Parameter "-I" mitgeben kann, ohne in einen Fehler dadurch hinein zu laufen.


    Daher: Wie gebe ich bei obigem init.d/homebridge den Parameter mit ?


    Hinweis: homebridge liegt scheinbar unter home/pi/.homebridge... der Aufruf scheint aber zu funktionieren. Das verwirrte mich nur, weil in init.d/homebridge steht:

    Code
    dir="/home/pi"


    Kann jemand helfen ?

  • 1) Habe editiert "sudo nano /etc/init.d/homebridge" und folgendes eingefügt:

    Warum wird im Status der generierten service unit, "sudo" angezeigt?

    Code
    CGroup: /system.slice/homebridge.service
    ├─1912 sudo -u pi homebridge
    ├─1919 homebridge
    └─1943 homebridge-config-ui-x
    Dez 21 23:06:28 piVCCU systemd[1]: Starting LSB: Start daemon at boot time...
    Dez 21 23:06:28 piVCCU homebridge[1910]: Starting homebridge
    Dez 21 23:06:28 piVCCU sudo[1912]: root : TTY=unknown ; PWD=/home/pi ; USER=pi ; COMMAND=/usr/local/bin/homebridge

    BTW: Statt eine service unit aus dem Start-Stop-Script generieren zu lassen, könntest Du doch auch eine native service unit erstellen/schreiben.

    The most popular websites without IPv6 in Germany.

  • Hm, da kann ich leider nicht ganz folgen...


    Letztlich habe ich init.d/homebridge, was homebridge problemlos aufrief, lediglich um den Startparameter -I erweitern wollen.


    Wie kann ich homebridge denn mit dem Parameter -I beim Booten korrekt starten lassen ?

  • Hm, da kann ich leider nicht ganz folgen...

    Jetzt habe ich es gesehen, ... die Zeilen 38 und 40 in deinem S-S-Script:

    Code
    sudo $cmd >> "$stdout_log" 2>> "$stderr_log" &
    else
    sudo -u "$user" $cmd >> "$stdout_log" 2>> "$stderr_log" &

    Mach mal dort "sudo" raus, denn das wird eh mit root-Rechten gestartet.

    The most popular websites without IPv6 in Germany.

  • Okay, aber in Zeile 40 stünde dann:

    -u "$user" $cmd >> "$stdout_log" 2>> "$stderr_log" &


    korrekt wäre doch aber eher:

    $cmd >> "$stdout_log" 2>> "$stderr_log" &


    Oder ?

  • korrekt wäre doch aber eher:

    $cmd >> "$stdout_log" 2>> "$stderr_log" &


    Oder ?

    Evtl. musst Du den if/else/fi-Block ändern.

    The most popular websites without IPv6 in Germany.