Raspian Wheezy und deutsche Tastatur

  • Hi,
    hab eine Logitech K400 Tastatur/Maus am Pi/B. Bisher keine Probleme damit.
    Seit Wheezy Raspian V. 2012-10-28 wird die Tastatur beim Hochfahren nicht spontan erkannt, ich muss erst einmal den Adapter unpluggen. Ausserdem wird das englische Tastatur-Layout beibehalten, wenn ich versuche das über raspi-config zu ändern. Hat jemand eine Idee dazu? Hat sich ggü. den älteren Images etwas geändert?
    Danke,
    Christoph

  • hast du es schon versucht es via Konsole zu ändern ?


    Code
    sudo nano /etc/default/keyboard
    
    
    XKBMODEL="pc105"
    XKBLAYOUT="de"


    Code
    sudo dpkg-reconfigure keyboard-configuration

    I sometimes feel that I have nothing to say and I want to communicate this.

    Edited once, last by klecks ().


  • hast du es schon versucht es via Konsole zu ändern ?


    Code
    sudo nano /etc/default/keyboard
    
    
    XKBMODEL="pc105"
    XKBLAYOUT="de"


    Code
    sudo dpkg-reconfigure keyboard-configuration


    Hi,
    ja, habe ich. In der keyboard datei steht es korrekt aber es passiert nicht.
    Christoph

  • sind alle Updates für das OS installiert worden ?


    Code
    sudo apt-get update && sudo apt-get upgrade -y


    hast du zum testen auch einen andere USB-Tastatur da?

    I sometimes feel that I have nothing to say and I want to communicate this.

  • Ja, die Updates sind aktuell.
    Ein anderes 'echtes' USB-Keyboard habe ich blöder Weise gerade nicht da. Kann ein Boot-log weiterhelfen ( wo finde ich das :) ? )?
    Christoph

  • Logfiles findest Du bei Linux üblicherweise in /var/log.
    Das System-Log ist /var/log/messages, die letzten Meldungen kannst Du Dir auch mit 'dmesg' anzeigen lassen.

  • Hi,
    nur um das vernünftig abzuschliessen:
    Ich hab mir ein anderes Keyboard besorgt und damit funktioniert alles ohne weiteres problemlos. Es wäre zwar nicht ganz uninteressant herauszufinden, warum das alte Keyboard nicht mehr funktioniert, aber ich hab keine Zeit mehr. Also: Thema erleditscht. Vielen Dank.
    Christoph

  • Hallo,


    ich hab das selbe Problem mit der Logitech K-400.


    Zwar ist in Config die Tastatureinstellung auf DE, trotzdem habe ich immer das englische Layout.


    Der Bluethooth Dongle steckt direkt im Raspberry Pi, der 2. USB Slot ist leer.


    Irgendjemand Ideen wie das zu lösen wäre?


    danke
    Zand0r

  • Quote from Zand0r pid=7156 dateline=1362564360


    Irgendjemand Ideen wie das zu lösen wäre?


    Ja: Nimm eine andere Tastatur.
    Die K400 verträgt sich nicht mit dem Pi und wenn Du ein Problem gelöst hast stolperst Du über ein anderes.

  • Bin das erste Mal hier im Forum und hänge mich gleich einmal mit einer Frage/Bemerkung an den Thread:


    Tastatur Logitech K400r - dasselbe Problem. Nach Boot in Kommandozeile ist das deutsche Layout korrekt, sobald ich den X Terminal Service starte und dann ein Terminalfenster öffne, wird wieder nur das englische Tastaturlayout verwendet.


    Jetzt aber: wenn ich direkt das deutsche Layout mit "sudo setxkbmap de" setze, erhalte ich sofort das deutsche Layout wieder - allerdings nur bis zum nächsten Start des X Terminals.


    Wo kann ich das Mapping dauerhaft verändern, sodass die ganze Chose ein Reboot übersteht? Ich dachte immer, mit der raspi-config wäre das erledigt.


    Klaus

  • Hallo Klaus,


    versuchs doch einfach mal indem du deinen Befehl in die "~/.bashrc" einfügst. Diese wird beim öffnen einer Shell automatisch ausgeführt und sollte dann auch dein Tastaturlayout umstellen.


    Gruß Georg

  • Hallo Georg


    danke für deine Antwort: ich habe noch ein wenig gesucht (das Internet ist ja ein Dorf) und etwas gefunden, was deinem Vorschlag ja entspricht. Das funktioniert tadellos. Bliebe zu wünschen, dass die Entwickler dieses Problem vielleicht im nächsten Release lösen können.


    Klaus

  • Guten Abend,


    ich nutze ebenfalls die Tastatur Logitech K400r und kämpfe mit dem skizzierten Problem "deutsche Tastatur, aber englische
    Sprachausgabe". Mit der obigen Anleitung gelingt mir die temporäre Umstellung für die aktuelle Session ausgezeichnet, aber bei der dauerhaften
    Umstellung gemäß der sich hinter dem Link verborgenen Anleitung scheitere ich.


    Könnte das bitte jemand Anfänger-geeignet darstellen? Offensichtlich interpretiere bzw. setze ich ein Zeichen fehlerhaft um. Danke!

  • Hallo Georg,


    Danke für Deine Unterstützung! Ich beziehe mich auf Raspbian.


    Ich gehe davon aus, dass ich die Befehle als Root oder mit dem Vorspann "sudo" (jede Zeile?) eingeben muss. (?)


    Müssen für "Ctrl + o" bzw. "Ctrl + x" alle drei Tasten gleichzeitig gedrückt werden? Ist das deutsche oder englische Tastenlayout gemeint?


    Wie muss ich die Befehle abschließen und aktivieren? Fenster schließen und anschließend "Logout" und "Login"?

  • Hallo Kettenfett,


    Quote

    Ich gehe davon aus, dass ich die Befehle als Root oder mit dem Vorspann "sudo" (jede Zeile?) eingeben muss. (?)


    Nein, die Befehle führst du als normaler Benutzer aus. Hier eine etwas ausführlichere Beschreibung was du machen musst.


    Zuerst erstellst du in deinem Heimatverzeichnis die Datei ".xsessionrc" mit einem Editor.


    Code
    nano ~/.xsessionrc


    In diese Datei fügst du die folgende Zeile ein. Diese ändert beim Starten einer X-Session das Tastaturlayout.


    Code
    setxkbmap de


    Wenn du diese Zeile eingefügt hast, speicherst du die Datei und beendest Nano mit Ctrl+X. Sobald das erledigt ist führst du einfach einen Neustart durch. Es würde auch ausreichen wenn du die aktuelle X-Session über Logout beendest und dich dann erneut anmeldest.


    Gruß Georg

  • (1) diese Datei mit dem vi-Editor öffnen --> vi /etc/xdg/lxsession/LXDE/autostart


    (2) folgenden Inhalt reinschreiben:


    @lxpanel --profile LXDE
    @pcmanfm --desktop --profile LXDE
    @xscreensaver -no-splash
    @setxkbmap -model pc105 -layout de
    @setxkbmap -option lv3:ralt_switch_multikey
    @setxkbmap -option grp:switch,grp:alt_shift_toggle,grp_led:scroll


    Viel Erfolg ;)