HifiBerry Amp2

  • Hallo ich habe mir einen CarPi gebaut und habe bisher den klinken Ausgang des Pi verwendet um den Externen Verstärker im Auto zu versorgen.

    Jetzt würde ich das ganze mit einem HifiBerry Amp2 betreiben um mir den "externen Verstärker" zu sparen.

    Aufgebaut ist das ganze Wie folgt 7"Touchdisplay-Pi-Hifiberry Amp2.

    Installiert habe ich das ganze wie auf der Homepage von Hifiberry beschrieben. Im System lässt sich auch der Amp2 auswählen. Allerdings kommt kein ton.

    Die Stromversorgung wird über ein 12v Netzteil sichergestellt.


    Hat jemand eine Idee wie ich das Problem in den griff kriege?

    mfg


    2 Mal editiert, zuletzt von anchorman85 ()

  • Ich habe hier einen AMP2 mit moodeaudio 4.4 einwandfrei laufen.

    Code
    1. cat /boot/config.txt
    2. disable_splash=1
    3. hdmi_drive=2
    4. dtparam=i2c_arm=on
    5. dtparam=i2s=on
    6. dtparam=audio=off
    7. dtoverlay=hifiberry-dacplus
    8. #dtoverlay=pi3-disable-wifi
    9. #dtoverlay=pi3-disable-bt

    Ich vermisse bei Dir den Eintrag:

    Code
    1. dtparam=i2s=on

    3 Mal editiert, zuletzt von MacNobi ()

  • dtparam=i2s=on war in der tatnicht in der config.txt Ich habe es jetzt hinzugefügt allerdings ohne erfolg


    Einmal editiert, zuletzt von anchorman85 ()

  • Hallo anchorman85,


    welchen Player verwendet Dein CarPi? Funktioniert es mit dem vorinstallierten OMXPlayer z.B. omxplayer /Pfad/zu/einem/Song.mp3?

    "Alles, was wir sind, ist Sand im Wind, Hoschi."

  • in der /boot/overlays/README hab ich das hier gefunden


  • Moin anchorman85,


    ist es denn sicher das hifiberry auch card0 ist?


    Siehe lcat /proc/asound/cards .


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

  • 0 [ALSA ]: bcm2835 - bcm2835 ALSA
    bcm2835 ALSA
    1 [sndrpihifiberry]: snd_rpi_hifiber - snd_rpi_hifiberry_dacplus
    snd_rpi_hifiberry_dacplus


    und das sagt aplay -l

    Code
    1. pi@raspberrypi:~ $ aplay -l
    2. **** List of PLAYBACK Hardware Devices ****
    3. card 0: sndrpihifiberry [snd_rpi_hifiberry_dacplus], device 0: HiFiBerry DAC+ HiFi pcm512x-hifi-0 []
    4. Subdevices: 1/1
    5. Subdevice #0: subdevice #0

    Einmal editiert, zuletzt von anchorman85 ()

  • Moin anchorman85,


    woher hast du die Einstellungen, die du in der asound.conf stehen hast?


    Auf der hifiberry-Seite steht:


    Zitat

    Create /etc/asound.conf with the following content:

    Code
    1. pcm.!default { type hw card 0
    2. }
    3. ctl.!default { type hw card 0
    4. }

    Make sure you have no .asound.conf file with different settings in your home directory (you might simply delete it if there is one). Reboot again now.


    DAC+, AMP2

    While there are a lot of mixer controls on the DAC+, you only need to care about one named “Digital”.

    Du hast eine Einstellung für Karten, die keinen hardware volume control haben.


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

  • Meine Einstellungen hatte ich aus anderen Foren von Usern die ein ähnliches Problem hatten und es somit gelöst hatten.

    Die Einstellung des Herstellers funktionieren leider auch nicht.

    Der CarPi lauft auf Linux 4.4xxx und Kodi 15.2

  • Moin anchorman85,


    machst du die Versuche an deinem Echtsystem?

    Hast du wenigstens ein Backup gemacht?


    Gut, kannst du das Ganze wieder in den Originalzustand bringen.


    Dann in der /boot/config.txt diese Zeile dtoverlay=hifiberry-dacplus einfügen und diese Zeile dtparam=audio=on löschen bzw. mit # ungültig machen.

    Die /etc/asound.conf so ändern das nur nachfolgendes drin steht:

    Code
    1. pcm.!default {
    2. type hw card 0
    3. }
    4. ctl.!default {
    5. type hw card 0
    6. }

    Kontrolle ob es in /home/pi/.asoundrc vorhanden ist. Wenn ja, löschen.

    Kontrolle mit aplay -l ob hifiberry das einzigste Sounddevice ist.


    Dann in einer Konsole speaker-test -c2 -Dplughw:0 -twav eingeben.


    Mal sehen was dann passiert.


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Einmal editiert, zuletzt von Bernd666 () aus folgendem Grund: Hinweis von Kle

  • Hi ich habe jetzt die oben beschrieben schritte befolgt allerdings ohne erfolg.

    das sagt aplay -l

    pi@raspberrypi:~ $ aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 0: sndrpihifiberry [snd_rpi_hifiberry_dacplus], device 0: HiFiBerry DAC+ HiFi pcm512x-hifi-0 []
    Subdevices: 1/1
    Subdevice #0: subdevice #0

    der speakertest bringt leider keinen ton.

    Das steht im Alsamixer

    Card: snd_rpi_hifiberry_dacplus


    pi@raspberrypi:~ $ sudo speaker-test -c2 -Dplughw:0 -twav

    speaker-test 1.0.28

    Playback device is plughw:0
    Stream parameters are 48000Hz, S16_LE, 2 channels
    WAV file(s)
    Playback open error: -16,Device or resource busy

    Einmal editiert, zuletzt von anchorman85 ()

  • Moin anchorman85,


    das wäre zu schön um wahr zu sein...


    Egal.

    Von dem CarPi ist nicht irgendwas aktiv und klaut uns das Device?

    sudo speaker-test -c2 -Dplughw:0,0 -twav

    Füge mal das rot geschrieben ein.

    Und was sagt eigentlich aplay -L?? Man achte auf das grosse L!!


    Geb mal ein alsa-info ein. Das Programm fragt was, mit N beantworten. Das Ergebnis ist dann so ähnlich

    Zitat

    Your ALSA information is in /tmp/alsa-info.txt.0HKded38TI

    Die Ausgabe würde mich interessieren.


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Einmal editiert, zuletzt von Bernd666 () aus folgendem Grund: Was dazu geschrieben

  • Moin


    alsa-info kennt er nicht

  • Moin anchorman85,


    das sieht doch schonmal gut aus.

    Wichtiger ist aber, hörst du was??


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"