Vom Raspberry auf ein NAS Festplatte zugreifen.

  • Hallo zusammen,

    ich finde immer den umgekehrten Weg aber nicht das was ich suche im netz oder auch hier.


    Ich habe ein Raspberry Pi 3 dieser soll als Plex Meinen Server diesen und Inhalte Filme etc. im Netzwerk über Plex zur Verfügung stellen.

    Ich habe eine Apple Time Capsule auf der eine Filmbibiliothek vorhanden ist. Da jetzt Raspberry der Medienserver ist möchte ich gerne das der PI auf genau diese Bibliothek Zugriefen kann, um die Daten zur Verfügung zu stellen.


    Wenn ich von einem Normen PC oder auch Mac den Medienserver installiere dann kann ich mittels Netzwerkfreigabe und smb auf die Daten der Time Capsule also NAS zugreifen aber bei dem Raspberry wird mir nichts angezeigt. Ich denke mann muss hier was installieren oder freigeben. Kann mir jemand hierbei weiter helfen. ?


    Wie mach ich ein bereits vorhandene Netzwerkfestplatte auf dem Raspberry sichtbar und kann vom Raspberry drauf zugreifen. Von meinem Mac aus z.B. kann unter dem Finder auf geh zu (mit Server verbinden gehen und mittels folgendem Kommando: smb://192.168.0.3 erhalte ich ein Abfrage nach Benutzer und Passwort und bin dann auf den Daten der Festplatte von der Time Capsule.

  • So genau oder ähnlich geht das auch unter Raspbian. Du kannst die Netzwerkfestplatte am RPi mounten (man mount) um darauf zu zugreifen. Suche mal im Forum, da gibt es diverse Themen. Oder hier.

  • sudo mount -t cifs //192.168.0.3/freigabe /Data/freigabe -o user=[xxx xxxx],pass=xxxxxx


    So müsste es doch gehen oder ?


    Ich erhalte aber eine Fehlermeldung


    Das ist bestimmt das einfachste auf der Welt für erahnende user wie euch etwas zu mounten. Ich Kappier es aber nicht.

  • Eine fertige Kommandozeile, die dann auch funktioniert, kann dir keiner liefern. Das wäre Zufall/Glückssache. Aber in dem Link, den ich dir gegeben habe steht ein Beispiel Aufruf (das mit der FritzBox). Den musst du entsprechend anpassen. Zusätzlich zum Testen bietet sich an die Mount Option -f zu benutzen. Ohne, müssten fehlgeschlagene Mount Versuche jedesmal mit umount rückgängig gemacht werden. Das vers=1.0 kannst du auch erst mal weglassen. Das ist für Fritz.nas nötig.


    Die Freigabe und der Mountpunkt müssen ans Ende. Aber sonst sieht das schon gut aus.

    Einmal editiert, zuletzt von daxb ()

  • Dein Anleitungs Link stammt vom "October 19, 2011"


    Da kannst Du nicht erwarten, dass das einfach so noch heute funktioniert.
    Derzeit kann z.B. ein Cifs-Mount nicht mehr ohne (Windows-) User/Passwd ausgeführt werden.


    Schau Dir einfach die User Kommentare ab 2015 an.


    Mit Punkt 2. meinst Du 2) Run this program at boot .... ?



    Servus !

    Wer nichts weiß, muss alles glauben.

  • Hallo,


    ich habe schon vieles ausprobiert aber komme nicht zum Ziel. Ich verstehe es einfach nicht.

    Ich würde daher gerne einen andren Weg versuchen. Ist es möglich ein Laufwerk aus dem Netzwerk nicht auch über die Desktop Oberfläche auf dem Raspberry zu mounten. Also ohne Linux Terminal befehle ?


    Vielleicht komme ich damit besser zurecht.


    Wenn ich z.B. auf denPunkt Netzwerk im Desktop gehe, dann zeigt er mir sogar die Time Capsule an. Wenn ich jedoch darauf klicke dann erhalte ich eine Fehlermeldung nichts gefunden oder so. Zeit Überschreitung etc.


    Es Mist doch bestimmt möglich über den Desktop das ganze einzubinden oder. ?

  • - ich habe schon vieles ausprobiert aber komme nicht zum Ziel.

    - Wenn ich jedoch darauf klicke dann erhalte ich eine Fehlermeldung nichts gefunden oder so. Zeit Überschreitung etc

    Was probiert? Welche Fehlermeldungen GENAU?


    Ich würde daher gerne einen andren Weg versuchen. Ist es möglich

    Nein, das sieht so aus, als ob das nicht funktioniert. Liegt imho daran, dass Deine Freigabe nur altertümliche Protokolle spricht, die allenthalben extra aktiviert werden müssen.


    Hier eine mögliche Lösung. Die wichtigsten Optionen scheinen sec=ntlm und vers=1.0 zu sein.


    Grüße, STF

  • Wenn ich z.B. auf denPunkt Netzwerk im Desktop gehe, dann zeigt er mir sogar die Time Capsule an. Wenn ich jedoch darauf klicke dann erhalte ich eine Fehlermeldung nichts gefunden oder so. Zeit Überschreitung etc.

    Den User "ich" gibt es in einem Mehrbenutzer-Betriebsystem so nicht.


    Das "Netzwerk" aus dem Browser steht dem aufrufenden User nur dann zur Verfügung, wenn ihm eine Freigabe erteilt wurde und/oder er Mitglied der freigegebenen (Netzwerk)Gruppe ist. Der Zugriff ist auch nur aus dem Browser während derselbsen Sitzung möglich und es wird auch kein für alle User verwendbarer Mount erstellt.


    Die zahlreichen erfolglosen Änderungen in der Konfiguration solltest Du erstmals rückgängig machen, den Eintrag in die /etc/fstab löschen/auskommentieren, ein "umount" auf den fehlerhaften mount ausführen und dann (nach lesen vpn < man mount > und < man mount.cifs > ) zuerst einen manuellen mount mit den Optionen: --fake, --verbose; _netdev, X-mount.mkdir, uid=xx , gid=xx , username=xx , password=xx .... machen.

    bis der --fake Mount fehlerfrei funktioniert. In etwa:

    (root) mount -fv -t cifs -o _netdev, ..... //192.168.0.3/freigabe /mnt/timecapsule


    Wenn kein Fehler mehr angezeigt wird, kannst Du die fake Option weglassen (also statt -fv nur mehr -v) und einen echten mount probieren.


    Bei Deinem Marsch quer über die Betriebssysteme (Windows, Aplle, Linux) solltest Du auch überlegen eine eigene Gruppe für Dein Gesamtvorhaben zu erstellen.


    Servus !

    Wer nichts weiß, muss alles glauben.

    Einmal editiert, zuletzt von RTFM ()

  • sudo mount -t cifs //192.168.0.3/freigabe /Data/freigabe -o user=[xxx xxxx],pass=xxxxxx

    Das wäre ziemlich falsch. Im Link sieht das Beispiel so aus:

    Code
    1. sudo mount -t cifs -o username=XXX,password=YYY,vers=1.0 //fritz.nas/FREIGABE MOUNTPOINT


    Wenn ich das -f, -v (zum Testen) und sec=ntlm von STF dazu nehme, dann wäre das das Ergebnis:

    Code
    1. sudo mount -f -v -t cifs -o username=XXX,password=YYY,vers=1.0,sec=ntlm //192.168.0.3/freigabe /Data/freigabe

    Der Mountpunkt /Data/freigabe sollte/muss der komplette Pfad sein. Vermutlich dann /home/pi/Data/freigabe? Wichtig ist auch die richtige Schreibweise. Es wird zwischen Gross- und Kleinbuchstaben unterschieden. Data wäre nicht gleich data. Versuche das mal umzusetzen und teile uns eine mögliche Fehlermeldung mit.


    Edit: Den Beitrag von RTFM hatte ich noch nicht gesehen, als ich das hier geschrieben habe.

  • Hallo zusammen,

    vielen Dank erst einmal für den Support.


    daxb

    Ich habe den Befehl wie folgt eingegeben:

    sudo mount -f -v -t cifs -o username=[xx ss],password=xyzxyz,vers=1.0,sec=ntlm //192.168.0.3/home/pi/Airport

    Couldn't chdir to //192.168.0.3/home/pi/Airport: No such file or directory


    Zuvor hatte ich noch das Verzeichnis eingebunden mit:


    Code
    1. mkdir /home/pi/Airport


    Ich erhalte jedoch folgende Fehlermeldung:


    Couldn't chdir to //192.168.0.3/home/pi/Airport: No such file or directory

  • Hi Hyle;


    das mit dem Dateiexplorer smb://192.168.0.3 hatte ich auch schon direkt ausprobiert. Es passiert dabei garnichts. Ich erhalte auch keine Fehlermeldung. Normalerweise müsste die Abfrage nach Benutzer und Passwort kommen. Kommt aber nicht.




    Mit dem Leerzeichen erhalte ich wieder die Fehlermeldung:


  • Wie kann ich eigentlich auf die Desktop Oberfläche des Raspberry Zugriefen. Perr ssh Verbindung habe ich ja nur den Terminal und muss um was zu überprüfen wie jetzt mit dem Freigabename wieder an den TV und alles stöpseln.

  • Damit erhalte ich ne Fehlermeldung

    Code
    1. pi@raspberrypi:~ $ sudo smbclient -L //192.168.0.3
    2. WARNING: The "syslog" option is deprecated
    3. Enter root's password:
    4. Server does not support EXTENDED_SECURITY but 'client use spnego = yes and 'client ntlmv2 auth = yes'
    5. session setup failed: NT_STATUS_ACCESS_DENIED
  • Ich habe nichts von "sudo" geschrieben.

    Wenn dein User auf dem 192.168.0.3 nicht "pi" heisst, muss du den auch noch angeben:

    smbclient -L //192.168.0.3 -U deinusername

    Das S in IOT steht für Sicherheit.