Failed to start /etc/rc.local Compatibility.

  • Beim Systemstart meines aktuellen Raspbians listet er auf was er macht und kurz vor Schluss kommt folgende Fehlermeldung:


    Failed to start /etc/rc.local Compatibility.

    See `systemct] status rc-local.service` for details.

    Starting Hold until boot process finished up...

    Starting Terminate Plymouth BootScreen...


    Ich weiss nicht was das bedeutet, das System macht sonst keine auffaelligen Probleme. Ich hatte die Aufloesung geaendert und die eine oder andere Software installiert, seitdem kam das irgendwann. Weiss jemand was das bedeutet und wie man das fixen kann?

    Raspberry Pi 3
    Raspian GNU/Linux 8.0 (Jessie)
    Kernel: 4.9.35-v7*

  • 1.

    pi@raspberrypi:~ $ cat /etc/rc.local

    #!/bin/sh -e

    #

    # rc.local

    #

    # This script is executed at the end of each multiuser runlevel.

    # Make sure that the script will "exit 0" on success or any other

    # value on error.

    #

    # In order to enable or disable this script just change the execution

    # bits.

    #

    # By default this script does nothing.


    # Print the IP address

    _IP=$(hostname -I) || true

    if [ "$_IP" ]; then

    printf "My IP address is %s\n" "$_IP"

    fi

    /usr/bin/numlockx on

    exit 0



    2.

    pi@raspberrypi:~ $ systemctl cat rc-local.service

    # Warning: rc-local.service changed on disk, the version systemd has loaded is o

    # This output shows the current version of the unit's original fragment and drop

    # If fragments or drop-ins were added or removed, they are not properly reflecte

    # Run 'systemctl daemon-reload' to reload units.

    # /lib/systemd/system/rc-local.service

    # This file is part of systemd.

    #

    # systemd is free software; you can redistribute it and/or modify it

    # under the terms of the GNU Lesser General Public License as published by

    # the Free Software Foundation; either version 2.1 of the License, or

    # (at your option) any later version.


    # This unit gets pulled automatically into multi-user.target by

    # systemd-rc-local-generator if /etc/rc.local is executable.

    [Unit]

    Description=/etc/rc.local Compatibility

    ConditionFileIsExecutable=/etc/rc.local

    After=network.target


    [Service]

    Type=forking


    3.

    pi@raspberrypi:~ $ systemd-analyze blame

    21.668s nmbd.service

    7.633s hciuart.service

    3.223s apt-daily.service

    1.912s dev-mmcblk0p2.device

    1.647s apt-daily-upgrade.service

    1.546s raspi-config.service

    1.342s networking.service

    1.210s smbd.service

    925ms lightdm.service

    923ms dphys-swapfile.service

    543ms keyboard-setup.service

    491ms exagear-guest-raspbian-8.service

    407ms systemd-fsck-root.service

    393ms rc-local.service

    383ms systemd-fsck@dev-disk-by\x2dpartuuid-fce36bff\x2d01.service

    369ms systemd-timesyncd.service

    339ms run-rpc_pipefs.mount

    337ms dhcpcd.service

    336ms sys-kernel-debug.mount

    336ms triggerhappy.service

    328ms systemd-udev-trigger.service

    319ms colord.service

    305ms systemd-logind.service


    4.

    pi@raspberrypi:~ $ systemd-analyze time

    Startup finished in 1.824s (kernel) + 27.556s (userspace) = 29.381s

    Raspberry Pi 3
    Raspian GNU/Linux 8.0 (Jessie)
    Kernel: 4.9.35-v7*

  • Ist das alles?

    Welches raspbian hast Du auf deinem PI? So sieht das z. B. auf meinem stretch aus:

  • Ich habe das allerneueste Raspbian.


    Wie aendere ich den Eintrag? Ich habe ein Tool installiert womit beim Start automatisch Numlock aktiviert wird. Ich besitze einen Keyrah Adapter damit meine Amiga 1200 Tastatur wenigstens ein Laempchen leuchtet. Scheinbar hat es damit zutun (?).

    Raspberry Pi 3
    Raspian GNU/Linux 8.0 (Jessie)
    Kernel: 4.9.35-v7*

  • Fehler ist weg, danke! Aber der Startbildschirm erscheint nicht, stattdessen listet er mir beim starten auf was er macht. Wie kann ich de Startbildschirm wieder aktivieren?

    Raspberry Pi 3
    Raspian GNU/Linux 8.0 (Jessie)
    Kernel: 4.9.35-v7*

  • Ne, dieser Eintrag fehlt voellig in der config.txt. Hatte ihn manuell eingefuegt, aber leider ohne Erfolg.


    Stimmt, ist eigentlich ein anderes Thema. Aber dadurch kam der Fehler zum Vorschein. Vielleicht hat das System das extra gemacht damit man den Fehler sehe nkann (?).

    Raspberry Pi 3
    Raspian GNU/Linux 8.0 (Jessie)
    Kernel: 4.9.35-v7*

  • Thema trotzdem soweit erledigt, habe vielen Dank. Vielleicht mache ich einen neuen Thread auf falls Google nichts dazu findet.

    Raspberry Pi 3
    Raspian GNU/Linux 8.0 (Jessie)
    Kernel: 4.9.35-v7*

  • Jo, wieder Volltreffer, das war es gewesen, danke dir! Frage mich nur wie sich das umstellen konnte, ich habe dort nichts gemacht.

    Raspberry Pi 3
    Raspian GNU/Linux 8.0 (Jessie)
    Kernel: 4.9.35-v7*