Airport Extreme mounten

  • Hallo zusammen,


    ich hab ein Problem eine Festplatte zu mounten, da ich noch neu bin.


    Sachlage ist so: Ich habe mehrere Raspberrys auf denen das RPi Cam Web Interface installiert ist. Diese nehmen zu bestimmten Zeiten Videos auf. Da die SD Karten zu klein sind, um alle Videos zu speichern, wollte ich diese auf einer externen Festplatte speichern. Habe im Internet stundenlang rumgegoogelt und ausprobiert, aber kriegs nicht hin.

    Ich habe einen Apple Airport Extreme, der nicht mit dem Internet verbunden ist. Die Festplatte ist an den Airport angeschlossen. Die Router-Adresse ist 192.168.0.1. Der Router war zwischenzeitlich ans Internet angeschlossen. Die Festplatte heißt laut Airport-Dienstprogramm WD Elements 25A2 1019.


    Ich habe mit meinem Laptop über PuTTY in den Raspberry eingeloggt und einen neuen Ordner erstellt:

    mkdir /home/pi/Airport


    dann hab ich eingegeben:

    sudo nano /etc/fstab


    in der letzten Zeile hab ich dann eingetragen und gespeichert:

    //192.168.0.1/WD\ Elements\ 25A2\ 1019 /home/pi/Airport cifs user=pi,password=password,file_mode=0777,dir_mode=0777,sec=ntlm


    Wenn ich dann eingebe:

    sudo mount -a


    kommt der Error: mount: /etc/fstab: parse error at line 6 -- ignored


    Wenn ich aber die Leerzeichen nach dem Backslash entferne kommt: mount error(101): Network is unreachable


    Ich weiß einfach nicht mehr weiter und hänge schon mehrere Stunden davor. Wenn jemand eine andere oder bessere Idee hat, kann er sie auch vorschlagen. Beachtet werden muss nur, dass die Pis und der Router oder Laptop zzgl. Festplatte keinen Zugang zum Internet haben, wenn sie aufnehmen.


    Dankeschön.


    Grüße, Marc

  • Hey,

    hab ich versucht. Bei Windows angeschlossen heißt die Festplatte Science, auch wenn ich die an einem Mac über ne Virtual Machine angeschlossen habe. Aber im Airport-Dienstprogramm heißt sie immer so, egal was ich bei Windows eingegeben habe.

  • Dass die Platte im AP Dienstprogramm diesen komischen Namen hat ist schon seltsam. Das kenne ich von meiner Extreme so nicht. Da hat die angeschlossene Platte den selben Namen wie sie auch im Netzwerk heißt.

    Wie ist die Platte denn formatiert? Die Extreme versteht sich am besten mit MacOS Extended (Journaled). Ansonsten gehen noch FAT16 oder FAT32.

    Schau doch mal von anderen Rechner wie die Platte im Netzwerk heißt. Ich vermute stark es liegt am falschen Namen oder die Festplatte an sich ist falsch eingerichtet.

  • Bevor ein mount in die /etc/fstab eingetragen wird, sollte er erstmals manuell funktionieren.

    Deshalb den fehlerhaften Eintrag erstmals löschen, oder # auskommentieren.


    In /etc/fstab ist ein Leerzeichen ein "Delimiter" (Begrenzungszeichen), so steht es zumindest in < man fstab >, ausserdem fehlen die Felder 5 und 6.


    Dein fstab Eintag würde manuell gemountet lauten:

    #> mount -t Elements\ -o 25A2\ 1019 //192.168.0.1/WD\


    probiere einmal als root:


    mount -h

    mount -fv -t cifs -o user=pi,password=password,file_mode=0777,dir_mode=0777,sec=ntlm "//192.168.0.1/WD\ Elements\ 25A2\ 1019" /home/pi/Airport


    Da bekommst Du alle noch möglichen Fehler angezeigt (-v verbose) und der Befehl wird tatsächlich noch nicht ausgeführt (-f fake = cold run). Dann kannst Du die Sonderzeichen uncl. Leerzeichen lt < man mount > im Mount-Ursprung noch beliebig berichtigen, wenn tatsächlich dem User pi nur "/WD\ Elements\ 25A2\ 1019" freigegeben werden kann.


    Servus !

    RTFM = Read The Factory Manual, oder so

  • Leerzeichen vermeiden ist immer eine gute Idee, ich nehme gerne den Unterstrich

    lasst die PIs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr

  • Ich probieren es grad aus. Die Festplatte ist nur über das Gerätekennwort des Routers geschützt. Und Gastzugriff ist auf lesen und schreiben gesetzt. Brauch ich dann überhaupt ein Username angeben? Und wenn ja, welchen? In den Anleitungen stand immer "pi". Deswegen dachte ich das wäre der Username vom Raspberry, was ich aber mittlerweile bezweifle.

  • Quote

    mount -fv -t cifs -o user=pi,password=password,file_mode=0777,dir_mode=0777,sec=ntlm "//192.168.0.1/WD\ Elements\ 25A2\ 1019" /home/pi/Airport

    Da kommt bei mir dann:

    Code
    1. mount.cifs kernel mount options: ip=192.168.0.1,unc=\\192.168.0.1\WD,file_mode=0777,dir_mode=0777,sec=ntlm,user=pi,prefixpath= Elements\ 25A2\ 1019,pass=*******

    Was heißt das und wie kann ich damit weiterarbeiten?

  • Von hier: Option f : Simuliert die Durchführung von mount, der Befehl wird nicht wirklich ausgeführt.


    Wenn da kein Fehler kommt, nimmst Du das f raus, danach sollte in /home/pi/Airport der Inhalt zu finden sein.

  • Es wird nur das angegeben, was ich geschrieben habe. Wenn ich das f rausnehme kommt aber wieder:

    Mount error(101): Network is unreachable

  • Für ip addr kommt:


    Für ping -c 3 192.168.0.1 kommt:


    connect: Das Netzwerk ist nicht erreichbar


    Ich hab mal n Screenshot von meinem Airport angehängt.

  • inet 192.168.4.1/24 brd 192.168.4.255 scope global wlan0

    ping -c 3 192.168.0.1 kommt: connect: Das Netzwerk ist nicht erreichbar

    Na wie auch, beide Geräte existieren in unterschiedlichen Netzen und es gibt wohl keinen Weg zwischen beiden. Beheb das, dann bist Du einen Schritt weiter.

  • Da kommt bei mir dann:

    Code
    1. mount.cifs kernel mount options: ip=192.168.0.1,unc=\\192.168.0.1\WD,file_mode=0777,dir_mode=0777,sec=ntlm,user=pi,prefixpath= Elements\ 25A2\ 1019,pass=*******

    Was heißt das und wie kann ich damit weiterarbeiten?

    Das heisst, dass ein cifs Mount an der (Windows-Apple)Freigabe "\\192.168.0.1\WD" nicht möglich war, weil eine solche Freigabe nicht existiert [schon gar nicht für den (Windows/CIFS) User pi)].


    Du kannst herumexperimenrieren und die Leerzeichen durch \040 ersetzen, oder, weil sich unter Windows die Freigabe unter "Science" zeigt (#3), einfach mit der NAS Adresse/Science auf das Apple Netzlaufwerk zuzugreifen versuchen. Allenfalls nicht mit dem username=pi, sen Dein Apple NAS möglicherweise noch gar nicht kennt, sondern mit der uid 65543, username=nobody.


    z.B. < # mount -fv -t cifs -o ...... //192.168.4.1/Science /home/pi/Airport >

    Servus !

    RTFM = Read The Factory Manual, oder so

    Edited 2 times, last by RTFM ().

  • So, die Probleme waren, dass die PIs selbst ein Wlan erstellt haben und die Festplatte tatsächlich in NTFS Dateiformat war.

    Ich habs jetzt aber anders gemacht. Ich hab die Festplatte an meinen Laptop geschlossen und diese über das Airport Netzwerk so gemountet:


    sudo mount -t cifs //10.0.1.24/e /home/pi/Airport -o ver=1.0,uid=1000,gid=1000,sec=ntlm


    Passwort musste ich dann eingeben. Hab dann in Airport den Ordner "Videos" erstellt. Kann ich auch auf drauf zugreifen vom Laptop.

    Wenn ich jetzt aber ein Video aufnehme ist es dort auch abgespeichert, ich kann es aber nicht auf dem Laptop sehen.


    Rechte vom Ordner sind: drwxrwxrwx 2 pi pi und von den Dateien -rw-r--r-- 1 www-data www-data


    Auch dass ändern der Rechte der Datei auf rwx für alle und der Eigentum auf pi:pi hat nichts gebracht.

    Wie greife ich nun auf die Dateien zu?

  • Du kannst es auf dem Laptop nicht sehen, weil das Video im Ordner /home/pi/Airport/Videos lokal auf deinem Pi (und nicht auf der Freigabe) gespeichert ist. Du musst es auf /home/pi/Airport/Name_der_Freigabe/Videos speichern (wobei du den Ordner "Videos" natürlich erst noch erstellen musst).


    Nachtrag: bei deinem Konstrukt musst du natürlich beachten, dass der Laptop immer an sein muss, sonst ist die Freigabe logischerweise für den Pi nicht erreichbar. Willst du das? Die Airport Extreme wäre da sicher die bessere Wahl.

  • Ok, das versteh ich nicht ganz. Ich hab vergessen zu sagen, dass die Videos in einem andern Ordner erstellt werden und ich die verbunden habe mit:

    mount --bind /var/www/hmtl/media /home/pi/Airport/Videos


    Die ganze Festplatte ist freigegeben im Netzwerk, nicht nur bestimmte Ordner.

  • Achso, ja ok. Verstanden. Gibt es denn eine Möglichkeit, dass die Dateien auch wirklich auf die Festplatte überschrieben werden?

    Weil die Verzeichnisse, die ich im PI erstelle sidn ja auch automatisch auf der Festplatte erkennbar. Aber halt nicht Dateien.

    Weil eigentlich ist die Festplatte gewollt, damit nicht die Gefahr besteht, dass die SD-Karte irgendwann voll ist.

    Muss ich das sonst alles über die Freigabe händisch machen oder krieg ich das irgendwie automatisch hin.