Web'n'Walk UMTS Stick läuft nicht

  • Hallo,


    ich versuche einen Web'n'Walk UMTS Stick am Raspberry zum laufen zu bekommen, leider wird er nur als USB Datenspeicher erkannt.


    Code
    1. $ lsusb | grep HSDPA
    2. Bus 001 Device 009: ID 0af0:6971 Option Globetrotter HSDPA Modem

    Bei der Internetsuche nach "0af0:6971" gibt es zwar etliche Fundstellen die behaupten eine Lösung zu haben. Allerdings verweisen viele auf weitere Links deren Seiten bereits gelöscht sind, z.B. in diesem Wiki


    Die Anleitung unter http://www.symablog.de/blog/um…aspberry-pi-installieren/

    schien recht erfolgversprechend zu sein und ich habe mich daran orientiert. Die Kontrollen in den Zwischenschritten sind ok. Trotzdem hat diese Vorgehensweise nicht funktioniert.


    Hat jemand ein letzter Zeit einen Web'n'Walk Stick zum laufen gebracht und kann schlüssig beschreiben wie sich der Erfolg eingestellt hat?

    Ich würde mich über eine Rückmeldung freuen.


    Grüße

    Radius

  • Bitte schaue Dir dies mal an und schreibe deutlich mehr Details, was Du genau vorhast und was nicht funktioniert. Beides lässt sich aktuell nicht erkennen.

    Mein Github-Repository ist hier zu finden.

  • Im Raspian sind eben schon Treiber für das Modem eingebaut; die Chancen stehen gut, dass die Karte auch als Modem eingesetzt werden kann. Aber der Threadopener muss eben noch mehr Infos kundtun, was er genau vorhat und was nicht klappt. Daher auch mein Hinweis auf den Thread "Wie frage ich nach Hilfe".

    Mein Github-Repository ist hier zu finden.

  • Hallo,


    mein aktuelles Release ist

    Raspbian GNU/Linux 9 (stretch)

    4.14.79-v7+.

    Raspberry Pi reference 2018-03-13


    Ich habe

    durchgeführt.


    Dann sudo tail -f /var/log/messages und den Stick eingesteckt.


    Meine Erwartung ist, dass der Stick als Modem erkannt wird, leider wird er nur als vfat Speicherstick gemounted.

    Code
    1. $ df -T
    2. Dateisystem Typ 1K-Blöcke Benutzt Verfügbar Verw% Eingehängt auf
    3. /dev/root ext4 30568540 6234284 23027972 22% /
    4. devtmpfs devtmpfs 470116 0 470116 0% /dev
    5. tmpfs tmpfs 474724 30712 444012 7% /dev/shm
    6. tmpfs tmpfs 474724 12328 462396 3% /run
    7. tmpfs tmpfs 5120 4 5116 1% /run/lock
    8. tmpfs tmpfs 474724 0 474724 0% /sys/fs/cgroup
    9. /dev/mmcblk0p1 vfat 42131 22540 19591 54% /boot
    10. tmpfs tmpfs 94944 4 94940 1% /run/user/1001


    Grüße

    Radius

  • ich versuche den usb_modswitch zu verstehen, in 40-usb_modeswitch.rules steht ja eine Zeile:

    Code
    1. ATTR{idVendor}=="0af0", ATTR{idProduct}=="6971", RUN+="usb_modeswitch '%b/%k'"

    wofür steht '%b%k'? Sind das Variablen mit dem Inhalt 0af0 und 6971?


    Grüße

    Radius

  • Hallo,

    habe den UMTS Stick eingesteckt und beim ifconfig -a entdeckt, dass es ein neues Netzwerkinterface gibt, allerdings angehalten.

    Code
    1. # ifconfig -a hso0
    2. hso0: flags=4240<POINTOPOINT,NOARP,MULTICAST> mtu 1486
    3. unspec 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00 txqueuelen 10 (UNSPEC)
    4. RX packets 0 bytes 0 (0.0 B)
    5. RX errors 0 dropped 0 overruns 0 frame 0
    6. TX packets 0 bytes 0 (0.0 B)
    7. TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

    Beim Versuch das Interface zu starten erhalte ich eine seltsame Fehlermeldung

    Code
    1. # ifup hso0
    2. ifup: unknown interface hso0

    Das Interface wird doch bei ifconfig -a erkannt, wieso ist das unknown?


    Andere Versuche mit ip (bin mit ip nicht vertraut und probiere Tipps aus einem Linux wiki)

    Mit ip -4 sollte eigentlich keine IPv6 Adresse angelegt werden :-/.

    Mit der IPv6 Adresse bekomme ich keine UMTS Verbindung und im Moment gehen mir die Ideen aus.

    Hat jemand einen rettenden Einfall?


    Grüße

    Radius

  • Hallo,

    sieht jemand eine Chance das Problem durch einen manuellen Eintrag in udev zu lösen?

    Falls ja, wie müsste der aussehen?


    Grüße

    Radium

  • Wenn Du nicht die Produkt-ID Deines Sticks kennst, mit der Du die CD-ROM auf Modem umschaltest, kannst Du ja auch versuchen den Stick an einem Windows Rechner zum Laufen zu bringen. Wenn das gelingt, sollte Windows (nach der Treiberinstallation von der CD des Sticks) die Umschalting vornehmen, sodass danach der Stick unter Linux gleich als Modem funktionieren könnte.


    Ich glaube nicht, dass der Stick mit einer udev Regel aktiviert werden kann, weil ja gerade der USB Client im Stick zunächst nur die Installations CD als Gerät zur USB Verbinding anbietet.


    Wenn nichts mehr geht, kannst Du auch noch über ppp Deinen Provider - Internetzugang konfigurieren. Dazu brauchst Du aber alle Zugengsdaten Deines Providers, da in /etc/ppp mehrere Config-Files einzurichten sind.


    Servus !

    RTFM = Read The Factory Manual, oder so