Pi Hole Installationsprobleme mit curl

  • Hallo zusammen,


    ich habe noch einen Pi 1 übrig und wollte damit über Ethernetkabel und Fritzbox, mir einen Pi-Hole installieren.


    Das scheitert aber schon relativ früh.

    Pi mit Raspbian Stretch lite und Update / Upgrade funktionieren einwandfrei.


    Danach versuche ich mit

    Code
    1. curl -sSL https://install.pi-hole.net | bash

    zu installieren und das geht nicht.

    Hier die Fehlermeldung


    curl: (7) Failed to connect to raw.githubusercontent.com port 443: Keine Route zum Zielrechner


    Ich hab schon alles mögliche versucht und bin mit meinem Latein am ende.


    Ich nutze Unitymedia 120 er Leitung. Habe IPV4 und IPV6 gleichzeitig, so wie es als Standard von Unitymedia eingepflegt wird. Alle Geräte im Netz haben damit kein Problem. Alles funktioniert bei mir einwandfrei.

    Nur die Installation am Pi wehrt sich.


    Ich habe auch schon versucht in der FritzBox mein IPV6 abzuschalten und nur IPV4 zu nutzen. So einfach ist das anscheinend nicht, weil ich danach noch nicht einmal apt-get update starten konnte.


    Ich würde sehr gerne den Pi-Hole nutzen.


    Ich hoffe es hat jemand eine Idee wie ich das Problem lösen kann.


    Gruß

    Boerni:wallbash:

  • Hallo,

    es liegt wahrscheinlich an DS-Lite oder deiner Netzwerkkonfiguration (Fehler: Keine Route zum Zielrechner)


    Netzwerkkonfig und Routing des Pi prüfen:

    Code
    1. ifconfig -a
    2. route -n 
    3. cat /etc/resolv.conf
    4. host install.pi-hole.net
    5. # Interface eth0 ggf. anpassen
    6. sudo traceroute -4In -m 20 -i eth0 install.pi-hole.net | awk '{print $2}'

    Es gibt auch alternative Installationsmöglichkeiten welche Du ausprobieren kannst → Pi-hole documentation - Installation

  • Hallo Flashmob,

    das werde ich morgen Nachmittag direkt testen, danke.


    DS-Lite dürfte es nicht sein, da ich eine echte V6 & V4 habe.


    Komisch dass nur alles funktioniert nur nicht curl.

  • Wie sind auf deinem PI, die Ausgaben von:

    Code
    1. nc -zv raw.githubusercontent.com 443
    2. mtr -4nr -c 1 raw.githubusercontent.com

    nc -zv raw.githubusercontent.com 443

    nc: connect to raw.githubusercontent.com port 443 (tcp) failed: No route to host

    pi@raspberrypi:~ $ mtr -4nr -c 1 raw.githubusercontent.com

    -bash: mtr: Kommando nicht gefunden.

    pi@raspberrypi:~ $ sudo mtr -4nr -c 1 raw.githubusercontent.com

    sudo: mtr: Befehl nicht gefunden

    pi@raspberrypi:~ $



    verstehe nicht, warum das so ist. :-(

  • Hallo,

    es liegt wahrscheinlich an DS-Lite oder deiner Netzwerkkonfiguration (Fehler: Keine Route zum Zielrechner)


    Netzwerkkonfig und Routing des Pi prüfen:

    Code
    1. ifconfig -a
    2. route -n 
    3. cat /etc/resolv.conf
    4. host install.pi-hole.net
    5. # Interface eth0 ggf. anpassen
    6. sudo traceroute -4In -m 20 -i eth0 install.pi-hole.net | awk '{print $2}'

    Es gibt auch alternative Installationsmöglichkeiten welche Du ausprobieren kannst → Pi-hole documentation - Installation


    pi@raspberrypi:~ $ ifconfig -a

    eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500

    inet xxxxxxxxxx netmask 255.255.255.0 broadcast xxxxxxxxxx

    inet6 xxxxxxxxxx prefixlen 64 scopeid 0x0<g lobal>

    inet6 xxxxxxxxxx prefixlen 64 scopeid 0x20<link>

    ether xxxxxxxxxx txqueuelen 1000 (Ethernet)

    RX packets 530 bytes 27596 (26.9 KiB)

    RX errors 0 dropped 118 overruns 0 frame 0

    TX packets 76 bytes 11975 (11.6 KiB)

    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0


    lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536

    inet 127.0.0.1 netmask 255.0.0.0

    inet6 ::1 prefixlen 128 scopeid 0x10<host>

    loop txqueuelen 1000 (Lokale Schleife)

    RX packets 2 bytes 190 (190.0 B)

    RX errors 0 dropped 0 overruns 0 frame 0

    TX packets 2 bytes 190 (190.0 B)

    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0


    pi@raspberrypi:~ $ nc -zv raw.githubusercontent.com 443

    nc: connect to raw.githubusercontent.com port 443 (tcp) failed: No route to host

    pi@raspberrypi:~ $ mtr -4nr -c 1 raw.githubusercontent.com

    -bash: mtr: Kommando nicht gefunden.

    pi@raspberrypi:~ $ sudo mtr -4nr -c 1 raw.githubusercontent.com

    sudo: mtr: Befehl nicht gefunden

    pi@raspberrypi:~ $ ^C

    pi@raspberrypi:~ $ ifconfig -a

    eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500

    inet xxxxxxxxxx netmask 255.255.255.0 broadcast xxxxxxxxxx

    inet6 2a02:908:95b:b960:c850:ba22:c7e0:7711 prefixlen 64 scopeid 0x0<g lobal>

    inet6 xxxxxxxxxx prefixlen 64 scopeid 0x20<link>

    ether xxxxxxxxxx txqueuelen 1000 (Ethernet)

    RX packets 1174 bytes 58556 (57.1 KiB)

    RX errors 0 dropped 268 overruns 0 frame 0

    TX packets 137 bytes 19921 (19.4 KiB)

    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0


    lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536

    inet 127.0.0.1 netmask 255.0.0.0

    inet6 ::1 prefixlen 128 scopeid 0x10<host>

    loop txqueuelen 1000 (Lokale Schleife)

    RX packets 4 bytes 366 (366.0 B)

    RX errors 0 dropped 0 overruns 0 frame 0

    TX packets 4 bytes 366 (366.0 B)

    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0


    pi@raspberrypi:~ $ route -n

    Kernel-IP-Routentabelle

    Ziel Router Genmask Flags Metric Ref Use Iface

    0.0.0.0 192.168.0.1 0.0.0.0 UG 202 0 0 eth0

    192.168.0.0 0.0.0.0 255.255.255.0 U 202 0 0 eth0

    pi@raspberrypi:~ $ cat /etc/resolv.conf

    # Generated by resolvconf

    domain fritz.box

    nameserver 192.168.0.1

    nameserver fd00::ca0e:14ff:fe9a:aebf

    pi@raspberrypi:~ $ host install.pi-hole.net

    install.pi-hole.net is an alias for guinan.pi-hole.io.

    guinan.pi-hole.io has address 78.46.180.80

    guinan.pi-hole.io has IPv6 address xxxxxxxxxx

    pi@raspberrypi:~ $ sudo traceroute -4In -m 20 -i eth0 install.pi-hole.net | awk '{print $2}'

    to

    *

    *

    *

    *

    *

    *

    *

    *

    *

    *

    *

    *

    *

    *

    *

    *

    *

    *

    *

    *

    pi@raspberrypi:~ $


    die xxxxxxxxxx sind meine Ips


    Danke für eure Mühe.

  • Hab jetzt alles eingegeben, was ich hier an Tips bekommen habe aber der Befehl


    Code
    1. curl -sSL https://install.pi-hole.net | bash

    funktioniert immer noch nicht.


    Ich probiere mal die Alternative

  • sch.... geht nix.


    Code
    1. git clone --depth 1 https://github.com/pi-hole/pi-hole.git Pi-hole

    hier kennt mein Pi noch nicht einmal den Befehl git


    Code
    1. wget -O basic-install.sh https://install.pi-hole.net


    Hier bekomme ich auch ca 20 mal die Meldung ....fehlgeschlagen: Keine Route zum Rielrechner.

    Die Anzahl der Verweise ist zu groß


    Oder soll ich mal ein anderes Image probieren ?

  • Sieht aus, als würde die Fritzbox nicht für Deinen Pi routen.


    Ist 192.168.0.1 denn tatsächlich die IP-Adresse Deiner Fritzbox? Hast Du auf der derzeit IPv6 aktiviert oder deaktiviert? Hast Du noch irgendeinen anderen Linuxrechner im Netz? Falls ja, kann der hosts in der großen weiten Welt erreichen?

  • Die interne IPv4-Adresse aus dem Subnetz der FritzBox musst Du nicht anonymisieren.

    Wie ist die interne IPv4-Adresse deines PI?

    Poste mal auch von deinem PI, die nicht anonymisierte Ausgabe von:

    Code
    1. arp -av

    Hier ist da Ergebnis


    Boerni-PC.fritz.box (192.168.0.2) auf 94:de:80:b3:5a:a6 [ether] auf eth0

    fritz.box (192.168.0.1) auf <unvollst▒ndig> auf eth0

    Eintr▒ge: 2 Ignoriert: 0 Gefunden: 2


    Mein PC ist die IP 192.168.0.2

  • Mein Pi hat die feste Adresse 192.168.0.69 und meine FritzBox hat 192.168.0.1

    OK, und wie ist auf deinem PI die Ausgabe von:

    Code
    1. arp -av

    ?


    EDIT:


    Code
    1. Boerni-PC.fritz.box (192.168.0.2) auf 94:de:80:b3:5a:a6 [ether] auf eth0
    2. fritz.box (192.168.0.1) auf <unvollst▒ndig> auf eth0
    3. Eintr▒ge: 2 Ignoriert: 0 Gefunden: 2


    Konfiguriere mal (... wegen dem "unvollständig") einen statischen arp-cache-Eintrag im deinem PI für die FritzBox.

  • Hallo rpi444,


    leider muss ich jetzt arbeiten, ich versuche es morgen Nachmittag.


    Danke für die Hilfe.

    Ist schon merkwürdig warum das so ist.

    Ich habe vorher schon öfter Raspbian installiert und am laufen gehabt. Solche Probleme kenne ich nicht.

    Ob Untitymedia etwas geändert hat ? Evtl sogar nach dem SW Update der FritzBox auf 7.01.


    Ich schreibe morgen Nachmittag ob es geklappt hat.


    Danke nochmals für die Hilfe hier im Forum !!!

  • Hallo,

    Du solltest den Pi über DHCP konfigurieren. die Adresse 192.168.0.69 ist normalerweise aus dem Adresspool des DHCP-Server der FB.


    * eine Konfiguration über DHCP (die Adresse kannst Du in der FB permanent einstellen) wäre die einfachste Möglichkeit

    * bei statischer Konfiguration unbedingt eine IP-Adresse außerhalb des Adresspool des DHCP-Server der FB wählen (wichtig!)

    * bei manueller, statischer Konfiguration musst Du auch das Gateway und DNS für korrektes Routing manuell angeben


    * git muss natürlich nachinstalliert werden, das Problem ist aber weiterhin eine fehlerhafte Netzwerk-, bzw. Schnittstellenkonfiguration

  • Ob Untitymedia etwas geändert hat ? Evtl sogar nach dem SW Update der FritzBox auf 7.01.

    UM hat nichts geändert. Mit der OS7.01 auf der FB gibt es eine Änderung bzgl. DNS.

    Poste mal von deinem PI die Ausgaben von:

    Code
    1. sudo nmap -sP -R --dns-servers 192.168.0.1 192.168.0.0/24 | grep -i fritz.box | awk {'print $5$6'}
    2. sudo nmap -sn 192.168.0.0/24 | grep -Eo '([0-9]{1,3}\.){3}[0-9]{1,3}'
    3. sudo arp-scan -I eth0 --localnet
    4. sudo arping -c 3 -I eth0 -s 192.168.0.69 192.168.0.1
    5. dhcpcd -4 -U eth0

    Evtl. vorher noch installieren:

    Code
    1. sudo apt-get install --no-install-recommends nmap arp-scan iputils-arping tcpdump


    EDIT:


    Du könntest die FB auch auf Werkseinstellungen setzen und danach alle Einstellungen _manuell_ eingeben.

    Das Registrieren von A-/AAAA-Records beim DNS-Server der FB, wird m. W. aber nicht mehr funktionieren.

    Evtl. setzt AVM hier (... d. h. im W/LAN der FB) auf avahi & Co.

  • Die IP hatte die FritzBox vergeben und ich habe Sie nur in der FritzBox festgesetzt. Damit ich ihn immer problemlos wiederfinde.

    Sollte ich die lieber ändern ?

  • Die IP hatte die FritzBox vergeben und ich habe Sie nur in der FritzBox festgesetzt. Damit ich ihn immer problemlos wiederfinde.

    Sollte ich die lieber ändern ?

    Nein, dass ist dann grundsätzlich ok. Deine Aussagen dahin waren in diesem Fall etwas irreführend, da Du ja zu Anfang sagtest, der Pi wäre manuell/statisch konfiguriert.


    Dennoch ist es eigenartig, dass die Konfiguration dann fehlerhaft ist. Mich würde interessieren, wie konfiguriert wurde. Ich benutze für meinen Pi mit PiHole ja raspbian-stretch-lite als Basis, was hier ja ebenfalls verwendet wird. Die Netzwerkkonfiguration (DHCP) befindet sich standardmäßig in der /etc/dhcpd.conf . Hier habe ich nur manuell auf eine statische Konfiguration geändert. Wurde ansonsten etwas manuell angepasst oder auch über raspi-config? Schau doch mal nach.

    Code
    1. cat /etc/dhcpcd.conf
    2. cat /etc/network/interfaces
    3. ls -l /etc/network/interfaces.d

    Einmal editiert, zuletzt von Flashmob ()

  • Code
    1. sudo nmap -sP -R --dns-servers 192.168.0.1 192.168.0.0/24 | grep -i fritz.box | awk {'print $5$6'}

    hier kam keine Ausgabe, anscheinend nur ausgeführt.


    Code
    1. sudo nmap -sn 192.168.0.0/24 | grep -Eo '([0-9]{1,3}\.){3}[0-9]{1,3}'

    192.168.0.2

    192.168.0.73

    192.168.0.69


    Code
    1. sudo arp-scan -I eth0 --localnet

    Interface: eth0, datalink type: EN10MB (Ethernet)

    Starting arp-scan 1.9 with 256 hosts (http://www.nta-monitor.com/tools/arp-scan/)

    192.168.0.2 94:de:80:b3:5a:a6 GIGA-BYTE TECHNOLOGY CO.,LTD.

    192.168.0.73 1c:15:1f:aa:7d:a6 (Unknown)


    2 packets received by filter, 0 packets dropped by kernel

    Ending arp-scan 1.9: 256 hosts scanned in 4.014 seconds (63.78 hosts/sec). 2 responded


    Code
    1. sudo arping -c 3 -I eth0 -s 192.168.0.69 192.168.0.1

    ARPING 192.168.0.1 from 192.168.0.69 eth0

    Sent 3 probes (3 broadcast(s))

    Received 0 response(s)


    Code
    1. dhcpcd -4 -U eth0

    broadcast_address='192.168.0.255'

    dhcp_lease_time='864000'

    dhcp_message_type='5'

    dhcp_rebinding_time='756000'

    dhcp_renewal_time='432000'

    dhcp_server_identifier='192.168.0.1'

    domain_name='fritz.box'

    domain_name_servers='192.168.0.1'

    ip_address='192.168.0.69'

    network_number='192.168.0.0'

    ntp_servers='192.168.0.1'

    routers='192.168.0.1'

    subnet_cidr='24'

    subnet_mask='255.255.255.0'



    Dies waren die Daten, die mein Pi angezeigt hat.

  • Nein, dass ist dann grundsätzlich ok. Deine Aussagen dahin waren in diesem Fall etwas irreführend, da Du ja zu Anfang sagtest, der Pi wäre manuell/statisch konfiguriert.


    Dennoch ist es eigenartig, dass die Konfiguration dann fehlerhaft ist. Mich würde interessieren, wie konfiguriert wurde. Ich benutze für meinen Pi mit PiHole ja raspbian-stretch-lite als Basis, was hier ja ebenfalls verwendet wird. Die Netzwerkkonfiguration (DHCP) befindet sich standardmäßig in der /etc/dhcpd.conf . Hier habe ich nur manuell auf eine statische Konfiguration geändert. Wurde ansonsten etwas manuell angepasst oder auch über raspi-config? Schau doch mal nach.

    Code
    1. cat /etc/dhcpcd.confcat /etc/network/interfacesls -l /etc/network/interfaces.d

    ich selber habe dort nichts geändert. Image aufgespielt, anschließen nur SSH freigegeben und seitdem habe ich das Problem.

    sudo apt update und sudo apt upgrade funktionieren.


    bei der obengenannten Eingabe beschwert sich mein pi mit dieser Meldung

    cat: Ung▒ltige Option -- l

    ▒cat --help▒ liefert weitere Informationen.