Rechte Maustaste deaktivieren

  • Hallo zusammen


    Ich möchte meinen Pi (Generation 2 - sollte der sich als zu schwach herausstellen dann halt der 3er) als digitalen Bilderrahmen einrichten. Für meine Zwecke ist es wichtig, dass die rechte Maustaste oder das Menü beim Klicken auf den Hintergrund / Desktop-Icons deaktiviert ist. Habe schon alle Einträge mit "ShowMenu" in "/etc/xdg/openbox/lxde-pi-rc.xml" sowie auch in "/etc/xdg/openbox/LXDE/rc.xml" auskommentiert (siehe stackexchange Beitrag). Dies hatte keinen Effekt.


    (Zur Not würde ich auch einen anderen Fenstermanager / Desktop nehmen. Wichtig ist dann, dass Dateien auf der Arbeitsfläche abgelegt werden können. Auch das Aufrufen von Dateien durch Einfach-Klick statt Doppel-Klick ist wichtig.)


    Wie kriege ich es hin, dass Rechtsklicks deaktiviert sind?


    Gruß Killerkaninchen

  • Wenn es nicht gelingt per Software, Maustreiber (auch selbsrkompiliert), o.Ä. das "rechte_Maustaste_gedrückt_Event" ins /dev/null zu verbiegen, bleibt noch immer ein Hardwareeingriff in die Maus selbst übrig, um das Event gar nicht erst entstehen zu lassen.


    Servus !

    Wer nichts weiß, muss alles glauben.

  • Hallo,


    evtl könnte das mit xinput funktionieren. :conf:


    Ein Beispiel für die mittlere Maustaste gibt es hier:

    "Alles, was wir sind, ist Sand im Wind, Hoschi."

  • Daran an die Hardware zu gehen hatte ich auch gedacht, aber vorher würde ich doch gerne ein paar andere Sachen ausprobieren. xinput sieht da sehr viel versprechend aus.


    Ich hatte oben nicht erwähnt, dass es ein Touchpad ist...

  • Rechte Maustaste ist immer noch aktiv, leider :/ Allerdings werde ich nicht hundertprozentig schlau aus den Zahlen...

  • 'xev' hat folgendes ergeben:


    Durch tippen auf das Touchfeld haben sich die letzten Einträge ergeben. Das heißt, das dies als linke Maustaste erkannt wird - egal wo ich drücke. Das ist schonmal sehr gut.

    Wenn ich das richtig einschätze, muss ich jetzt mit 'Button 3' arbeiten... Ich bleibe dran.


    EDIT:


    Ich habe die .Xmodmap im Homeverzeichnis erstellt:

    Code
    1. xmodmap -pke > .Xmodmap

    und dann die folgende Zeile ergänzt:

    Code
    1. ! Maustasten
    2. pointer = 1 1 1 0 0 6 7 8 9 10

    Die rechte Taste ist deaktiviert - die linke jetzt aber auch wenn ich das ganze aktiviere:

    Code
    1. xmodmap ~/.Xmodmap
    2. X Error of failed request: BadValue (integer parameter out of range for operation)
    3. Major opcode of failed request: 116 (X_SetPointerMapping)
    4. Value in failed request: 0x1
    5. Serial number of failed request: 258
    6. Current serial number in output stream: 258

    In den oben genannten Dateien (...rc.xml) habe ich noch nicht die Änderungen zurückgenommen. Kann das damit zu tun haben? (Probiere es gleich einfach mal, habe aber gerade keine Zeit.)

    Einmal editiert, zuletzt von Killerkaninchen () aus folgendem Grund: Ergänzung

  • Wenn ich das richtig verstehe, dann so:

    Code
    1. xinput set-button-map 4 1 2 0


    //Edit

    evtl. auch statt der 4 die 8.

    "Alles, was wir sind, ist Sand im Wind, Hoschi."

  • Wenn ich die Werte in der .Xmodmap folgendermaßen ändere

    Code
    1. pointer = 1 0 0 0 0 6 7 8 9 10

    gibt es keine Fehlermeldung mehr, aber der Prozess openbox belegt 100% CPU.


    Erfolgreich war aber folgendes:

    Code
    1. xinput set-button-map 8 1 2 0

    Jetzt muss ich noch die übrigen Konfig-Dateien aufräumen, aber vermutlich funktioniert es jetzt, wie es soll...

    Wo wird der Befehl jetzt eingetragen? .bashrc hinter das letzte 'fi'?