Raspberry STRETCH wLan Adapter wlan0 reconnect funktioniert nicht

  • OK, ok, das ist so:

    Und jetzt testen bzw. die Ausgabe von "sudo sysctl -p" noch posten.

    The most popular websites without IPv6 in Germany.

  • ... was soll der Befehlt machen

    OK. Befehl soll zeigen ob Du Eintragungen in die /etc/sysctl.conf (oder gleichwertig) gemacht hast.


    Teste jetzt mal mit cat und deinem Script bzw. mit deiner großen log-Datei (via onboard-wifi).

    The most popular websites without IPv6 in Germany.

  • autschi - wLan -wech ... Neustart

    OK, dann gro und gso erneut auf off, die mtu auf 1472 setzen:

    Code
    sudo ifconfig wlan0 mtu 1472

    und in die "/etc/sysctl.conf" folgende Zeilen eintragen:

    die Datei speichern,

    Code
    sudo sysctl -p

    ausführen und erneut testen.

    BTW: Vor den nächsten reboot solltest Du noch die Zeile:

    Code
    dtoverlay=pi3-disable-bt

    in die "/boot/config.txt" eintragen.


    EDIT:


    Was auch testen bzw. schauen solltest ist, ob auf deinem PI vor dem hängen bleiben, Prozesse mit dem Zustandsflag "D" (uninterruptible sleep (usually IO)) enstehen:

    Code
    ps -o pid,stat,command -e | grep [D]

    Solche Prozesse können auch dazu führen, dass der PI nicht mehr reagiert. Diese Prozesse können nicht mehr gekillt werden.

    The most popular websites without IPv6 in Germany.

    Edited once, last by rpi444 ().

  • Problem sysctl.con:

    sysctl: cannot stat /proc/sys/net/netfilter/nf_conntrack_checksum: Datei oder Verzeichnis nicht gefunden

  • Test habe ich durchgeführt, immer wieder einsteigen, immer wieder einsteigen, das Karusell fährt gleich nach dem Neustart die nächste Runde :o(

    Was ist mit der Prüfung, ob der richtige Treiber für die wLan Hardware on Board auch richtig, und auf neuestem Stand ist? Wie macht man das?