Berechtigung externe Festplatte

  • Nabend!


    Ich bin dabei für Owncloud eine externe Festplatte auszurüsten. Mir fehlt jetzt noch ein Schritt. Ich muss die Berechtigungen ändern, nur leider bekomme ich eine Fehlermeldung:


    chown: der Eigentümer von '/media/festplatte' wird geändert: Die Operation ist nicht erlaubt


    Code
    1. Befehl: sudo chown -R www-data:www-data /media/festplatte


    Was mache ich falsch?


    Gruß Christian

  • Du musst mit www-data (uid, gid) mounten, wenn alle Files www-data gehören sollen. (bei NTFS, FAT)


    Servus !

    RTFM = Read The Factory Manual, oder so

  • Code
    1. sudo mount -t exfat -o utf8,uid=www-data,gid=www-data,noatime /dev/sda2 /media/festplatte

    so? Nur die Ordner haben immer noch die alte Berechtigung

  • drwxrwxrwx 1 XXX XXX 131072 Feb 10 21:27 .

    drwxr-xr-x 4 www-data www-data 4096 Feb 10 17:17 ..

    drwxrwxrwx 1 XXX XXX 131072 Feb 10 21:27 XXX

    drwxrwxrwx 1 XXX XXX 131072 Feb 10 21:27 avatars

    -rwxrwxrwx 1 XXX XXX 4096 Feb 10 12:38 ._.com.apple.timemachine.dono

    ...


    XXX = Mein Benutzername

  • exFAT läuft im fuse (File System im Userspace). Ob jedermann auf das gemountete Device zugreifen darf, wird mit allow_other in fuse.conf oder den Optionen bestimmt. Das wie [rwx] wird durch die umask festgesetzt.

    Die Multi-User Rechteverwaltung wird bei Verwendung von Windows Dateissystemen zur Gänze aufgehoben.

    Greift www-data auf das Dateisystem zu, werden alle Files + Dirs als www-data gehörig angezeigt, wenn allow_other aktiviert ist.


    Ich habe kein exFAT installiert und kann Dir daher aus < man mount.exFAT > nicht vorlesen.



    Servus !

    RTFM = Read The Factory Manual, oder so

  • Danke, nur leider schaffe ich es nicht...


    fuse.conf

    # /etc/fuse.conf - Configuration file for Filesystem in Userspace (FUSE)


    # Set the maximum number of FUSE mounts allowed to non-root users.

    # The default is 1000.

    #mount_max = 1000


    # Allow non-root users to specify the allow_other or allow_root mount options.

    # user_allow_other


    habe dann bei user_allow_other das "#" entfernt aber habe leider weiterhin die Fehlermeldung...

  • Du hast bereits den exFAT Mount so (ver-)konfiguriert, dass jeder User auf das Filesystem zugreifen kann.


    Greift der User "ich" XXX auf exFAT zu, werden ihm alle Dateien als "ich ich rwx rwx rwx" angezeigt und behandelt,

    greift der User www-data darauf zu. werden ihm alle Dateien als "www-data www-data rwx rwx rwx" angezeigt.


    Das hast Du mit umask 000, bzw. chmod 777 zustande gebracht.


    Die Frage ist, wer soll wie auf die exFAT Partition zugreifen dürfen ? Dass nur www-data rw zugreifen darf, hast Du wahrscheinlich nicht geplant.


    Servus !

    RTFM = Read The Factory Manual, oder so

  • naja www-data würde reichen ist eine reine Festplatte für meine Cloud... wird maximal nochmal bei mir am mac angesc

  • Habe die Festplatte jetzt einfach anders Formatiert und läuft sofort, wollte mal testen ob es auch 100%tig daran liegt. Kannst du mir vielleicht sagen wie ich das mit der Berechtigung hinbekomme oder nach was ich googeln kann. Habe schon viele Seiten durch aber finde nichts gutes...

  • Habe dann bei user_allow_other das "#" entfernt aber habe leider weiterhin die Fehlermeldung...

    Dann mach das # wieder davor, sonst machst Du Deine Konfiguration immer mehr kaputt.


    Wenn wirklich nur www-data (User und Group) auf die exFAT vom pi aus zugreifen soll, dann probiere als Mountoption uid=33,gid=33,dmask=007,fmask=117 ais.



    Servus !

    RTFM = Read The Factory Manual, oder so