IQ Audio Pi-DAC Pro

  • Hallo an das Forum und deren Mitglieder!


    Ich bin relativ unerfahren im Umgang mit dem RPI, habe sonst mehr mit PC usw. zu tun. Da ich jedoch nun einen RPI 3 in mein Auto als Entertainmentsystem einbauen möchte, bin ich jetzt in die Tiefen des RPI DT hinabgestiegen und habe mich dort leider verloren. Wo ist das Problem?

    Ich nutze einen RPI 3 mit original 7“ Display. Installiert ist ein Raspian Jessie, welches als Image von einer Kaufversion von OpenAuto stammt. Lt. uname ist die Version 4.14.79-v7 installiert. Um die Soundausgabe in einer sehr guten Qualität zu erhalten, habe ich von IQAudio die PI-DAC Pro gekauft. Die Karte wird auch erkannt, so dass ich unter Einstellungen – Audio Device Settings die anzuzeigenden Elemente konfigurieren kann. Die Lautstärke kann jedoch nicht über die GUI von OpenAuto eingestellt werden. Wenn ich unter dem Punkt Unterhaltungsmedien auf PulsAudio-Lautstärkeregler klicke, kommt eine Fehlermeldung, dass der PULSE_SERVER in der Umgebung/X11 oder default-server falsch konfiguriert sei. In der config.txt steht nicht die iqaudio…, sondern vc-fkms-v3d, wo ich schon mein erstes Erklärungsproblem habe. ändere ich den Eintrag, wie von IQAudio empfohlen, läuft es auch nicht. Vielleicht hat je jemand eine Erklärung und eine Lösung, damit ich mit meinem Projekt werter komme. Sollten noch Parameter oder sonstige Fragen notwendig sein, stelle ich gerne noch weitere Infos ein.


    Bis dahin danke ich schon einmal für eure Hilfestellung!

    Gruß Joachim

  • Hallo Hyle,


    die ausgabe von cat /etc/os-release ist:


    pi@raspberrypi:~ $ cat /etc/os-release

    PRETTY_NAME="Raspbian GNU/Linux 9 (stretch)"

    NAME="Raspbian GNU/Linux"

    VERSION_ID="9"

    VERSION="9 (stretch)"

    ID=raspbian

    ID_LIKE=debian

    HOME_URL="http://www.raspbian.org/"

    SUPPORT_URL="http://www.raspbian.org/RaspbianForums"

    BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"


    ich hoffe, du kannst damit was anfangen. Schon mal danke für deine hilfe.

  • Wirklich helfen kann ich Dir leider nicht. Ich war nur verwundert über Raspbian Jessie in Deinem Beitrag, weil ich bei dem Kernel 4.14.79-v7 Raspbian Stretch erwartet hätte. Das hat sich ja auch bestätigt.

    PRETTY_NAME="Raspbian GNU/Linux 9 (stretch)"

    Das soll keine Klugscheißerei sein, das ist eine wichtige Info! ;)

  • Aha, ich dachte, es sei ein Jessie. Wie gesagt, bin neuling und Klugscheißen ist das nun wirklich nicht. Kann ja nur was lernen.


    Was mache ich aber mit meiner Soundkarte? Ist klanglich erste Sahne, läuft jedoch nicht. Irgenwie blöd. Wer kann denn helfen????

  • Moin jojojur,


    woran machst es fest das die Karte erkannt wird?

    ich habe es richtig verstanden, das du die Karte erst eingesetzt hast.

    Das System war schon vorhanden, oder?


    Mhm, alles nur Fragen...


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

  • Hallo Bernd,


    die Karte wird ja erkannt, nur im PulsAudio kann ich die Lautstärke nicht öffnen. Dann kommt der Fehler. Die Audioausgabe funktioniert prima und in einer super Qualität. Die Lautstärke kann ich auch nicht in OpenAuto ändern, da wahrscheinlich PulsAudio nicht läuft. Mit einer USB Soundkarte funktioniert das super, nur ist die Qualität nicht gut und die CPU Last ist zu hoch. Habe jetzt in einer PDF über ein RPI Radio Projekt gelesen, dass die Hifiberry und IQAudio scheinbar Pulsaudio nicht brauchen oder nicht unterstützen??? – das geht aus der Doku nicht genau hervor. Ich bin jedoch auch noch viel zu unbedarft, was die DT angeht.


    Ich habe zum einen das System mit der Soundkarte installiert und auch das System ohne Soundkarte (nur auf dem RPI) installiert und danach die Karte eingebaut. Beides mit gleichem Ergebnis.


    Ich bin zurzeit (noch) der Meinung, ich brauche PulsAudio, damit OpenAuto die Lautstärkeregelung funktioniert. Wenn ich damit falsch liege, wie konfiguriere ich denn den DAC Ausgang als MAIN LS, dass es von OpenAuto genutzt werden kann?


    Ich hoffe, ich konnte ein paar Fragen beantworten. Sollte noch was fehlen, kurze Nachricht.


    Gruß Joachim

  • Moin Joachim,


    du hast die Karte eingebaut und sie wurde sofort erkannt oder hast du irgendwo was eingestellt?


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

  • Moin Joachim,


    ich kann es mir nicht so richtig vorstellen.


    Was ich auf GitHub so auf die Schnelle gesehen habe hilft auch nicht wirklich.


    Nur das ein Modul "dtaudio" den Sound macht. Aber warum der nun die Lautstärkeregelung nicht hinbekommt....


    Hast du mal neu gebaut mit der Soundkarte eingebaut??

    Ansonsten weiss ich auch nicht weiter.


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

  • was darf ich denn unter neu gebaut verstehen. Wie gesagt, ich bin neuling ;-). Ich habe das Image von OpenAuto genommen und die vorhandenen Treiber verwendet. in der config.txt steht jedoch nicht, wie in der Anleitung von IQ Audio geschrieben, ein overlay iqaudio/dacplus. es steht dort "vc-fkms-v3d", Änderung bringt jedoch auch nichts und das sollte ja auch vom EEProm konfiguriert werden.

  • Moin Joachim,


    wo gibt es denn das Image?


    Ich habe nur was zum Selbstbasteln gefunden. Link wäre toll.


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

  • Ich habe bei Bluweave im Forum gestöbert und genau das gleiche mit einer HifiBerry gefunden. PulsAudio scheint abzustürzen.


    Zitat aus dem Forum:



    No Audio

    Sun Jan 13, 2019 5:58 pm

    Hi,

    So today I finally had some time to mess with my install, and when I got it hooked up. I noticed that I don't have any audio for some reason now.


    I brought it back inside, and experience the same thing. It used to work, so not sure what is going on.


    I have a HIFI Berry HAT.


    The main OS volume is set to MAX, and the volume in OA is not at 0.


    When I go into the sound settings of the OS, I do see an odd error that says


    'Connection to Pulse Audio failed'


    (Bild hänge ich als Datei an)


    pulse audio2.PNG (196.36 KiB) Viewed 160 times

    Anyone know what I can troubleshoot to get this working again?

    I'm using the most recent release of Open Auto.

    Re: No Audio

    Sun Jan 13, 2019 11:03 pm

    So a little update.


    I tried reflashing the card, with a clean OpenAuto. Still no audio.

    I then tried flashing the latest version of Crankshaft.

    After I selected in the Crankshaft options to use the HIFI Berry, audio works OK. Is there a similar setting in OpenAuto, to select the HIFI Berry as the sound card?


    Any ideas why it's not working in OpenAuto now? The only change I've made recently is updating to the latest version.

    Re: No Audio

    Sun Jan 13, 2019 11:43 pm

    Nothing changed regarding audio in the latest release. Maybe after upgrade you missed some configuration that you did previously?


    Please follow https://support.hifiberry.com/hc/en-us/ ... -or-higher instructions and double check that everything was configured properly.

    Re: No Audio

    Wed Jan 23, 2019 8:08 pm

    Chirisfromwa did you get this fixed?

    I had a similar issue with my IQaudio DAC plus.

    After some googling I found several posts talking about similar issues with pulseaudio on stock raspbain. The only solution that seems to work is to delay starting of the pulse audio server or at least restarting it after its crashed at logon.


    I'm hoping to get some time tonight to install the latest update and finish some more on my setup. So I'll check what the fix was. I do still get a disconnect between OA and the volume controls sometimes on first boot, but restarting OA usually sorts it out, without restarting the pi.

    Re: No Audio

    Thu Jan 24, 2019 3:35 am

    I had to add the following two lines to /home/pi/.config/lxsession/LXDE-pi/autostart file.

    rm -rf /home/pi/.config/pulse

    @pulseaudio --start


    The first line basically removes the whole pulseaudio config in the pi user directory.

    The second line starts pulseaudio, the @ means it will be restarted if it crashes again.

    Without these lines I have the same error every time I reboot. They can be ran from a terminal to test.


    There are a couple of down sides to this, system boot time is longer and system volume will default to 100% on every boot.

    I've also tried several other solutions from the web, but nothing else works.

    This does not appear to be OA related and is the same on stock Raspbain for me!

    Hope this helps, till a better fix is found.

    Re: No Audio

    Sun Jan 27, 2019 11:01 pm

    „Sun Jan 13, 2019 11:03 pm

    So a little update.


    I tried reflashing the card, with a clean OpenAuto. Still no audio.

    I then tried flashing the latest version of Crankshaft.

    After I selected in the Crankshaft options to use the HIFI Berry, audio works OK. Is there a similar setting in OpenAuto, to select the HIFI Berry as the sound card?


    Any ideas why it's not working in OpenAuto now? The only change I've made recently is updating to the latest version.“

    A bit if an update for you! I still haven't found a true fix for this, but I do have an improvement on what I suggested before.

    Instead of removing the whole pulse config folder. Just remove the config file for the default-source at startup.

    On my system the full file name is e2f7f9b303df4bd98f56edefd7d40c5a-default-source.


    Add the following to /home/pi/.config/lxsession/LXDE-pi/autostart to remove it.

    Code: Select all

    rm -rf /home/pi/.config/pulse/*default-source

    It doesn't seem to be necessary to tell pulseaudio to restart either, and this maintains the previous volume setting.

    So far I've been fine tuning other things all day and restarted the system several times, and pulseaudio hasn't crashed.


    Zitat ende.


    Es scheint also ein generelles Problem mit PulsAudio zu geben. Noch keiner so ein problem gehabt?


    Leider muss ich PulsAudio nutzen, da das OpenAuto, egal ob Pro oder nicht, auf PulsAudio aufsetzt.


    OpenAuto ist kein Android System, sondern läuft auf dem Raspberry. Bitte nicht mit Android Auto verwechseln. Android Auto ist jedoch in OpenAuto enthalten und erlaubt die Nutzung von Android Geräten im Auto. OpenAuto ist als Free und als Kaufversion von Bluewavestudio erhältlich. Für mehr Infos mal unter Youtube nach OpenAuto suchen.


    Auf jeden Fall danke ich schon mal für die Hilfe.:thumbup::thumbup::thumbup:


    Grüße Joachim


  • Moin Joachim,


    keine Ahnung ob es bei openAuto überhaupt greift, aber einen Versuch ist es wert.


    Man kann ja in der /boot/config.txt Overlay-Dateien eintragen.

    Für deine Audiokarte gibt es auch ein Overlay. Schau dir mal die /boot/overlays/README an.


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

  • Hallo Bernd,


    die Overlay habe ich schon mal probiert, bringt nichts, ist genau das gleiche. Wenn ich das richtig verstanden habe, sollte jedoch die Overlays sowieso durch den I²C EEProm auf der Karte konfiguriert werden. Oder liege ich da falsch? Somit ist es eigentlich egal, was ich da eintrage, da es sowieso überschrieben wird. Ein anderer hat auch schon diese Autokonfig (plug&play) ausgeschaltet und von Hand das Overlay eingestellt, selbe Effekt.


    Ich werde heute Abend mal die Punkte im dem Zitierten Forumbeitrag probieren und schauen, ob PulsAudio wirklich abstürzt. Ich denke, dann kann ich zumindest schon mal sagen, was da passiert. Hilfreich wäre auch ein logging von PulsAudio, geht sowas?


    Gruß Joachim

  • Moin Joachim,


    es sollte was in journalctl -f sein. der Schalter "-f" ist fortlaufende Ausgabe..

    Meldungen während der Bootzeit sind auch drin, aber die Eingabe von dmesg ist einfacher ;-))


    Viel Erfolg


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

  • Hallo Bernd,


    ich habe gestern noch die Anleitung aus dem Zitat oben ausprobiert, leider alles ohne Erfolg. Da mir gestern auch die Zeit fehlte, noch weitere Analysen zu machen, habe ich zum einen noch geschaut, ob sich die Karte im I²C Bus finden lässt (Dann sollte das Overlay passen - am I²C Bus ist die Adresse 0x4C gefunden worden. Eine der möglichen Adressen vom DAC. Sollte also stimmen.) und zum anderen habe ich noch dmesg eingegeben und eine ellenlange Liste bekommen, die ich leider nicht mehr genau sichten konnte (Das Bett und die Frau hatte gerufen ;-). Ich werde heute mit einer älteren Release versuchen, PulseAudio zum Leben zu bringen, wenn das nicht klappt, probier ich noch eine HifiBerry aus, die ich noch liegen habe und wenn das auch scheitert, geht es mit der aktuellen Version und der Auswertung der ellenlangen Liste weiter. Der PulsAudio Server scheint ja doch sehr eigenwillig zu sein. Na ja, nur so lernt man richtig ;-).


  • Also ich erinnere mich, dass die Foundation (raspberrypi.org) irgendwo empfiehlt, dass man bei Verwendung von Bluetooth PulseAudio deaktivieren soll, da es da Probleme gäbe.


    Im Umkehrschluss könntest Du mal probieren, Bluetooth zu deaktivieren, vielleicht läuft es dann mit PulseAudio.


    Nachtrag:

    Was anderes:

    Ich hab so nen HifiBerry DAC Clone (PiFi DAC+). In der Konfiguration zu Volumio wird da z.B. das Original eingetragen (HiFiBerry DAC Plus).

    Vielleicht hilft Dir das ?!?!

    Die Ähnlichkeiten zu den originalen HifiBerry Karten sind jedenfalls irgendwo erkennbar und evtl. kannst Du es ja mal mit einer ähnlich namentlich genannten HifiBerry Karte bei der Auswahl probieren.

    ;) Gruß Outi :D
    PIs: 2x Pi B (Rente) / 1x Pi B+ (Rente) / 1x Pi 2 B (Tests) / 2x Pi 3 B (RaspberryMatic/Win10IoT) / 2x Pi Zero 1.2 (J. Lite) / 2x Pi Zero 1.3 (J. Lite) / 2x Pi Zero W 1.1 (Stretch) / 1x Pi 3 B+ (Stretch)
    Platinen: Sense HAT / RPI-RF-MOD / PiFi DAC+ V2.0

    Edited 2 times, last by Outlaw ().