Ich kann keine "APT"entfernen

  • Hallo liebes Raspberry PI Forum,

    Ich habe ein Problem und das wäre das ich keine apt mehr entfernen

    kann, und ich bin schon ratlos. Ich freue mich über eine Antwort.


    Hier ist einfach mal so ein "Log" (mit den wichtigsten Informationen)


    $exagear

    Starting /bin/bash in the guest image /opt/exagear/images/ubuntu-1404lts

    $sudo apt-get remove wine

    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

    $sudo apt-get -f install

    Do you want to continue? [Y/n] y

    debconf: Perl may be unconfigured (Can't locate strict.pm in @INC (you may need to install the strict module) (@INC contains: /etc/perl /usr/local/lib/perl/5.18.2 /usr/local/share/perl/5.18.2 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.18 /usr/share/perl/5.18 /usr/local/lib/site_perl .) at (eval 1) line 2.

    BEGIN failed--compilation aborted at (eval 1) line 2.

    ) -- aborting

    (Reading database ... 29312 files and directories currently installed.)

    Preparing to unpack .../x11-common_1%3a7.7+1ubuntu8.1_all.deb ...

    Can't locate strict.pm in @INC (you may need to install the strict module) (@INC contains: /etc/perl /usr/local/lib/perl/5.18.2 /usr/local/share/perl/5.18.2 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.18 /usr/share/perl/5.18 /usr/local/lib/site_perl .) at /usr/share/debconf/frontend line 5.

    BEGIN failed--compilation aborted at /usr/share/debconf/frontend line 5.

    dpkg: error processing archive /var/cache/apt/archives/x11-common_1%3a7.7+1ubuntu8.1_all.deb (--unpack):

    subprocess new pre-installation script returned error exit status 2

    /var/lib/dpkg/tmp.ci/postrm: 679: /var/lib/dpkg/tmp.ci/postrm: systemctl: not found

    Errors were encountered while processing:

    /var/cache/apt/archives/x11-common_1%3a7.7+1ubuntu8.1_all.deb

    E: Sub-process /usr/bin/dpkg returned an error code (1)

  • Aber mit exagear hast Du (evtl. nur versucht) etwas mit ubuntu zu installieren:

    Ja, das stimmt ich habe es versucht.:D


    "Ubuntu 14.04 hat noch SysV. Evtl. brauchst Du ein neueres image mit systemd" Wie geht das denn?

  • Hast Du evtl. eine veraltete Anleitung aus dem Internet benutzt (... die evtl. noch für </= wheezy war)?

    ja... das könnte sein. Ich wusste nicht das es später so ausarten könnte

  • Wie sind z. Zt. auf deinem PI, die Ausgaben von:

    pi@RaspbianServer-06022019:~ $ cat /etc/os-release

    PRETTY_NAME="Raspbian GNU/Linux 9 (stretch)"

    NAME="Raspbian GNU/Linux"

    VERSION_ID="9"

    VERSION="9 (stretch)"

    ID=raspbian

    ID_LIKE=debian

    HOME_URL="http://www.raspbian.org/"

    SUPPORT_URL="http://www.raspbian.org/RaspbianForums"

    BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"

    pi@RaspbianServer-06022019:~ $

    pi@RaspbianServer-06022019:~ $ uname -a

    Linux RaspbianServer-06022019 4.14.79-v7+ #1159 SMP Sun Nov 4 17:50:20 GMT 2018 armv7l GNU/Linux

    pi@RaspbianServer-06022019:~ $