Chromium soll immer im Vordergrund sein

  • Hallo Leute,

    ich starte chromium via /.config/autostart/start.desktop im Kioskmode.

    Code
    1. [Desktop Entry]
    2. Name=Start-WebBrowser
    3. Exec=chromium-browser --kiosk http://meine.site -start-maximized
    4. Terminal=false
    5. Type=Application
    6. Comment=Autostart webbrowser at login

    Da noch andere Anwendungen gestartet werden, ist chromium nicht zwingend im Vordergrund.

    :blush: Was muss ich tun, dass chromium nach einem Reboot immer im Vordergrund ist und bleibt?

    Danke für eure Tipps.

    LG superbike

  • superbike

    Hat den Titel des Themas von „Chromium immer im Vordergrund“ zu „Chromium soll immer im Vordergrund sein“ geändert.
  • Probier mal bei openbox ob die Eigenschaft layer das bewerkstelligt. Siehe im Beispiel ganz unten. Die Konfigurationsdatei ist i.d.R. /home/pi/.config/openbox/lxde-pi-rc.xml. Kann aber sein das 'above' nur beim öffnen gilt.

    Code
    1. <layer>normal</layer>
    2. # 'above', 'normal', or 'below'

    Das muss natürlich für Chromium gemacht werden (siehe applications setting).

  • (:ist die Lösung; dauernd, nicht nur beim öffnen.

    Für meinen Fall habe ich die Datei /home/pi/.config/openbox/lxde-pi-rc.xml im Bereich <applications> erweitern mit:

    Code
    1. <applications>
    2. ...
    3. <application name="chromium-browser">
    4. <layer>above</layer>
    5. </application>

    daxb ::bravo2: Danke für Deinen Tipp.