Raspi setzt Zeit zurück

  • Hallo zusammen


    Folgendes ist passiert:




    Weiss jemand, woran das liegen könnte? Vielen Dank für die Feedbacks! :-)

    Mit freundlichem Gruss,
    Jan

  • Danke für die Tipps, das System wurde von Jesse nach Stretch hochgehoben. Das könnte der Grund sein, warum der alte Dienst verwendet wird. Kann es ja mal mit dem Neuen versuchen - das wird allerdings nicht das Problem mit dem Einfrieren lösen (?), denke ich zumindest.


    Irgendwas ist da definitiv nicht in Ordnung, habe die Logs deshalb als Dateianhang beigepackt.

  • Danke, habe nun ntp durch rdate ersetzt und avahi-daemon gelöscht. Das behebt zwar nicht das Problem mit dem Freeze (Hitze? Inoffizieller .86er-Kernel?), allerdings ist es zumindest besser als vorher..;-)

    Mit freundlichem Gruss,
    Jan

  • Inoffizieller .86er-Kernel?

    Dann höchstwahrscheinlich dies. Aktuell ist Linux raspberrypi 4.14.79-v7+ #1159 SMP Sun Nov 4 17:50:20 GMT 2018 armv7l GNU/Linux Warum nutztest Du rpi-update? Gibt es ein triftigen Grund?


    Jessie nach Stretch

    Oder aber dies ist der Grund. Auf dem RPi zieht dies manchmal merkwürdige Effekte nach sich, die beim neuinstallieren nicht vorhanden sind.


    Grüße, STF

  • ..., habe nun ntp durch rdate ersetzt und avahi-daemon gelöscht. Das behebt zwar nicht das Problem ...

    Das habe ich ja auch nicht behauptet. rdate solltest Du lediglich zum testen installieren und nicht als Ersatz für ntp.

    Wenn Du ntp ersetzen willst, dann (auf stretch) mit systemd-timesyncd.


    Die andere Ausgabe willst Du ja nicht posten, ... denn man kann den ntpd auch so konfigurieren, dass dieser auf das Entstehen/Erscheinen von "neuen"/zusätzlichen Interfaces (zwecks Lauschen) _nicht_ reagiert bzw. diese ignoriert.

    Z. B.:

    Zitat

    -U interface_update_interval

    Number of seconds to wait between interface list scans to pick up new and delete network interface. Set to 0 to disable dynamic interface list updating. The default is to scan every 5 minutes.

  • Vielen Dank, nun habe ich das Paket "ntp" wieder installiert.

    Apropos einfrieren: Gemäss https://www.reddit.com/r/kerne…released_please_pick_and/ sowie https://lwn.net/Articles/773993/ sollte der Kernel 4.14.86 "stable" sein, oder wird in diesem Fall nicht 1:1 der gleiche .86er-Kernel bei Raspbian verwendet wie bei linux.org publiziert ist? Wandeln die versch. Distris die Kernel noch ab?


    Der Grund, warum ich diesen Kernel verwendet, ist dass ich potentielle zukünftige Probleme verhindern will. Will es nicht herausfordern mit irgendwelchen Development- oder Testing-Kerneln...

    Mit freundlichem Gruss,
    Jan

  • Will es nicht herausfordern mit irgendwelchen Development- oder Testing-Kerneln

    Aber genau das machst Du doch damit! :conf: Aktuell und sable ist nach wie vor: 4.14.79


    Quellen:

    https://github.com/Hexxeh/rpi-firmware/tree/stable/modules

    http://downloads.raspberrypi.org/raspbian/release_notes.txt


    //Edit Mit sudo rpi-update 2267b322afdb18b4abf9603fea836916190b1b5d solltest Du zurück auf 4.14.79 kommen. Den Link zum Kompendium wg. evtl. Risiken hat Dir STF ja schon gezeigt, Viel Glück!

    "Alles, was wir sind, ist Sand im Wind, Hoschi."

    Einmal editiert, zuletzt von hyle ()

  • Das mit "rpi-update" [Commit-Nr.] ist mir soweit klar.

    Aber: Wenn nun linux.org eine best. Kernel-Version als "stable" deklariert, so gilt das nicht für eine konkrete Linux-Distribution...??

    Mit freundlichem Gruss,
    Jan