Touchscreen kalibrierung funktioniert nicht

  • Hallo zusammen,


    ich habe einen Raspberry PI3, ein altes 15,4" Lenovo Notebookdisplay (1600x900) sowie ein 15,4" Touchscreen in einen Bilderrahmen eingebaut. Der Touchscreen funktioniert jedoch stimmt die Auflösung des Tochscreens nicht mit dem Display überein. Will meinen das wenn ich mit dem Finger in der Mitte des Displays anfange nach Außen zu streichen weicht die Mauszeigerposition immer weiter von der reellen Position ab. In der Mitte sind beide noch auf der gleichen Position, wenn der Finger aber am Rand des Tochscreens (egal ob X oder Y) ist, ist der Mauszeiger noch steuerbar aber nicht am Rand des Displays. Das rote Rechteck im Bild zeigt in etwa den Bewegungsbereich des Mauszeigers auf dem Display an. Den xinput_calibrator habe ich schon mehrfach ausgeführt. Eine andere Distribution (Dietpi) habe ich auch wie in den zwei Bildern zu sehen ausprobiert. Immer das gleiche.


    Hier habe ich mal die Debugausgabe des xinput_calibrator angegeben. Wie man erkennen kann hat er vier Clicks mit Positionen zurückbekommen und sie dann umgerechnet. Leider hat das aber keine Auswirkung.

    Hat jemand eine Idee was ich falsch mache oder ist das ein Bug?

    Grüße Poldi

  • Sind die Werte in /etc/X11/xorg.conf.d/99-calibration.conf

    noch min_x=0, max_x=65535 und min_y=0, max_y=65535, oder schon auf die geänderten Werte ab Zeile 22 Deiner Ausgabe angepasst ?


    Servus !

    Wer nichts weiß, muss alles glauben.

  • Hallo zusammen,

    der Hinweis von AIT war perfekt. :danke_ATDE: für die schnelle Hilfe.

    Code
    1. sudo apt-get install xserver-xorg-input-evdev
    2. sudo cp -rf /usr/share/X11/xorg.conf.d/10-evdev.conf /usr/share/X11/xorg.conf.d/45-evdev.conf

    Nach dem erstellen der Datei /usr/share/X11/xorg.conf.d/99-calibration.conf und dem einfügen der Daten aus dem xinput_calibrator funktioniert es auch nach einem Neustart.


    Grüße Poldi