Kein Accespoint bei Tor-Router

  • Guten Morgen liebe Forengemeinde,


    ich nutze einen Pi 3 Modell B+ mit Raspian Stretch vom 18.11.19 (Linux raspberrypi 4.14.98-v7+ #1200 SMP Tue Feb 12 20:27:48 GMT 2019 armv7l GNU/Linux). Ich habe damit einen Tor Router nach folgender Anleitung aufgesetzt: https://3os.org/raspberryPi/TOR-Pi/


    Ich bin schon seit einiger Zeit dabei, das erste Mal habe ich den Router lt. der Anleitung vor ca. einem Jahr aufgesetzt, damals hat aber der damalige Provider die Nutzung blockiert. Seit Dezember bin ich wieder in Deutschland und habe den Router hier erfolgreich betrieben, so dass ich davon ausgehen kann, das die Anleitung so erstmal ohne Probleme läuft.


    Leider ging hier der Raspberry defekt, so dass ich einen neuen gekauft habe und einrichten wollte. Ich habe mich wieder an diese Anelitung gehalten, jetzt zeigt mir der Raspberry aber noch nicht mal sein WLAN-Netz....


    Systemctl schaut wie folgt aus:


    DHCP und networking.services laufen nicht..... :-(


    Beim Einrichten bekam ich auch folgende Meldung


    kann das Problem damit zusammenhängen? Wenn ja, wie bekomme ich den Router wieder zum laufen?


    Danke und Grüße

  • Hallo RPI444,


    danke für deine Antwort. Auch das alte Modell war ein PI3 B+..... ich spiele jetzt das Procedure mit der Installation wieder durch. Jetzt hakt es schon bei der Installation von GIT :-( :-( Fehlermeldung:


    Code
    1. pi@raspberrypi:~ $ sudo apt-get install git
    2. Reading package lists... Done
    3. Building dependency tree
    4. Reading state information... Done
    5. E: Unable to locate package git
  • Git funktioniert seid 10 minuten.... alles gut daher.


    Die Installation wurde erfolgreich durchgeführt, das PAckage von

    Code
    1. clone https://github.com/unixabg/RPI-Wireless-Hotspot.git

    installiert und danach der Raspberry neu gestartet. Anschließend war der Accesspoint, der durch den Raspberry zur Verfügung gestellt werden sollte, nicht verfügbar.


    Systemctl ergibt:

  • pi@raspberrypi:~ $ apt-cache policy hostapd

    hostapd:

    Installed: 2:2.6-21~bpo9~rpt1

    Candidate: 2:2.6-21~bpo9~rpt1

    Version table:

    *** 2:2.6-21~bpo9~rpt1 500

    500 http://archive.raspberrypi.org/debian stretch/main armhf Packages

    100 /var/lib/dpkg/status

    2:2.4-1+deb9u2 500

    500 http://raspbian.raspberrypi.org/raspbian stretch/main armhf Packages

    pi@raspberrypi:~ $ ps -fC hostapd

    UID PID PPID C STIME TTY TIME CMD

    pi@raspberrypi:~ $ systemctl status hostapd

    ● hostapd.service

    Loaded: masked (/dev/null; bad)

    Active: inactive (dead)

  • Kann ich dir echt nicht sagen...

    Lt. der Readme von RPI-Wireless-Hotspot

    macht die installation folgendes:


    • Configured hotspot starts automatically on boot, no extra configuration necessary

    • Configured WiFi network is WPA encrypted.

    • Default SSID of "RaspberryPiFi" and WPA key of "0123456789A" can be modified during install

    • Once set up, the local network facilites of the Pi will still operate as normal

    • Easy setup of either a custom or preconfigured DNS server (including unblock-us for removing netflix geoblocks)

    • Router enumeration for WiFi network

    • Allows chromecast compatibility with unblock-us by intercepting google's DNS requests on the pi

    Da steht nichts von einer masked hostpad....


    Kann ich das nicht irgendwie händisch laden und dann schauen wir weiter?

  • Kann ich das nicht irgendwie händisch laden und dann schauen wir weiter?

    Naja, eigentlich soll as install-Script aus deiner Anleitung das machen. Dort steht u. a.:

    Code
    1. echo "Initialising access point"
    2. service hostapd start
    3. update-rc.d hostapd enable

    Leider wissen wir nicht, ob diese Anleitung nur für raspbian-jessie ist, oder auch für raspbian-stretch ist?

    Was hat sich bezgl. hostapd in stretch (aktuelle Version) geändert? Hat der Autor der Anleitung das berücksichtigt?

    Kennst Du solche Hinweise?

  • Quote

    Leider wissen wir nicht, ob diese Anleitung nur für raspbian-jessie ist, oder auch für raspbian-stretch ist?

    Was hat sich bezgl. hostapd in stretch (aktuelle Version) geändert? Hat der Autor der Anleitung das berücksichtigt?

    Kennst Du solche Hinweise?

    Das kann ich dir leider nicht sagen....


    Da alles von dieser Seite irgendwann 2016 geschrieben wurde und der Raspberry bis vor kurzem (also Ende 2018) nach dieser Anleitung problemlos lief, dann denke ich, es liegt eher an raspian-stretch. Also an der Version von 11/2018...


    Ich habe den Hotstapd mal manuell versucht zu starten


    Code
    1. hostapd -dd /etc/hostapd.conf

    als Ergebnis kam


    Code
    1. random: Trying to read entropy from /dev/random
    2. Configuration file: /etc/hostapd.conf
    3. Could not open configuration file '/etc/hostapd.conf' for reading.
    4. Failed to set up interface with /etc/hostapd.conf
    5. hostapd_init: free iface 0xd88cf8
    6. Failed to initialize interface

    Edited once, last by Subsurfer ().