OpenVPN-Server läuft nicht

  • Hallo,


    ich habe ein ähnliches Problem mit meinem OpenVPN-Server. Ich bin noch am Einrichten aber habe schon dabei das Problem, dass er nicht läuft:


    $ systemctl status openvpn zeigt mir immer als (...active(exited)...) an


    Hier sind die anderen Tests die ich gemacht habe:

    So sieht meine "openvpn.conf" aus:



    Und die rpivpn:

    Vielen Dank für jede Hilfe

    Edited once, last by chrisgu ().

  • So sieht meine "openvpn.conf" aus:


    Versuch mal als Test, mit:

    Code
    user openvpn
    group openvpn

    statt

    Code
    user nobody
    group nogroup

    und ohne

    Code
    client-to-client

    Wie sind z. Zt. auf deinem PI die Ausgaben von:

    Code
    ifconfig -a
    route -n
    ls -la /etc/openvpn/easy-rsa
    systemctl status openvpn@server

    ?

    The most popular websites without IPv6 in Germany.

  • Hallo,


    hier sind die Ausgaben:


    $ ifconfig -a:

    lo: flags=73>UP, LOOPBACK, RUNNING> mtu 65536 ...

    inet 127.0.0.1 netmask 255.0.0.0

    inet6 ::1 prefixlen 128 scopeid 0x10<host>

    loop txqueuelen 1000 (Lokale Schleife)

    RX packets 0 bytes 0 (0.0 B)

    RX errors 0 dropped 0 overrruns 0 frame 0

    TX packets 0 bytes 0 (0.0 B)

    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0


    eth0: flags=4163>UP, BROADCAST; RUNNING, MULTICAST> mtu 1500 ...

    inet 192.168.2.104 netmask 255.255.255.0

    inet6 2003:d1:de02:f5be:5812:baab:7272:411a prefixlen 64 scopeid 0x0<global>


    --- eth0 soll der Link fürs VPN werden ---


    wlan0:

    flags=4163>UP, BROADCAST; RUNNING, MULTICAST> mtu 1500 ...

    inet 192.168.2.101 netmask 255.255.255.0

    inet6 2003:d1:de02:f8be:2529:4172:ac5b:7110 prefixlen 64 scopeid 0x0<global>


    --- über wlan0 verwalte ich den Raspberry per ssh ---


    $ route -n

    Ziel Router Genmask Flags Metric Ref Use Iface

    0.0.0.0 192.168.2.1 0.0.0.0 UG 202 0 0 eth0

    0.0.0.0 192.168.2.1 0.0.0.0 UG 303 0 0 wlan0

    192.168.2.0 0.0.0.0 255.255.255.0 U 202 0 0 eth0

    192.168.2.0 0.0.0.0 255.255.255.0 U 303 0 0 wlan0



    $ ln -ls /etc/openvpn/easy-rsa


    In dem Ordner sind die Dateien:

    build-ca

    build-dh

    build-inter

    build-key

    build-key-pass .

    ...

    clean-all

    openssl-0.9.6.cnf

    openssl-0.9.8.cnf

    openssl-1.0.0.cnf

    pkitool

    revoke-full

    vars


    Der Link:

    ln: openssl.cnf --> openssl-1.0.0.cnf


    Die directory:

    easy-rsa


    $ systemctl status openvpn@server

    Loaded: loaded (/lib/systemd/system/openvpn@.service; disabled; vendor preset: enabled)

    Active: inactive (dead)

    Docs: man: openvpn(8)

    ...


    Was mich wundert, ist, dass er gar nicht erst started, bzw. "exited" ist.


    Internetverbindung hat er.


    Ich probier jetzt mal die Tipps. ..


    Nachdem ich den Dienst mit $systemctl restart openvpn neu gestartet habe, gibt er mir bei $systemctl status openvpn@.service folgendes aus:


    Loaded: loaded (/lib/systemd/system/openvpn@.service; disabled; vendor preset: enabled)

    Active: active (exited) since Sun 2019-03-17 .....

    Process: 2810 ExecStart=/bin/true (code=exited, status=0/SUCCESS)

    Main PID: 2810 (code=exited, status=0/SUCCESS)

    Mär 17 12:16:55 raspberrypi systemd[1]: Starting OpenVPN service...

    Mär 17 12:16:55 raspberrypi systemd[1]: Started OpenVPN service...


    Bei $ systemctl status openvpn@openvpn ist die Ausgabe


    Mär 17 12:16:55 raspberry systemd[1]: Starting OpenVPN connection to openvpn...

    Mär 17 12:16:55 raspberry systemd[1]: openvpn@openvpn.service: Control process exited, code=exited status=1

    Mär 17 12:16:55 raspberry systemd[1]: Failed to start OpenVPN connection to openvpn.

    Mär 17 12:16:55 raspberry systemd[1]: openvpn@openvpn.service: Unit entered failed state.

    Mär 17 12:16:55 raspberry systemd[1]: openvpn@openvpn.service: Failed with result 'exit-code'.

    Edited 5 times, last by chrisgu ().

  • Warum ist dein PI per WLAN und per Kabel mit dem Router verbunden? Versuch mal mit nur einem Interface.

    Nach, den Änderungen in der conf-Datei:

    Code
    sudo systemctl daemon-reload
    sudo systemctl stop openvpn
    sudo systemctl start openvpn

    ausführen.

    The most popular websites without IPv6 in Germany.

  • Hat leider nicht geklappt...


    Ich habe das wlan0 ausgeschaltet (Bei "$ route -n" wird jetzt nur noch angezeigt):

    Ziel:0.0.0.0 Router: 192.168.2.1 Flags: UG Interface: eth0

    Ziel: 192.168.2.0 Router: 0.0.0.0 Flags: U Interface: eth0


    Habe es in der openvpn.conf mit

    user openvpn

    group openvpn


    und mit


    user nouser

    group nogroup


    probiert..


    Neu gestartet habe ich jeweils mit:

    $ sudo systemctl daemon-reload

    $ sudo systemctl stop openvpn

    $ sudo systemctl start openvpn


    Die Ausgabe bei "$ systemctl status openvpn@server" ist jedesmal:

    Loaded: loaded...

    Active: failed (result: exit-code)

  • Die Ausgabe bei "$ systemctl status openvpn@server" ist jedesmal:

    Loaded: loaded...

    Active: failed (result: exit-code)

    Wie sind jetzt die aktuellen Eintragungen in der Log-Datei?

    The most popular websites without IPv6 in Germany.

  • Das über systemctl status:

    Und wenn ich die Datei /var/log/openvpn anschaue, dann ist da eigentlich nur ein Eintrag, der aber ca. 500 x:

    Code
    Options error: --server directive network/netmask combination is invalid
    Use --help for more information

    Allerdings ist mein Eintrag in der "openvpn.conf" für "server" = "192.168.2.104" und die Subnetzmaske "255.255.255.0" bzw. in den Umgebungsvariablen "192.168.2.104/24"

  • Und wenn ich die Datei /var/log/openvpn anschaue, dann ist da eigentlich nur ein Eintrag, der aber ca. 500 x:

    Code
    Options error: --server directive network/netmask combination is invalid
    Use --help for more information

    Allerdings ist mein Eintrag in der "openvpn.conf" für "server" = "192.168.2.104" und die Subnetzmaske "255.255.255.0" bzw. in den Umgebungsvariablen "192.168.2.104/24"

    Dann versuch mal mit der Zeile:

    Code
    server 192.168.2.0 255.255.255.0

    statt

    Code
    server 192.168.2.104 255.255.255.0


    EDIT:


    Besser wäre m. E. aber die Zeile:

    Code
    server 10.8.0.0 255.255.255.0

    (oder gleichwertig).


    Siehe auch: https://wiki.ubuntuusers.de/OpenVPN/

    The most popular websites without IPv6 in Germany.

  • ok, mach ich. Hier sind übrigens doch noch Einträge vom 2. Februar im /var/log/openvpn (ich habe jetzt nur die reinkopiert, die mir relevant scheinen, sonst wäre das wohl zu lang):

  • ... Hat leider auch nichts gebracht... Ich habe den OpenVPN neu aufgesetzt, kann es sein, dass irgendwelche alten Einstellungen nicht richtig gelöscht wurden? Habe ihn mit -purge entfernt gehabt.


    Aber wie es ausschaut kam nach dem 3. Februar nichts mehr im openvpn.log außer diese Zeile:

    "Options error: --server directive network/netmask combination is invalid"

  • ... Hat leider auch nichts gebracht...

    Siehe EDIT oben. Wie ist danach der _aktuelle_ Eintrag in der Log-Datei? Oder gibt es nach der Änderung keinen Eintrag mehr?

    The most popular websites without IPv6 in Germany.

  • ..doch, es hat sich was getan:


  • ..doch, es hat sich was getan:

    Versuch mal auch mit:

    Code
    server 10.8.0.0 255.255.255.0

    statt "server 192.168.2.0 255.255.255.0".


    Hast Du auch den user und die group geändert?

    The most popular websites without IPv6 in Germany.

  • Ja, hatte ich geändert. Habe beide Versionen probiert: nouser/nogroup und openvpn/openvpn


    Bei 301. & 302 ...


    Ich habe jetzt nochmal user und group geändert, hier die Einträge aus dem log:


    Es muss was mit der fehlenden GID für die Gruppe openvpn zu tun haben... Aber wenn ich nogroup nehme, gibt er ja den gleichen Fehler aus

  • Ja, hatte ich geändert. Habe beide Versionen probiert: nouser/nogroup und openvpn/openvpn


    Bei 301. & 302 ...

    Naja, das sagt was anderes:

    Code
    Sun Mar 17 14:42:20 2019 us=608989 failed to find GID for group nouser
    Sun Mar 17 14:42:20 2019 us=609060 Exiting due to fatal error

    Wie ist die Ausgabe von:

    Code
    cat /etc/group | grep -iE 'openvpn|nogroup|nouser'

    ?

    The most popular websites without IPv6 in Germany.

  • Ich habs nochmal durchprobiert, mit "nogroup|nouser":

    Code
    Sun Mar 17 15:00:08 2019 us=157275 failed to find UID for user nouser
    Sun Mar 17 15:00:08 2019 us=157437 Exiting due to fatal error
    Sun Mar 17 15:00:08 2019 us=157650 /sbin/ip route del 192.168.2.0/24
    Sun Mar 17 15:00:08 2019 us=164221 Closing TUN/TAP interface
    Sun Mar 17 15:00:08 2019 us=164471 /sbin/ip addr del dev tun0 local 192.168.2.1 peer 192.168.2.2

    und mit "openvpn"

    Code
    Sun Mar 17 14:56:10 2019 us=566533 Data Channel MTU parms [ L:1622 D:1450 EF:122 EB:406 ET:0 EL:3 ]
    Sun Mar 17 14:56:10 2019 us=567712 failed to find GID for group openvpn
    Sun Mar 17 14:56:10 2019 us=567814 Exiting due to fatal error
    Sun Mar 17 14:56:10 2019 us=567916 /sbin/ip route del 192.168.2.0/24
    Sun Mar 17 14:56:10 2019 us=571266 Closing TUN/TAP interface
    Sun Mar 17 14:56:10 2019 us=571404 /sbin/ip addr del dev tun0 local 192.168.2.1 peer 192.168.2.2


    Die Ausgabe für "$ cat /etc/group | grep -iE 'openvpn|nogroup|nouser'" ist:

    Code
    root@raspberrypi:/var/log# cat /etc/group | grep -iE 'openvpn|nogroup|nouser'
    nogroup:x:65534:

    Er hat nur für "nogroup" eine GID ...

  • Ich habs nochmal durchprobiert, mit "nogroup|nouser":

    und mit "openvpn"

    Warum postest Du nicht die Ausgabe von:

    Code
    cat /etc/group | grep -iE 'openvpn|nogroup|nouser'

    ?

    The most popular websites without IPv6 in Germany.

  • Habs noch schnell an den Beitrag davor rangehängt gehabt:


    Code
    root@raspberrypi:/var/log# cat /etc/group | grep -iE 'openvpn|nogroup|nouser'
    nogroup:x:65534:

    Er hat anscheinend nur für nogroup eine GID