Kein Sound mit hifiberry-dac

    • Official Post

    https://bobrathbone.com/raspberrypi/pi_internet_radio.html


    Der Typ hat die Audio Einrichtung sehr gut beschrieben, musst dir Mal das PDF durchlesen - damit hat's bei mir immer geklappt.

    Achduschei... 237 Seiten? :conf: Wo genau hat er das beschrieben?

  • Hallo,


    genau für so einen Zweck hab ich das I-netradio gebaut.

    Nur ich restauriere die Radios und lasse sie möglichst im Originalzustand, deshalb ich das Projekt auch viel einfacher gestaltet.


    Als Zusatz kommt nur der Raspberry Zero die Soundkarte und noch eine kleine Elektronik rein die den Drehkondensator des AM-Bereiches auswertet.

    Das Audiosignal lege ich auf den internen Verstärker dort wo normalerweise die Kurzwelle einspeist.

    Schaltet man also das Röhrenradio auf KW so kann man mit dem Senderrad 12 Internetstationen durchdrehen.


    Das zweite ist gerade in Arbeit.

    Einen entsprechenden Zusatz für alte Transistorradios baue ich gerade mit einem ESP8266.

    I-Netsound läuft die Senderwahl und das Webinterface ist in Arbeit.


    Viele Grüße

    Thotaa

  • Hallo hyle,


    nein auf den ersten Blick wahrscheinlich nicht, aber was wollte ich sagen?

    Vielleicht muss man manchmal einfach ganz vorne, mit was Einfachem beginnen.


    Der Bob Rathbone benutzt auch Stretch, vielleicht liegts doch am Betriebssystem.


    Vielleicht geh ich auch von falschen Voraussetzungen aus.

    Als ich vor ca. 2 Jahren (ohne ca. 6 Monate Vorbereitung "wie gehe ich das Ziel an") mit dem Projekt gestartet habe gehörte zu der Grundausstattung 2 Raspis 3 B+; 2 Zero W ; 1 Zero; 3 Phat-DAC; 2 Chinasounds; ein Phytonbuch; Netzteile und Steckbretter und SD-Karten in ausreichender Anzahl (wiedererwarten ging davon nix über den Jordan).

    Ich habe bis zum ersten richtigen Erfolg bestimmt 10 (wenns reicht) mal SD-Karten geflasht und versucht einzurichten bis ich "mein System" so hatte wie es am besten für mich war. Und erst als ich wirklich mit allen Internetrecherchen und Foren durchstöbern nicht mehr weiter kam, hab ich hier meine erste Frage gestellt.

    Von dem was ich über Linux lernen musste (durfte), um an der einen oder anderen Stelle weiter zu kommen, mal ganz abgesehen.


    Wenn ich dann höre es fehlt an einem 3,5mm Kopfhörer versteh ichs halt begrenzt.
    Nicht böse sein, aber geh zu Mediamarkt und kauf einen für 3,50 Es und 2 SD-Karten für je 10Es gleich mit.

    Und was ich noch verdeutlichen wollte, so was geht nicht schnell, schon gar nicht hopplahopp neben Schule oder Beruf her.

    Da muss man sich einlesen, ausprobieren, erfolgreich Scheitern, den nächsten Versuch besser machen.

    Das bringt einen weiter.


    Viele Grüße

    Thotaa

  • Hallo,

    https://bobrathbone.com/raspberrypi/pi_internet_radio.html
    Der Typ hat die Audio Einrichtung sehr gut beschrieben, musst dir Mal das PDF durchlesen

    Documentation

    Raspberry PI Radio.pdf

    in der Dokumentation von Bob Rathbone gibt es ein Kapitel Raspberry Pi 7-inch touch screen mit einem Link auf eine Seite von Nov 17, 2015

    Quote from Bob Rathbone

    There is a very good setup guide for the Raspberry Pi touch-screen at: https://www.modmypi.com/blog/raspberry-pi-7-touch-screen-assembly-guide

    Diese Anleitung (vom 17.11.2015) das 7" Raspberry Pi Touch Display an einen Raspberry Pi anzuschließen, beschreibt 4 Jumper-Kabel zwischen Display-Platine und Raspberry-Platine (GND, 5V, SCL, SDA).


    Die Jumper-Kabel für SCL und SDA waren nur für den RPi 1B notwendig, weil dort i2c0 nicht am Display-Port (DSI) angeschlossen waren. Quelle


    Es gibt 2 i2c-Anschlüsse, am GPIO liegt i2c1 und am Display-Port (DSI) liegt i2c0. Quelle


    Schönen Gruß, kle

  • so hätte ich Manul weiter oben auch verstanden, der die Karte sein 3,5 Jahren nutzt

    Das war ein Missverständnis, ich habe eine Hifiberry DAC+ im Einsatz, die an einen externen Verstärker angeschlossen ist.


    Diese Karte wird über den snd_rpi_hifiberry_dacplus-Treiber betrieben, ich weiss also nicht, in wie weit sich meine Erfahrungen übertragen lassen.


    Der Vollständigkeit halber trotzdem: Ich betreibe die Karte auf einem Raspbian stretch, Kernel 4.14.98-v7+. Ich habe keine /etc/asound.conf. Der einzige Eintrag in meiner /boot/config.txt ist dtoverlay=hifiberry-dacplus.


    Nachtrag: Daß die Lautsprecher funktionieren, hast Du anderweitig bestätigt?

  • raspbastler Wurde nicht über Hifiberry Amp2 gesprochen, der hat doch I2C? Gut ich bin auf ungestellte Fragen eingegangen. sorry bin wieder weg.

    Bleib ruhig hier so war das nicht gemeint ;)


    Sondern eher das man ne andere Anleitung hat zur Einrichtung von Soundkarten..

    Wenn's brennt 112 hilft weiter!

  • Hallo zusammen,


    Thotaa: ok - du hörst eben schon was mit 'speaker-test'. Da fängt es bei mir an, da ich da nichts höre. Insofern verstehe ich auch, dass ich dannach mit keiner Software einen Ton hören kann.


    Thotaa: dein Beitrag 26: ich nutze ebenfalls Stretch. Und ich habe mein erstes Projekt vor ca 3 Jahren begonnen und umgesetzt. Seitdem auch 2 Projekt ununterbrochen am Laufen. Nun wollte ich mir letztes Jahr ein Internet-Radio bauen. Also viel Rechere betrieben und gelesen und dann begonnen. LCD Display läuft, alles andere kann ich ebenfalls. Aber ich schaffe es eben nicht einen Ton zu hören und deswegen habe ich nach ca 4 Monaten Suche gedacht, ich schaue mal, ob ich hier Hilfe finde....


    raspbastler:

    Diese Anleitung kenne ich. Habe ich auch schon vor längerer Zeit, als ich mit meinem Projekt begonnen habe, gelesen.

    Er beschreibt zwar ganz viele Sachen - auch absolute Basics wie OS installieren - extrem detailliert, ich finde aber keine Detailkonfiguration für den hifiberry-dac.

    Irgendwann nutzt er eine Software 'configure_radio'. Aber alles andere wie LCD Display hätte ich schon am Laufen.

    Er verweist dann auf troubleshooting ab Seite 108, aber das hilft mir eben auch nicht weiter:-(


    raspbastler:

    Vielleicht liegt mein Problem doch in der Konfiguration von alsa oder ...

    Hast du evtl eine Idee, was ich noch prüfen könnte?


    Viele Grüße

    Mike

  • Hallo Manul,


    ich habe extra noch ein zweites Lautsprecher alternativ angeschlossen, die ich vorher auch getestet hatte.

    Ich nutze ebenfall Raspbian strech mit Kernel 4.14.98-v7+.

    Ich habe in der /boot/config.txt diesen Eintrag:

    dtoverlay=hifiberry-dac

    Ich habe eine asound.conf mit diesem Inhalt:

    pcm.!default {

    type hw card 0

    }

    ctl.!default {

    type hw card 0

    }


    Viele Grüße

    Mike

  • Hallo Mike300,


    wir bemühen uns weiter, und es ehrt Dich wenn Du die entsprechende Vorarbeit geleistet hast, war auch durch aus konstruktiv gedacht.


    Was ich ganz vergessen (oder überlesen habe) ist der Speakertest, wenn das nicht geht brauchen wir uns auch mit den Playern und drum rum nicht weiter beschäftigen.


    Als erstes wäre jetzt wichtig, kommt was (auch Speakertest) aus dem 3,5mm Jack auf dem Raspi, wenn ja geht die Umleitung zur i2S nicht.

    Alles andere stellen wir hinten an.


    Viele Grüße

    Thotaa

  • Hallo MIke300,


    und was natürlich immer noch im Raum steht, ist der Miniamp defekt?


    Wo könntest Du den Testen, hast Du jemand in der Nähe der eine zweite i2S Karte hat.


    Viele Grüße

    Thotaa

  • Hallo Thotaa,


    ich habe eben eine PC-3,5mm-Klinken Kopfhörer angeschlossen. Mit speaker-test höre ich leider ebenfalls nichts.

    Aber brauche ich da nicht einen speziellen Klinkenstecker für den Raspi (ich habe da was im Kopf, dass die Buchse am Raspi 4 Ringe hat)

    Dann müsste ich mir so einen Adapter besorgen.


    Den Miniamp könnte ich höchstens an einem anderem Raspberry Pi testen. Ich habe noch einen Zweier-Raspberry, derzeit aber in einem Projekt eingebaut.

    Umgekehrt kenne ich leider niemanden, der auch den hifiberry-dac hat oder nutzt, so dass ich mal temporär tauschen und testen könnte.


    Viele Grüße

    Mike

  • Hallo Mike300,


    nein, der Standart-Kopfhörer tuts.

    Der 4. Ring ist ein Mikrophoneingang und da das bei einem "Nurkopfhörer" durchgehendes Metall ist, eben kurzgeschlossen und damit außer Funktion.


    Mmh jetzt wirds interessant, den Miniamp am anderen Raspi zu testen wird wohl nichts bringen da Du dort auch nur die bekannten Einstellungen vornehmen kannst.


    Hast Du die I2C Schnittstelle im "raspi-config" aktiviert, das ist glaub auch nötig damit die I2S läuft?


    Langsam wirds eng mit Hilfe aus der Ferne.


    Viele Grüße

    Thotaa

  • Hallo Thotaa,


    ok. Danke für den Hinweis für den 4. Ring (dann muss ich da nicht mehr suchen)


    Ich habe eben mit sudo raspi-config den I2C zur Sicherheit nochmals enabled:


    ┌──────────────────────────────────────────────────────────┐

    │ │

    │ The ARM I2C interface is enabled │

    │ │


    Kopfhörer mit speaker-test danach aber leider auch noch ohne Ton.


    Viele Grüße

    Mike