Samba Freigabe Funktioniert nicht Richtig

  • Hallo Leute,

    ich habe ein Problem: Mein Samba-Server auf einem RPi 3B funzt nicht mehr richtig. Ich wollte mich heute einloggen, und dsa funktionierte auch, doch wurde dann behauptet, ich hätte keine Schreibberechtigung. Dies ist bei den ersten beiden Freigaben der Fall, bei der dritten habe ich keine Probleme:

    [Blocked Image: http://playlix42.github.io/media/hs.png]


    Erst dachte ich, es läge an den Zugriffsrechten auf die Externe Festplatte, auf der die ersten beiden Freigaben liegen, allerdings kann ich mit "root" über den Pfad vom Wurzelverzeichnis aus darauf zugreifen und schreiben. Alles irgendwie ziemlich verwirrend :conf:.

    Kann mir da irgeneiner weiterhelfen? :helpnew:

    Es ist zum Explodieren!!!:@

    Schonmal Danke im Voraus!

    LG, Playlix

  • . Ich wollte mich heute einloggen, und dsa funktionierte auch, doch wurde dann behauptet, ich hätte keine Schreibberechtigung.

    Der User "ich" funktioniert bei mit auch nicht.


    Wie ist die Ausgabe von < lsblk > und von < mount >, bei angeschlossener USB-HD ?


    Ist in den Logfiles eine Auffälligkeit erkennbar ?


    Servus !

    RTFM = Read The Factory Manual, oder so

  • Ich muss später mal schauen, ob ich heute zeit finde, das abzufragen. Und ich meinte übrigens nicht den Benutzer "ich", sondern wurde mir im Dateimanager angezeigt, dass es keine Schreibberechtigung gäbe. Aber wie gesagt: über "root" kann ich auf die externe Festplatte (Toshiba, keine externe Stromversorgung) schreiben.

    Oder sollte ich einfach mal Samba neu installieren?


    LG, Playlix

  • Oder sollte ich einfach mal Samba neu installieren?

    Kannste machen, vielleicht bringt das unter Windows ja was, aber außer Zeitverschwendung wird das hier an Deinem Problem so gar nichts ändern. Ein sinnvolles Vorgehen sieht anders aus, beginne mit:

    Wie ist die Ausgabe von < lsblk > und von < mount >, bei angeschlossener USB-HD ?

    Danach kopierst Du die /etc/samba/smb.conf in einen Codeblock (das Zeichen da oben: </>).


    Fragen für Zusatzpunkte:


    • Hat der Zugriff über Samba irgendwann einmal funktioniert?
    • Wenn ja, was hast Du dann geändert?
    • Welchen Dateimanager meinst Du, den auf dem RPi oder den auf Deinem Windows Rechner?
    • Was ist die Ausgabe auf Deinem Pi von ls -lisa /media/hs?
    • Die ganzen Nutzer (pi, hs, Nutzer, ToFeMi) gibt es? Du hast die auch in der Userdatenbank von Samba angelegt?
    • Wozu benötigst Du write list, wozu force user?
    • Welches Dateisystem hat die externe Platte?
  • sondern wurde mir im Dateimanager angezeigt, dass es keine Schreibberechtigung gäbe.

    das ist so nicht richtig

    rufe den Dateimanager mit root auf dann kannst du schreiben, andere Möglichkeit, root ändert die Dateirechte für andere User.


    sudo pcmanfm

    Images

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

  • Kannste machen, vielleicht bringt das unter Windows ja was, aber außer Zeitverschwendung wird das hier an Deinem Problem so gar nichts ändern.

    Hallo STF,

    der Server läuft auf einem RPi 3B, und die Frage war so gemeint, ob es sinnvoll wäre, den Server-Server neu zu installieren.


    LG, Playlix

  • das ist so nicht richtig

    rufe den Dateimanager mit root auf dann kannst du schreiben, andere Möglichkeit, root ändert die Dateirechte für andere User.


    sudo pcmanfm

    Hallo jar,

    das klingt erstmal logisch und brauchbar, ich werde es mal ausprobieren.


    LG, Playlix

  • der Server läuft auf einem RPi 3B, und die Frage war so gemeint, ob es sinnvoll wäre, den Server-Server neu zu installieren.


    Bitte?


    In meinem Verständnis hängt an Deinem RPi eine externe Platte, Samba ist installiert und Du möchtest von einem WinPC auf die Freigabe zugreifen. Nein, einen Dienst oder Programm (samba in dem Fall) auf einem Linux Rechner einfach mal neu zu installieren, bringt nur ganz selten etwas. Ich habe ein paar Fragen in #4 ergänzt.

    logisch und brauchbar

    Nein, das ist weder logisch noch brauchbar. Nur, weil root das darf (der darf ja fast alles), heißt das noch lang nicht, dass es sinnvoll ist. Die unterschiedlichen Rechte und damit verbundenen Zugriffsmöglichkeiten (oder auch nicht) haben schon ihren Sinn.

  • rufe den Dateimanager mit root auf dann kannst du schreiben, andere Möglichkeit, root ändert die Dateirechte für andere User.

    Das habe ich jetzt erst gesehen. Die Freigabe heißt "root", laut Bild kommen die Rechte von "pi", Und wenn der überall alles darf, na denn: Gute Nacht. Alles ziemlich verwirrend und wenig zielführend, den PCManFM mit sudo aufzurufen.


    Playlix , beantworte doch bitte einmal die Fragen aus #4 , dann sehen wir weiter.


    Aber wie gesagt: über "root" kann ich auf die externe Festplatte (Toshiba, keine externe Stromversorgung) schreiben.

    Was auch logisch wäre: Über die Freigabe namens "root" greift der Nutzer pi auf die externe Platte zu. Playlix , verwende besser keine definierten Begriffe für diese Dinge und beschreibe klar, was Du womit genau gemacht hast/machen wolltest.


    Ich verweise gern noch auf Hofei s Anleitung zum Fragen fragen...

  • Oder sollte ich einfach mal Samba neu installieren?

    Dann musst Du alles neu konfigurieren.


    Besser Du berichtigst zuerst Deine mounts, überprüfst Deine Festplatte zumindest 1x wöchentlich, machst eine ordentliche smb.conf samt Samba-Userverwalting und verlässt Dich nicht darauf, dass chmod 777 alle Zugriffsprobleme beseitigt; genau das Gegenteil ist nämlich der Fall.


    Fang mit einer Kopie von /usr/share/samba/smb.conf an und lass das verrückte [root] jedenfalls weg.



    Servus !

    RTFM = Read The Factory Manual, oder so

    • Hat der Zugriff über Samba irgendwann einmal funktioniert?
    • Wenn ja, was hast Du dann geändert?
    • Welchen Dateimanager meinst Du, den auf dem RPi oder den auf Deinem Windows Rechner?
    • Was ist die Ausgabe auf Deinem Pi von ls -lisa /media/hs?
    • Die ganzen Nutzer (pi, hs, Nutzer, ToFeMi) gibt es? Du hast die auch in der Userdatenbank von Samba angelegt?
    • Wozu benötigst Du write list, wozu force user?
    • Welches Dateisystem hat die externe Platte?

    Also, dann fang ich mal an:

    - Der Zugriff über Samba hat so nicht funktioniert.

    - Ich nutze zum Testen kein Windows, sondern Ubuntu; ich meine den auf dem Ubunturechner.

    - ls -lisa /media/hs gibt folgendes aus:

    Code
    insgesamt 6344
     5    4 drwxr-xr-x 1 pi   root    4096 Apr 24 16:42 .
    19    4 drwxr-xr-x 4 root root    4096 Apr  3 21:12 ..
    65    4 drwxr-xr-x 1 pi   root    4096 Apr  7 18:02 BWKI
    35 1288 -rwxr-xr-x 2 pi   root 1317593 Okt  6  2016 Instruction Manual for Safety and Comfort.pdf
    66    4 drwxr-xr-x 1 pi   root    4096 Apr 24 16:42 Public
    82    0 drwxr-xr-x 1 pi   root       0 Apr 24 16:42 sddd
    36 5020 -rwxr-xr-x 2 pi   root 5138052 Dez  5  2017 TOSHIBA CANVIO BASICS.pdf
    77   20 -rwxr-xr-x 1 pi   root   17727 Okt  5  2013 twofing-0.1.2.tar.gz

    - hs ist nur das Mountverzeichnis, ich hab in media den Mountpoint "hs" angelegt; Wie lege ich die Benutzer darin an?

    - Keine Ahnung, das stand mal in so nem Tutorial, daraus hatte ich das übernommen

    - Die Externe Festplatte hat das Dateisystem NTFS, ich binde sie vorher immer mit sudo mount -t ntfs -o uid=1000,umask=0022 /dev/sda1 /media/hs ein.


    LG, Playlix

  • Und weil danach gefragt wurde, hier der inhalt von smb.conf:

    Edited once, last by Playlix ().

  • OK, das sieht doch erst mal gar nicht so schlecht aus. Wenn das noch nie funktioniert hat, dann schreib bitte etwas anderes als:

    Samba-Server auf einem RPi 3B funzt nicht mehr richtig.

    Der Nutzer pi darf auf Deiner externen Platte arbeiten, das mounten scheint mir erst mal OK zu sein.


    Welche Nutzer soll es zusätzlich geben und wo sollen die zugreifen dürfen? Soll es überhaupt weitere Anmeldungen geben?


    Edit: smb.conf:


    Das Verzeichnis fehlt schon mal auf Deiner Platte, die Freigabe funktioniert so nicht:

    path = /media/hs/General/

  • Also, es soll die Möglichkeit geben,

    - sich als "pi" mit dem root passwort einzuloggen, um das gesamte System bearbeiten zu können (das funktioniert, letzte Freigabe)

    - sich als "nutzer" mit dem Passwort von "nutzer" in /media/hs/Public einzuloggen

    - sich als "ToFeMi" mit dem Passwort von "ToFeMi" in /media/hs/BWKI einzuloggen


    Ach, und Danke für die Berichtigung, habe ich geändert.


    LG, Playlix

  • - sich als "pi" mit dem root passwort einzuloggen, um das gesamte System bearbeiten zu können (das funktioniert, letzte Freigabe)

    Das ist ein Denkfehler. Der Nutzer "pi" hat per se keine root Rechte und kein root Passwort (er hat sein eigenes). Er darf sudo innerhalb des Systems benutzen, um sich root-Rechte zu verschaffen. Über samba darf er genau das lesen/schreiben/ändern, was er auch lokal (ohne sudo) dürfte.


    Ob der Zugriff auf eine mit NTFS formatierte Platte über Samba mit unterschiedlichen Nutzern und Rechten überhaupt funktioniert, kann ich aus dem Stand nicht sagen. Das müsste ich selbst ausprobieren.

  • Hallo STF,

    es wäre auch möglich, alle Server zusammenfließen zu lassen (auf eine Freigabe).

    Ich denke, das ist wesentlich einfacher hinzubekommen.


    LG, Playlix

  • Hallo an alle:

    Ich habe nun alle Server zusammenlaufen lassen, und siehe da, es funktioniert!!!

    Ich danke erstmal für euer Engagement und eure Zeit.

    Ich wünsche euch noch eine schöne Woche!


    LG, Playlix

  • Sie ist bereis als Gruppe root gemountet. (weil der mountbefehl ohne gid= Option aufgerufen wird, und daher die gid des aufrufenden Prozesses herangezogen wird.)


    Ob bei einem bind/remount sich auch die uid bei einer NTFS Partition ändern lässt, weiss ich nicht (habe kein NTFS).


    Di kannst aber die Partition auch mehrmals mit verschiedener uid / gid auf verschiedene mountpoints mounten und dann das Verzeichnis /BWKI dem (SMB-)User "ToFeMi" und das Verzeichnis /Public dem User "Nutzer" freischalten.


    Servus !

    RTFM = Read The Factory Manual, oder so