Watchdog dauerhaft starten

  • Hallo,


    ich möchte den Watchdog auf meinem Raspberry dauerhaft aktivieren.

    Ich hatte es so verstanden dass dieses erfolgt wenn ich mit sudo /etc/init.d/watchdog start starte.

    Der Watchdog resetet dann aber nur ein mal.

    Nach dem Booten ist er offensichtlich wieder aus


    Was muss ich sonst noch tun?

  • ich möchte den Watchdog auf meinem Raspberry dauerhaft aktivieren.

    Den hardware-watchdog kannst Du mit:

    Code
    1. dtparam=watchdog=on

    in der "/boot/config.txt"-Datei starten. Siehe danach die Ausgaben von:

    Code
    1. ls -la /dev/watchdog*
    2. sudo vcgencmd measure_temp

    Mit einer forkbomb kannst Du den hardware-watchdog testen.

    Der software-watchdog wird m. E. nicht benötigt:

  • Hallo,


    ich vermute dass dein Vorschlag für die Temeperaturüberwachung funktioniert.

    Was ich nicht dazu gesagt hatte war dass ich den Watchdog für die Überwachung eines Programms nutzen möchte.

    Ich beschreibe dazu regelmäßig eine Textdatei.

    Im Einzelnen habe ich das in der config so hinterlegt:


    sudo nano /etc/watchdog.conf


    Code
    1. change = 30
    2. max-load-1 = 24
    3. realtime = yes
    4. file = /home/pi/Desktop/Watchdog/Watchdog.txt

    Wenn ich es richtig verstanden habe müsste nun die Datei Watchdog.txt spät nach 30sec beschrieben werden.


    Leider geht das nur ein mal. Nach dem Neustart ist der Watchdog scheinbar wieder dafür ausgeschaltet


    P.s.

    Hier übrigens noch die Info nach dem Restart:


    Code
    1. ls -la /dev/watchdog*
    2. crw------- 1 root root 10, 130 Mai 19 08:12 /dev/watchdog
    3. crw------- 1 root root 252, 0 Mai 19 08:12 /dev/watchdog0

    Edited once, last by Düsentrieb: Hinweis vergessen ().

  • Danke für deine Unterstützung!


    Nach dem Neustart:

    Code
    1. systemctl status watchdog
    2. ● watchdog.service - watchdog daemon
    3. Loaded: loaded (/lib/systemd/system/watchdog.service; static)
    4. Active: inactive (dead)



    Hier die Ausgaben:



    Laufen tut der Watchdog nachdem ich ihn manuell gestartet habe.

    Der Watchdog wirkt wenn ich das Programm anhalte

  • Hi,


    hier die Ausgaben:


    systemctl status watchdog

    ● watchdog.service - watchdog daemon

    Loaded: loaded (/lib/systemd/system/watchdog.service; static)

    Active: inactive (dead)


    systemctl is-active watchdog

    inactive



    Es startet einfach nicht....

  • Quote

    Nach dem Neustart:

    Code

    1. systemctl status watchdog
    2. ● watchdog.service - watchdog daemon
    3. Loaded: loaded (/lib/systemd/system/watchdog.service; static)
    4. Active: inactive (dead)

    Direkt nach dem Neustart war die Ausgabe auch nach #7 die gleiche.

    Ich habe dann manuell gestartet

  • die sieht so aus:


    cat /lib/systemd/system/watchdog.service

    [Unit]

    Description=watchdog daemon

    Conflicts=wd_keepalive.service

    After=multi-user.target

    OnFailure=wd_keepalive.service


    [Service]

    Type=forking

    EnvironmentFile=/etc/default/watchdog

    ExecStartPre=/bin/sh -c '[ -z "${watchdog_module}" ] || [ "${watchdog_module}" = "none" ] || /sbin/modprobe $watchdog_module

    ExecStart=/bin/sh -c '[ $run_watchdog != 1 ] || exec /usr/sbin/watchdog $watchdog_options'

    ExecStopPost=/bin/sh -c '[ $run_wd_keepalive != 1 ] || false'


    [Install]

  • die sieht so aus:


    cat /etc/default/watchdog

    # Start watchdog at boot time? 0 or 1

    run_watchdog=1

    # Start wd_keepalive after stopping watchdog? 0 or 1

    run_wd_keepalive=1

    # Load module before starting watchdog

    watchdog_module="none"

    # Specify additional watchdog options here (see manpage).