Pi findet Bluetooth Tastatur nach Neustart nicht

  • Hallo,


    ich betreibe den Raspberry 3B+ unter Raspbian mit einer KeySonic Multimedia Bluetooth Tastatur mit Touchpad, was die meiste Zeit gut funktionierte.


    Leider erkennt der Pi nun bei Neustart die Tastatur nicht mehr, ich muss eine Maus anschließen und die Tastatur im Raspbian entfernen und dann neu verbinden. Ist verständlicherweise recht nervig.


    Hat jemand einen Ansatz dass die Bluetooth Tastatur wieder wie gehabt nach Bootup erkannt wird?


    Thx

  • Was hast Du denn geändert, bevor es nicht mehr funktionierte ?

    Update, config.txt, /etc/modules, raspi.config, BT=on/off, Programm geschrieben/installiert ... ?


    Ist es die KSK-8022BT, oder die -5220BT ?



    Servus !

    RTFM = Read The Factory Manual, oder so

  • Was hast Du denn geändert, bevor es nicht mehr funktionierte ?

    Update, config.txt, /etc/modules, raspi.config, BT=on/off, Programm geschrieben/installiert ... ?

    Wenn dann kann es nur ein Update gewesen sein. Die mache ich regelmäßig, ansonsten habe ich nicht "gespielt".


    ... es handelt sich um die KSK-5220BT!

  • Die KSK-5220BT ist schon richtig.

    Da ist wohl beim letzten Update was schief gelaufen.

    Wurden alle Pakete fehlerfrei instaliert, oder ist etwas zurückgeblieben?

    Hast Du aus der Grafikkonsole am Pi das Update durchgeführt, oder remote per ssh ?

    Vor upgrade auch update ausgeführt ?


    Sonst sollte in den Logfiles Hinweise enthalten sein, warum nicht schon im Bootprozess die BT Tastatur aktiviert wird.


    Servus !

    RTFM = Read The Factory Manual, oder so

  • soweit ich mich entsinne hat alles fehlerfrei funktioniert

    ich mach die updates mal so mal so, glaube aber dass ichs in der konsole auf dem desktop durchgeführt habe

    ja klar update for upgrade...


    welche logfiles wären da interessant?

  • Hallo,

    habe das Thema über Google gefunden... wollte nur kurz Bescheid geben, dass ich auch ein Leidensgenosse bin (Logitech Cordless Mediaboard Pro, als Maus und Tastatur Ersatz)


    Eben per update && dist-upgrade aktualisiert und bin für den Moment ausgesperrt, weil ich hier keine USB-Tastatur zur Hand habe.


    Unter anderem war ein Kernel Update dabei... leider habe ich mir diesmal die Liste der Updates aber nicht genau angesehen.

  • puh, was mach ich als Noob jetzt damit

    Beim apt-log wäre interessant, ob Bluetooth Pakete aktualisiert wurden (z.B. bluez).


    Ich frage mich, ob eventuell das Kernel Module nicht geladen wird oder der bluetooth.service nicht startet?


    Morgen versuche ich mal meine Tastatur in den Umzugskartons aufzuspüren...

  • Habs mir eben ansehen können und auch mal bluetoothctl gestartet.


    Sofort fällt die Ausgabe auf, die im Sekundentakt so fortgesetzt wird:

    [CHG] Device die-mac-adresse Connected: yes

    [CHG] Device die-mac-adresse Connected: no

    [CHG] Device die-mac-adresse Connected: yes

    [CHG] Device die-mac-adresse Connected: no

    ...


    Danach habe ich das Gerät aus der Liste entfernt und neu gepaired. Noch auf trusted gesetzt und schon konnte ich problemlos connecten... kein Fehler und eine ganz normale Ausgabe.


    Wenn das Gerät danach aber wieder getrennt wird, egal ob durch Standby, disconnect Befehl oder Power off an der Tastatur... beim Verbindungsversuch danach geht wieder die "Connected: yes/no Schleife" los.


    Ich vermute es liegt an der bluez-firmware (1.2-4, Link).









    Edit: Wenn ich nachher oder morgen Zeit finde, versuche ich ein Downgrade auf 1.2-3+rpt7:



    sudo apt-get install bluez-firmware=1.2-3+rpt7


    Edit2: bluez-firmware ist es nicht... vielleicht liegt es doch am Kernel? Es gab nen Sprung von 4.14 zu 4.19 (1.20190401-1 zu 1.20190517-1)

    Edited 3 times, last by M0rtin ().

  • Hallo nochmal,

    ich würde es gerne mit einem Downgrade versuchen, habe aber noch nie rpi-update verwendet.


    "sudo rpi-update a08ece3"


    Ist doch der korrekte Befehl und die Commit-Nummer vom letzten richtigen 4.14.98 Kernel?

    Hab da etwas Angst vor... :)

    • Official Post

    Hallo M0rtin,


    keine Ahnung warum Du gerade auf 4.14.98 zurück willst (sorry, hab den Rest nicht gelesen), aber die korrekte Commit ist a08ece3d48c3c40bf1b501772af9933249c11c5b also wäre der Befehl dann:

    Code
    sudo rpi-update a08ece3d48c3c40bf1b501772af9933249c11c5b

    Viel Glück! ;)

  • Das dürfte tatsächlich am Kernel liegen. Habe plötzlich die gleichen Probleme unter OpenSuse Leap 15! Nachdem ein Downgrade der Module mit Bluetooth (bluez, libbluetooth3 und ein SecurityUpdate für bluez) nichts brachte, bin ich vom Kernel 4.12.14-lp150.12.61.1-x86_64 auf 4.12.14-lp150.12.58.1-x86_64 zurück gegangen. Scheinbar handelt es sich nicht um den gleichen Kernel (ev. wegen ARM/x86?). Es sieht so aus als jetzt alles wieder OK...
    Dieser englische Beitrag brachte mich auf die Idee mit den Downgrade...

    ...wenn Software nicht so hard-ware ;) ...

    Freue mich über jeden like :thumbup:

  • hyle

    Daneschön für deine Antwort


    @all

    Juhuuu... mit der 4.14.98 Firmware/Kernel funktioniert die Bluetooth-Tastatur wieder prima.

    Habs auch nochmal extra mit der aktuellen 4.19 gegengeprüft und es gab wieder den "Connected: yes/no"-Loop.

  • Nachdem ich jetzt ein paar Tage verreist war wieder eingeloggt - auch für mich hat das downgrade auf ggst. Kernel das Problem behoben! Danke also an alle!


    ...eine Frage noch zu weiteren Updates - wie soll man am besten vorgehen um zu vermeiden dass das Problem wieder auftaucht? Erst bei nächstem Kernel Release wieder updaten?

  • Also ich werde das unter openSuse so handhaben - erst beim nächsten Kernel ein Update machen und wenn es wieder Probleme gibt, weiß ich ja welche Version ich brauche...

    ...wenn Software nicht so hard-ware ;) ...

    Freue mich über jeden like :thumbup: