Raspbian: Sound von Videos stockt manchmal

  • Wenn ich ein YouTube Video abspiele oder auch im VLC Player ein Video ansehe, egal wo, wird der Sound nicht fliessend abgespielt. Es kommt immer zu kurzen Ausfaellen des Sounds und das stoert extrem. Frueher war das nicht gewesen, ich finde leider keine Loesung fuer dieses Problem, ausser das dies existiert. Ist das allgemein bekannt? Kann man da was machen?

    Raspberry Pi 3B
    Raspian GNU/Linux 9.9 (Stretch)
    Kernel: 4.14.98-v7*

  • Habe den Raspberry ganz normal ueber HDMI Kabel mit einem Monitor/TV verbunden. Ueber Kodi scheint es zu funktionieren, im Raspbian spackt es. Nervt besonders wenn man Musik ueber YouTube schaut :(

    Raspberry Pi 3B
    Raspian GNU/Linux 9.9 (Stretch)
    Kernel: 4.14.98-v7*

  • Auf einem alten System habe ich 4.14.92-v7+ und dort funktioniert alles super.


    Auf dem aktuellen System verwende ich 4.19.42-v7+ und dort buggt der Sound!

    Weiteres zum aktuellen System:

    pi@Raspberry:~ $ lsb_release -a

    No LSB modules are available.

    Distributor ID: Raspbian

    Description: Raspbian GNU/Linux 9.9 (stretch)

    Release: 9.9

    Codename: stretch


    Was kann man tun?

    Raspberry Pi 3B
    Raspian GNU/Linux 9.9 (Stretch)
    Kernel: 4.14.98-v7*

  • Problem geloest! Ich habe ein Downgrade auf deine genannte Version versucht und das Problem ist weg! Du hast geschrieben dass 4.14.98 die neueste Version ist (?), wie kann es sein dass ich 4.19.42 nach einem herkoemmlichen Update erhalten habe? Diese Version war jedenfalls buggy, unter 4.14.98 gibts keine Probleme. Hatte ich mit diesem Befehl installiert:


    sudo rpi-update a08ece3d48c3c40bf1b501772af9933249c11c5b



    Damit ist das Problem geloest.

    Raspberry Pi 3B
    Raspian GNU/Linux 9.9 (Stretch)
    Kernel: 4.14.98-v7*

  • ..., wie kann es sein dass ich 4.19.42 nach einem herkoemmlichen Update erhalten habe?

    Weil das die aktuelle Kernelversion für raspbian-stretch ist.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Ihr muesstet doch auch alle Probleme haben, zumindest diejenigen die das einfache Update ausfuehren, Videos mit bugfreien Sound abspielen zu koennen?

    Der Downgrade hat geholfen und ich werde jetzt erstmal lange Zeit kein Update mehr durchfuehren! Das System tut was es soll und auf neue Bugs habe ich keine Lust.

    Raspberry Pi 3B
    Raspian GNU/Linux 9.9 (Stretch)
    Kernel: 4.14.98-v7*

  • Das System tut was es soll und auf neue Bugs habe ich keine Lust.

    Du kannst ja versuchen den Kaufpreis für BS samt Updates zurückzuverlangen, wenn Dein Update mit wesenlichen, unbehebbaren Mängeln behaftet war/ist.


    Servus !

    RTFM = Read The Factory Manual, oder so

    • Official Post

    Ihr muesstet doch auch alle Probleme haben, zumindest diejenigen die das einfache Update ausfuehren, Videos mit bugfreien Sound abspielen zu koennen?

    YT Videos am RPi abspielen? :shy: Nö, das bleibt für mich ein Lern- und Bastelcomputer!

  • Ihr muesstet doch auch alle Probleme haben, zumindest diejenigen die das einfache Update ausfuehren, Videos mit bugfreien Sound abspielen zu koennen?

    Nein, warum? Man kann seine Software ja so konfigurieren bzw. optimieren, dass diese auch mit dem aktuellen Kernel funktioniert.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Ihr muesstet doch auch alle Probleme haben, zumindest diejenigen die das einfache Update ausfuehren, Videos mit bugfreien Sound abspielen zu koennen?

    Hier läuft der zur Zeit aktuelle Kernel 4.19.42-v7+ und ich konnte keine Sound Aussetzer feststellen. Hier ist der RPi 3B auch über HDMI am TV angeschlossen. Du hast geschrieben, das es bei dir unter Kodi keine Sound Probleme gibt, nur unter Raspbian. Betraf/ betrifft das omxplayer und vlc? Da Kodi, soweit mir bekannt, den omxplayer benutzt, könnte man hier das Problem eingrenzen. Vielleicht hast du auch irgendein Programm laufen, welches stört (top/htop während des Video abspielen mitlaufen lassen). Hast du pulseaudio installiert?

  • Ne, was ist pulseaudio?


    Ueberaschende weise habe ich das gleiche Problem unter Retropie im Amiberry-Emulator! Wie tue ich das downgraden? Langsam wird es nervig, ich habe das Modell 3b+, vielleicht ist damit einiges inkombatibel?

    Raspberry Pi 3B
    Raspian GNU/Linux 9.9 (Stretch)
    Kernel: 4.14.98-v7*

  • Pulseaudio (apt-cache show pulseaudio) ist ein Sound Server. Wenn nicht installiert, dann gut.


    Hast du das HDMI Kabel überprüft oder getauscht? Ist der Fernseher i.0. (ggf. ein Anderen testen)? Wie ist der Sound über analog Klinke? Kannst du andere Störquellen ausschliessen?

  • So, habe eine alte Version von Retropie auf eine neue SD-Karte kopiert, dort ist der Fehler nicht vorhanden. Woran es lag weiss ich nicht, aber wenigstens funkioniert es wieder. Man sollte immer Backups seines Systems bereit haben!

    Raspberry Pi 3B
    Raspian GNU/Linux 9.9 (Stretch)
    Kernel: 4.14.98-v7*

  • Habe monatelang nach einer Lösung für die Sound-Aussetzer gesucht und gefunden:

    - Replace raspberry durch alten Notebook unter WIndows.....

  • Sound-Aussetzer ... - Replace raspberry ... Notebook unter WIndows.....

    Tach @mkirc und herzlich willkommen im Forum. Das ist natürlich DER Einstieg hier. Vielen Dank für die äußerst hilfreiche Aufklärung. [Blocked Image: https://media.tenor.com/images/f6deb8b22a76a72b545b7cf235b1cb6b/tenor.gif]