keine Lan-Verbindung zum PC möglich wenn UMTS Stick in RPi

  • Ich Grüße euch,


    Eine kurze Erklärung was ich vor habe:

    ich möchte mir eine Alarmanlage basteln welche in einen Proberaum installiert wird. Dieser Proberaum ist ca. 20 min von mir zu Hause entfernt.

    Die Meldungen sollen über einen UMTS-Stick (Huawei E3531) und Telegram zu mir geschickt werden.


    Momentan hängt es daran das ich, wenn ich den UMTS-Stick an den Pi schmeiße, mir die Lan-Verbindung zum Laptop abschmiert.

    Wenn ich vor Ort zum Bsp. meine Python Scripte Testen will muss ich den UMTS-Stick vorher abziehen bevor ich eine Lan-Verbindung von Laptop zum Pi herstellen kann.


    RPi 3 B+

    Als Betriebssystem habe ich Raspbian und Lan via VNC und Remotedesktop (Statische IP).


    Internetverbindung via UMTS-Stick funzt auch mittlerweile obwohl dieser nicht als Modem erkannt wird.


    Kann mir jemand dabei helfen?

  • An der Netzwerkconfig habe ich nichts weiter verändert.

    Ist alles auf auto.


    der stick wird als eth1 erkannt und Lankabel als eth0.

    sollte der stick nicht aber als wlan erkannt werden?


    ich habe schon folgende Anleitung versucht:

    Anleitung

    bzw. diese hier:

    Anleitung 2


    Funzt aber auch nicht.


    Zumal mein stick auch nicht als USB0 erkannt wird.


    Oder bin ich komplett auf dem falschem Pfad?


    Danke schon mal.

  • was hat wlan mit umts zu tun?

    ppp0 müsste bei dir erscheinen.


    die erste anleitung sollte gehen, ansonsten hast du noch ein anderes problem. pin vom stick ausgeschaltet?

    das leben ist hart, aber wir müssen da durch.

  • Wenn Du an eth0 gar kein Netzwerk mit Router angeschlossen hast (sondern nur einen Laptop), dann brauchst Du die automatische Netzwerkkonfiuration nicht. Die DHCP Anfrage auf eth0 ist sogar contraproduktiv.


    Entweder vergibst Du dem Pi eine statische Adresse aus einem anderen Netz als dem UMTS Stick und lässt alles "auto" wie DHCP, DNS & CO weg, oder Du trägst für eth0 garnichts ein, dann kommst Du vom Laptop auf den Pi über seine Link Local Adresse.


    Der UMTS Stick wird deshalb als eth1 angezeigt, weil er "automatisch" mit ethernet over usb als router (mit allen üblichen Funktionen) initialisiert wurde. Auf die Konfigurationsseite des UMTS Sticks kommst Du über Port 80 seiner IP Adresse. (z.B. 192.168.0.1:80 bzw. lt. Dox). Dort werden auch die SMS Deines Providers einsehbar.


    Servus !

    RTFM = Read The Factory Manual, oder so

  • die erste anleitung sollte gehen, ansonsten hast du noch ein anderes problem. pin vom stick ausgeschaltet?

    Der Pin zur SIM-Karte ist aus ausgeschaltet.

    Bei der ersten Anleitung ist es so das ich zwar wvdialconf ausführen kann aber nichts passiert:



    unter lsusb kommt:


    Code
    lsusb
    Bus 001 Device 008: ID 12d1:14dc Huawei Technologies Co., Ltd. E33372 LTE/UMTS/GSM HiLink Modem/Networkcard

    Wobei unter der ID wohl eigentlich 12d1:1f01 bzw 12d1:1001 stehen soll.:/


    Modeswitch ist installiert was scheinbar nichts ändert.


    In dieser Anleitung 3 soll man eine config erstellen mit folgendem Inhalt:


    Code
    "/etc/usb_modeswitch.d/12d1:1f01"
    
    DefaultVendor=0x12d1
    DefaultProduct=0x1f01
    MessageContent="55534243123456780000000000000011062000000100000000000000000000"
    NoDriverLoading=1

    nach einem reboot erscheint folgendes unter lsusb:


    Code
    lsusb
    Bus 001 Device 006: ID 12d1:1001 Huawei Technologies Co., Ltd. E161/E169/E620/E800 HSDPA Modem

    Die ID hat sich geändert. Toll.....

    und unter sudo wvdialconf /etc/wvdial.conf kommt:


    danach steht in der config:


    peng.....keine Ahnung was da rein muss:stumm::conf:


    Edit:

    Danach ist der Stick nicht mehr erreichbar.



    Wenn Du an eth0 gar kein Netzwerk mit Router angeschlossen hast (sondern nur einen Laptop), dann brauchst Du die automatische Netzwerkkonfiuration nicht. Die DHCP Anfrage auf eth0 ist sogar contraproduktiv.


    Entweder vergibst Du dem Pi eine statische Adresse aus einem anderen Netz als dem UMTS Stick und lässt alles "auto" wie DHCP, DNS & CO weg, oder Du trägst für eth0 garnichts ein, dann kommst Du vom Laptop auf den Pi über seine Link Local Adresse.


    Ich probiere es aus.






    :danke_ATDE: vielmals.

    Edited once, last by keepfear ().

  • ID 12d1:14dc Huawei Technologies Co., Ltd.

    passt schon, das ist der "HiLink Mode" (E33372 LTE/UMTS/GSM HiLink Modem/Networkcard),

    der am Stick jetzt schon aktiviert ist. Und der Stick wirdüber USB und eth0 auch als Router verbunden. Da brauchst Du nicht nochmal mit wvdial und ppp auf den Stick zugreifen.


    Servus !

    RTFM = Read The Factory Manual, oder so

  • Wenn der Stick z.B. folgende ip hat: 192.168.1.2 und ich meinem PI die ip: 192.168.2.1 gebe dann sind beide in verschiedene Subnetze, richtig?

    Oder müssen beide adressen komplett unterschiedlich sein? Also nicht nur der 3. Block sonder auch die beiden davor?

    Muss ich in der dhpcd.conf dann explizit sagen das eth0 nichts zugewiesen bekommt und in der ifcong dann alles einstellen?


    Ich komme hier nicht richtig zum Zuge. Da wie gesagt ich die Lan-Verbindung verliere sobald der UMTS-Stick angeschlossen wird trotz fester ip im Lan.

  • Wenn der Stick z.B. folgende ip hat: 192.168.1.2 und ich meinem PI die ip: 192.168.2.1 gebe dann sind beide in verschiedene Subnetze, richtig?


    Muss ich in der dhpcd.conf dann explizit sagen das eth0 nichts zugewiesen bekommt und in der ifcong dann alles einstellen?

    Ja, richtig.


    BTW: Wo gibt es die dhpcd.conf und die ifcong?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • im Raspbian Buster.

    OK. Buster habe ich noch nicht.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Grüße,


    es funktioniert jetzt alles.

    Ich muss im Remotedesktop in Win 10 raspberrypi.local als Adresse eingeben.

    Das muss man natürlich erstmal wissen.


    Danke trotzdem an alle.


    Bis dahin