Wie kann der WLAN Client (STA) in den 2,4 GHz mode gezwungen werden?

  • Hallo zusammen,


    ich betreibe einen Raspi 3B+ als Router (AP und STA mode gleichzeitig), Basis ist ein Raspian Stretch light.


    Der STA mode verbindet sich als Client ohne Probleme, sowohl mit einem 5 GHz Access Point als auch mit einem 2,4 GHz Access Point. Der AP, der die gleiche Hardware nutzt, folgt jeweils ohne Probleme und spannt sein Netzwerk auf.

    Ist der STA mode allerdings mit einem 5 GHz Access Point verbunden, so sieht ein reiner 2,4 GHz Client meinen AP erwartungsgemäß nicht.


    Wie kann ich den STA mode beim Aushandeln mit seinem Access Point auf einen 2,4 GHz Betrieb begrenzen? Ich möchte ungern mit iwconfig einen Kanal oder eine Frequenz wie zum Beispiel 2.422G vorgeben, dass sollen STA mode und Access Point selber aushandeln.

  • Ich möchte ungern mit iwconfig einen Kanal oder eine Frequenz wie zum Beispiel 2.422G vorgeben, dass sollen STA mode und Access Point selber aushandeln.

    Dann konfiguriere alle Kanäle des nur 2.4 GHz-Netzes, mit z. B.:

    https://w1.fi/cgit/hostap/plai…icant/wpa_supplicant.conf


    EDIT:


    BTW:

    Code
    update_config=0

    nicht vergessen.


    EDIT 2:


    Wie ist jetzt (d. h. z. Zt.) auf deinem PI3B+ die Ausgabe von:

    Code
    iw event

    , nach dem Du auf deinem PI3B+:

    Code
    wpa_cli scan

    ausgeführt hast? "iw event" musst Du vor dem "wpa_cli scan", starten.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

    Edited 2 times, last by rpi444 ().

  • Zuerst einmal vielen Dank für den Tipp.


    Mit dieser Korrektur der wpa_supplicant.conf

    startet der eigene AP tatsächlich nur mit 2,4 GHz. Allerdings kommt der STA Mode nicht hoch.


    pi@rechner:~$ sudo ifup wlan0

    wpa_supplicant: /sbin/wpa_supplicant daemon failed to start

    run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1

    ifup: failed to bring up wlan0


    Die wpa_cli Abfrage brachte vorher:

    pi@rechner:~$ wpa_cli scan

    Selected interface 'p2p-dev-wlan0'

    OK

    und hinterher:

    pi@rechner:~$ wpa_cli scan

    Failed to connect to non-global ctrl_ifname: (nil) error: No such file or directory


    Hier die Rückmeldung, wenn ich den wpa_supplicant von Hand starte:

    pi@rechner:~$ wpa_supplicant -i wlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf

    Successfully initialized wpa_supplicant

    Line 6: unknown global field 'scan_freq=2412 2417 2422 2427 2432 2437 2442 2447 2452 2457G 2462 2467 2472'.

    Line 6: Invalid configuration line 'scan_freq=2412 2417 2422 2427 2432 2437 2442 2447 2452 2457G 2462 2467 2472'.

    Failed to read or parse configuration '/etc/wpa_supplicant/wpa_supplicant.conf'.

  • Line 6: unknown global field 'scan_freq=2412 2417 2422 2427 2432 2437 2442 2447 2452 2457G 2462 2467 2472'.

    Line 6: Invalid configuration line 'scan_freq=2412 2417 2422 2427 2432 2437 2442 2447 2452 2457G 2462 2467 2472'.

    Failed to read or parse configuration '/etc/wpa_supplicant/wpa_supplicant.conf'

    Versuch mal mit dieser Konfiguration (2 Zeilen) im network-block (statt global).

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Wenn ich die beiden Zeilen in den network-block schiebe, startet der wpa_supplicant wie folgt:

    Code
    Successfully initialized wpa_supplicant
    nl80211: deinit ifname=wlan0 disabled_11b_rates=0
    wlan0: Failed to initialize driver interface

    Allerdings wählt sich der STA wieder in den 5 GHz Bereich ein. Ich habe auch schon probiert, nur einen der beiden Zeilen im globalen Bereich und die zweiten Zeile im network Bereich und vice versa. Beide Versuche enden im 5 GHz Bereich.

  • Wenn ich die beiden Zeilen in den network-block schiebe, startet der wpa_supplicant wie folgt:

    Code
    Successfully initialized wpa_supplicant
    nl80211: deinit ifname=wlan0 disabled_11b_rates=0
    wlan0: Failed to initialize driver interface

    Allerdings wählt sich der STA wieder in den 5 GHz Bereich ein.

    Wie hast Du das 2.4GHz-WLAN des AP konfiguriert (b+g?), wenn sich dein PI als STA mit diesem verbinden soll? Welchen AP hast Du? Versuch mal mit den Zeilen:

    Code
    options brcmfmac roamoff=1
    options brcmfmac p2pon=0

    in der "/etc/modprobe.d/brcmfmac.conf" und danach rebooten.

    Wie sind die Ausgaben von:

    Code
    ps aux | grep -i [w]pa
    systemctl status wpa_supplicant
    iwconfig

    , wenn sich dein PI (als STA) per 5GHz mit dem AP verbunden hat?


    Wenn Du die erforderlichen Kenntnisse hast, dann könntest Du den wpa_supplicant, ohne dbus-Abhängigkeit, aus dem source-code kompilieren und eine eigene (andere) service-unit für den wpa_supplicant erstellen/benutzen.


    BTW: Noch besser wäre vor dem kompilieren, den source-code so zu verändern (patchen), dass 5GHz gar nicht mehr genutzt werden kann (mit dem wpa_supplicant).


    EDIT:


    Welchen Treiber benutzt Du für das wlan-Interface?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

    Edited once, last by rpi444 ().

  • Mit Deinem Tipp hat es jetzt funktioniert.


    In die Konfigurationsdatei des Treibers habe ich beide Zeilen eingefügt und der STA arbeitet jetzt im 2,4 GHz Bereich. Wenn die untere Zeile auskommentiere, funtioniert es ebenfalls.

    Code
    pi@rechner:~$ cat /etc/modprobe.d/brcmfmac.conf
    options brcmfmac roamoff=1
    #options brcmfmac p2pon=0

    Der Vollständigkeit halber habe ich die Einstellungen des wpa_supplicant hier nochmals angegeben, auch hier konnte ich einen Parameter auskommentieren:



    Nochmals vielen Dank.

  • Der Vollständigkeit halber habe ich die Einstellungen des wpa_supplicant hier nochmals angegeben, auch hier konnte ich einen Parameter auskommentieren:


    Code
    ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
    update_config=1
    #update_config=0

    BTW: Warum hast Du "update_config=0" geändert? Willst Du, dass dein System die config des wpa_supplicant ändern/ergänzen kann/darf?


    EDIT:


    BTW: Die Zeile:

    Code
    scan_freq=2412 2417 2422 2427 2432 2437 2442 2447 2452 2457G 2462 2467 22472

    ist aber nicht fehlerfrei. Siehe z. B.: 2457G, 22472

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Du hast recht:

    • Den Fehler in der Zeile scan_freq habe ich korrigiert und
    • update_config habe ich wieder auf 0 gesetzt.

    Untenstehend findet sich zusammengefasst die Lösung.


    Herzlichen Dank.